Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
RonnieJamesDiner

Linedef Interactive Portal Bug [/SOLVED]

Question

Posted (edited)

[SOLVED] I'm a goof, sorry for posting this so hastily. I didn't realize there was already newer versions of GZDoom available (lesson learned, I'll check that first next time). GZDoom version 3.4.1 appears to have fixed this bug. A mod can delete this thread if they'd like. Again, sorry.

 

 

 

 

 

Hello everyone, I've been working on a map that uses the interactive linedef portals (Action Special 156 in Doom 2 UDMF), and I've hit a snag that I don't understand at all. I've created a small, simple demo map that duplicates the scenario and problem (a download link for the demo map is at the bottom of the page).

 

First, I'll attempt to explain/show how the scenario (and the glitch I'm getting) actually works:

bugtest_picture.jpg.f89a8d62ef00a3fa1aee1fa7f3fd530e.jpg

 

 

 

The player begins in sector 1. Linedef with TAG 1 is an interactive portal (Action Special 156) which exits on linedef TAG 2. Now, linedef TAG 2 is also an interactive portal, but exits on linedef TAG 3 - and TAG 3 is initially setup as an interactive portal, but with no exit line. Basically, once the player passes into sector 2, they cannot go back into sector 1, and can only pass into sector 3, and once they pass into sector 3, they cannot leave sector 3.

 

The next step involves getting a key (which the player needs in sector 1), and involves an ACS script. When the key is picked up, it executes a simple script which calls two "Line_SetPortalTarget" actions. The first instance tells linedef TAG 3 to now exit on linedef TAG 2, and the second instance tells linedef TAG 2 to now exit on linedef TAG 1 - essentially, the reverse path is now available to the player, but only once they have acquired the key.

 

Now, this whole process works fine and dandy. But here's the catch...

 

So, you're in sector 3, you've picked up the key and the script has been executed - but then you die! Well, if you've made a save game after picking up the key and calling the script, for some reason, the interactive portals are now broken. You still have the key, but the changes called in the ACS script don't seem to fair so well. First of all, the visual aspect of being able to see between the sectors is gone. Second of all, while the interactive aspect of the portal still *functions* (I say that dubiously), it portals you into the wall in sector 2, where you're now stuck.

 

You can test this scenario (and strange glitch) for yourself in the demo map below. You can run from sector 1 to sector 3 using the interactive portals, grab the key (call the script), and then run back through the portals into sector 1. Restart the map - but this time, after you grab the key, cross the linedef with the autosave, and then step into the red square which will insta-kill you. When you reload at the autosave point, you should see the problem. You'll still have the blue key, but the portals won't work correctly anymore.

 

I'm hoping someone might be able to shed some light on how/why this is occurring. I understand how much simpler my life would be if I just ditched the whole interactive portal gimmick, but it's an aspect to the map I'm working on which I would love to preserve, if possible. Thanks in advance for any help or suggestions. Have a great day!

 

Download: http://www.mediafire.com/file/v9hc4i52s191zii/bugtest_lineportals.wad

 

If this information helps:

 

The map is being built using GZDoomBuilder 2.3, in Doom 2 UDMF format

I've tested the map in GZDoom versions 3.2.43.2.5,  and 3.3.2 - with the same result each time

 

 

Edited by RonnieJamesDiner

Share this post


Link to post

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×