Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Skag1337

How do I fix this acs script?

Recommended Posts

I've just started using acs and I made this script,

Quote

script 1 (void)
{
       Print(s:"Nice shot! I've unlocked a button for you, it'll unlock the sewers!");
       Delay (8);
       Ceiling_RaiseToNearest(6969,30)
}
 

and it gives me this error.

Quote

Line 6 in file "C:\Users\Vladimir\AppData\Local\Temp\SLADE3\SCRIPTS.acs" ...
C:\Users\████████\AppData\Local\Temp\SLADE3\SCRIPTS.acs:6: Missing semicolon.
> } 
> ^

I've tried everything and it wont compile! What do I do?

Share this post


Link to post

I tried that and it gave me this error.

Quote

Line 5 in file "C:\Users\YOUAINTLOOKINGATMYPC\AppData\Local\Temp\SLADE3\SCRIPTS.acs" ...
C:\Users\Vladimir\AppData\Local\Temp\SLADE3\SCRIPTS.acs:5: Function ceiling_raisetonearest is used but not defined.
 

 

Share this post


Link to post

You probably didn't include the script library, then.

At the top, you always have to write this bit:

#include "zcommon.acs"

Otherwise, it won't know what to do and give you that error.

Share this post


Link to post

FWIW, GZDB-BF sports a snippet tool while in the script editor,

which makes it easy to insert some useful code sequences

 

IMQBMTd.png

 

Even better, you can create your own snippets. See the section

Code Snippets in the Refmanual.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×