Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jack8822

Doom Builder 2

Recommended Posts

Hey Everybody!

 

I'm using Doom in hexen format and i seem to be running into an issue that i can't work around...Also don't see many topics on it so far..I'm not sure if this is the correct place for this topic so forgive my noobish ways!

 

Running into a problem with monsters being able to hit through walls despite the areas on the map grid being seperate from each other..Any ideas?

Share this post


Link to post

This sounds like a node builder issue. Try using GZDoom Builder if you haven't already and maybe its version of ZDBSP or ZenNode will build the node properly.

Share this post


Link to post

Ah i see interesting thanks for the input i will give GZDoom Builder a shot and see if i can fix the nodes in the current mapset

Share this post


Link to post

Welcome to Doomworld!

 

This is the appropriate forum for your question, so no worries there. As for your problem, I agree with Aquila, it sounds like a problem with the nodes. Rebuilding the nodes should take care of that.

 

If it doesn't, make sure that there is truly void space between the walls. You can always post a screenshot of the area in question in the editor, too, if it's still an issue.

Share this post


Link to post

Here's a quick look and thanks for the welcome Peg!

 

So the main area where the damage from some hellknights is coming through is from the red sector conflicting to the base sector area with the green..Not sure if the brown sector has the same issue as i have not managed to test that yet

 

How would i go about rebuilding nodes? I'm pretty new to GZDoom Builder at the moment

 

So far the things i have tried are

1.Mode Nodebuilder view and rebuild nodes

 

2.Draw in linedef around the sector

 

3.Edit the linedefs on the sector and flip the arrows to point in and also flip them to point out on the sector ((Tried both))

 

4.Block monsters/sound/everything and make impassable as well

GZScreen at 2018.08.03 18-38-16.921 [R2787].jpg

Share this post


Link to post

In GZDoom Builder you shouldn't be able to flip lines that have void space behind them. Are they double sided? If so, then that's the problem.

If they are being drawn double sided by default, then there's something going on in the editor.

Share this post


Link to post

This area here seems to be the issue with the HK's being active and the lines are double-sided however when removing double-sided I have no clue how to fix the missing texture

GZScreen at 2018.08.03 19-18-09.025 [R2787].jpg

Share this post


Link to post
Posted (edited)

Your map looks like it's way too big and spans the whole grid, which is causing a bug where attacks will go through walls. It has nothing to do with nodes. You're going to need to reduce your map size somehow.

 

EDIT: This is relevant:

 

Edited by Nevander

Share this post


Link to post

Sorry about that i'll see if i can make it a bit more in-depth also i apologize for my terrible map editing skillz

I put the screenies in order

 

in GZ1 you can see where the play starts (The Black sector is a building the player/players enter and to fight your way to GZ2 a teleporter which takes us to GZ3 screenie and you can see in GZ4 screen the zoomed out lava sector it is contained in it's own area so indeed the Knight's would not be activated until the players are seen (Default doom style)

 

However in GZ6 Screenie take note of the top left section of the black sector in the Building where you see some ammo and the mouse arrow pointed..Once the player nears that are they are almost instantly killed by the knights in the sector you saw above posted ((the 4 knights on the brick sector with the teleporter behind them))

 

I hope this helps a bit more

 

1593492857_GZ6at2018_08.0319-38-27.796R2787.jpg.2bb824368c2107542f98b26d62f08325.jpg

 

 

GZ1 at 2018.08.03 19-36-40.609 [R2787].jpg

GZ2 at 2018.08.03 19-36-53.105 [R2787].jpg

GZ3 at 2018.08.03 19-36-59.089 [R2787].jpg

GZ4 at 2018.08.03 19-37-02.625 [R2787].jpg

GZ5 at 2018.08.03 19-37-10.162 [R2787].jpg

Share this post


Link to post

I'd like to start by saying props on clarifying things :D

 

I am not 100% sure, but if I had to guess I'd agree that the problem comes down to the size of your map. Try cutting out the red area,pasting it into a new map and seeing if that fixes it; (or vice versa save a copy and in that copy delete the rest of the map, rebuild nodes [save] and test it) if so the map is likely just too big, which you may be able to fix by moving the areas closer together, but then again that playspace is huge so I also have to wonder if it really needs to be that size. I prolly won't be of much further use, unfortunately, but I hope you can figure it out and wish you the best :)

 

Share this post


Link to post

Thanks Nevander and Fonze and yes i agree i could cut down on the map size..Also the lava area (red sector) is a mario like platform forcing the player to jump across those pillars to the brick section that's why the area was so large to begin with..Also i simply decided to remove those 4 pesky knights since they were somehow the only 4 activated No biggie! and lesson learned

 

Map Size reduce!

Share this post


Link to post

You don't necessarily have to cut down map size, putting the parts closer togther might do the trick already. As the thread @Nevander linked says your map has to fit into a 32767x32767 box. You could try to move your lava area between the other areas, like this:

 

grafik.png.a64acfa8305837a3ecea674b1f4497e0.png

 

Then check if it doesn't exeed the 32767x32767 limit (easiest way is to try to draw a box with those dimensions around it).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×