Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
webcider

HocusDoom giving me trouble in Gzdoom 3.1.5

Recommended Posts

I been trying to look far and wide on the internet for a answer to this crash i am getting from Gzdoom. while playing Hocusdoom mod

 

I am wondering if there is a way to troubleshoot windows registration or ini files. i been reinstalling and deleting multiple times different version of GZdoom.

 

The behavior is this and never fails to crash. in Hocus Pocus doom i pick up the very first Gem. and the engine crashes.

 

Anyone have any idea what is going on here? my gzdoom folder is 3 gb and has many different wads. located its not located on the c: drive and the path is D:\games\gzdoom

system is windows 10 64bit, i tried compatibility modes and that hasn't changed the error.

 

https://forum.zdoom.org/viewtopic.php?t=45804

 

Thanks.

Share this post


Link to post

First of all, do you mean GZDoom 3.1.5, 3.5.1, or something else entirely? 3.5.1 is the newest version of GZDoom as of this writing. 3.1.5 doesn't exist...unless if you really mean 3.1.5 you mean an SVN build in between 3.1 and 3.2 . 

Second of all, have you tried doing a completely fresh install of the latest GZDoom on a computer you never ran GZDoom on before?

Third, what are your system specs? A lot of different computers can run Windows 10 64bit, let alone GZDoom. 

Fourth, what do you mean by "windows registration files"? If you mean .reg , that's a file that adds or deletes information from the Windows Registry, and such a thing should have no business in any GZDoom distribution. As for .ini , that's how GZDoom saves game settings. While it's possible that it might be corrupted or messed up in some fashion, the fact that you apparently deleted it (along with the rest of GZDoom) multiple times makes the file corruption theory a lot less plausible. If you still insist on your GZDoom .ini being "troubleshooted", I recommend zipping it and uploading it here as an attachment.

Fifth, what is the file name of your Hocus Doom PK3? Normally I'd ask what version it is, but this mod seems to go by dates instead of version numbers.


Sixth, try adding +logfile log.txt to the command line associated with the Hocus Doom PK3 (assuming you're using a shortcut, batch, or loading it in the command prompt). After it crashes again, I recommend you zip the resulting log.txt file and upload it as an attachment here.

Seventh, you mentioned that your gzdoom folder has many different wads. How is your gzdoom folder organized?

I'm sorry if all this is overwhelming, but your post was fairly vague. In order to troubleshoot your problem, we'll have to look at the problem thoroughly. 

Share this post


Link to post

Okay i will try my best to answer.

 

1. GZDoom is version 3.5.1.0 and am normally running Modern 64 bit but in this case i also tried Vintage and 32 bit respectively

2. sadly this is my only computer. i tried to start up GZDoom with HocusDoom on a fresh Windows Profile that gave the same error. - only thing i can do is reinstall my computer fresh windows installation complete deletion of C: drive i am not happy for that option but i am warming up to the idea that might be necessary. 

3. So my system specs are as following i5 6600K CPU @ 3.50 Ghz - clocked to 3.50 ghz.32 GB DDR4 ram, GTX 980 4 gb video ram. 256 gb ssd harddrive as system folder, then 8 terabyte data storage on sata2 standard hard drives. GZdoom is installed on a standard hard drive not my system drive.

4. As i am using ZDL.exe version 3.2.2.2 and i read that it stores some ini in my windows appdata folder. this place C:\Users\%userprofile%\AppData\Roaming\Vectec Software "btw this path doesn't work on my system says path doesn't exist, here is my path instead, C:\Users\Usuario\AppData\Roaming\Vectec Software  i was wondering if GZdoom is having similar behavior. i am looking for way to completely clean GZdoom from my system and everything related to registration in regard to windows 10. if that could cause issues.

5. this is the filname i am using and only this hocusdoom-07-28-18.pk3 i am choosing DOOM2.wad and using GZdoom. i tried dragging the Hocusdoom.pk3 file to gzdoom.exe and that starts up hocusdoom as well but still same error.

6. attached a crash report... with logfiles.

7. alright so all my pk3 and wad files are just in root folder. it is not organized at all. i been trying same build of gzdoom from clean folder. structures where i just copy the hocusdoom.pk3 file to the named folder one such example is folder D:\games\doom

 

no its fine i  really want to know whats going on here. as it seems like no one else seems to have this issue..

last i attached my ini file with config setup.

CrashReport.zip

doomfolder.jpg

gzdoom-WebCideR.zip

Share this post


Link to post

Thanks for writing i have decided , to stop thinking about it, it seems to be related to my corrupted windows 10 installation and profile setup. as such i will need reinstall and reconfigure. i am done with this thread... 

 

I did try without ZDL btw. its very strange.. i also tried deleting my antivirus and just running the game. 

 

The game runs fine until i pick up a gem... it seems related to my windows profile perhaps game is using Windows Profile to store scoring. and then that gives problems due to my windows profile being crappy.

 

I will try and run GZdoom from another windows profile. and see if that fixes the issue as i never tried that yet.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×