Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Slade Crashing (Worked Before)

Recommended Posts

Hey guys. As some of you might know by now, I am running Arch Linux x86_64, blah blah blah.


Anyways, I installed SLADE3 from the AUR, and it worked for a while. However, it suddenly now starts crashing with the following error:


[xcb] Unknown sequence number while processing reply
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
slade: xcb_io.c:630: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted (core dumped)


It worked before, and I'm not sure what changed... anything I can do?

Share this post

Link to post

Init code?


I take it thats something I'd need to recompile for... weird that it worked before.


Any help on accomplishing this?

Share this post

Link to post

I'm not sure. I didn't write any of the system code in SLADE. It seems that App::init() in src/Application/App.cpp would be the logical place to try.


Alternatively, try changing the version of SMFL you're using, since apparently this error is specific to XCB and SFML reverted to using Xlib instead.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now