Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
meapineapple

How can I make Zandronum stop changing monitor settings?

Recommended Posts

Whenever I open Zandronum, it changes the monitor's brightness, contrast, etc. settings even in windowed mode. I can focus another window and then go back to the Zandronum window and my monitor settings return to normal, but this is really annoying. How can I make Zandronum stop trying to impose its own monitor settings?

Share this post


Link to post

Are you sure that your video driver is not interfering? Some bloated video drivers have per-game settings for things like brightness, anti-aliasing, etc., on top of what the game actually requests.

 

On my older rig, when Doom3 crashed, it left my desktop washed out and extra bright. The only fix was rebooting, or launching Doom3 again, and immediately shutting it down properly.

Share this post


Link to post

@kb1 I am sure that it is not my video driver interfering. The brightness, contrast, and gamma correction sliders in the graphics options change the monitor settings, not Zandronum's own display settings. Any time Zandronum is opened, even in windowed mode, it changes the monitor settings to match those graphics options. That's fine if Zandronum is being played fullscreen but gets irritating when played in a window. 

Share this post


Link to post

Well, that is offensive. Most ports adjust the RGB values sent to video memory, not change your system's global controls - yikes. I guess you could always adjust Zandronium to "50%", or whatever it takes to match your normal desktop, so its effects amount to nothing being changed. But then Zandronium might end up too bright/dark. Surely there's a better way, especially when running in a window.

 

I'd be interested to hear more about the rationale behind it - this ought to be good.

Share this post


Link to post

Zandronum is based on GZDoom's older OpenGL code which has a flaw its gamma implementation, namely that the gamma alters the display settings of the entire display/system, rather than it being implemented in the renderer itself.

Essentially, you cannot disable it. All you can do is just make sure the gamma level matches your desktop.

Share this post


Link to post

Yeah, matching it to my display settings doesn't work if I use f.lux to change the display settings depending on the time of day...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×