Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Customgtp

Disable smartaim using acs script.

Recommended Posts

So I'm making a Wad and I'm using an older version of beautiful Doom that just has the objects so I can use natural torch lighing. The problem is that players will have a message on screen yelling at the to turn smartaim to 3. I want to fix this buy running a script that instantly sets smart aim to 3. I can't figure this out because it keeps telling me I have the wrong identifier. Here is what I am trying to put into my script.

 

script 11 (void)
{
    setcvar (v; Sv_smartaim, 3)    
}

 

The V is a placeholder as I could not find anywhere what to put there in that.

Share this post


Link to post

I don't think it is possible to set built in CVARs with ACS, only read them. You can only do this with CVARs added from a mod.

Share this post


Link to post

https://zdoom.org/wiki/SetCVar_(ACS)

That V doesn't belong there. Furthermore, the CVar being set is a string, so it should be in quotes, and you need a semicolon, like this:

SetCVar ("SV_SmartAim", 3);

This will still not work, though, because as Nevander and the page I linked said, you can't set built-in CVars, only user-defined ones. That is why Beautiful Doom is displaying that message rather than setting it for them.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×