Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ketmar

k8vavoom: no good thing ever dies!

Recommended Posts

Makes sense..

I do recall there being a player bobbing motion when the grab/pickup took place in vanilla.

I notice this doesn't happen in k8vavoom though. ~ even though he won't grab the BFG.

 

Oh btw, sorry not to de-rail, but is there a -turbo parameter in k8vavoom?

 

Edited by Mr.Rocket

Share this post


Link to post
13 minutes ago, Mr.Rocket said:

is there a -turbo parameter in k8vavoom?

nope. but you can play with "cl_forwardspeed", "cl_backspeed" and "cl_sidespeed" cvars. and some other cvars you may find in "p_player_input.cpp". just note that all those cvars are persistent, so new values will be stored in config. maybe i should change that...

 

17 minutes ago, Mr.Rocket said:

sorry not to de-rail

it's not a derailing, this is Official Thread, so you can ask any k8vavoom questions here. or any questions you like, just add "and how to do that in k8vavoom" at the end. ;-)

Share this post


Link to post
5 minutes ago, ketmar said:

or any questions you like, just add "and how to do that in k8vavoom" at the end. ;-)

I lol'd at that. :P

Share this post


Link to post

also, almost nobody knows that, but you can revert any cvar to its default value with "cvar_reset varname" console command. also, pressing "backspace" in options menu will reset the option to default. and "?" will print the cvar for the current menu item into the console.

Share this post


Link to post
1 hour ago, ketmar said:

also, pressing "backspace" in options menu will reset the option to default

 

Does you ask if you are sure, with Y-or-N and whatnot?

Share this post


Link to post
50 minutes ago, Gustavo6046 said:

Does you ask if you are sure, with Y-or-N and whatnot?

it's not something destructive, and it's quite hard to press "backspace" in menu by accident (nobody found it by accident yet ;-), so i see no reason in excessive prompts. i strongly believe that users are not as dumb as modern software tends to assume.

 

p.s.: more Pro-Tips(tm): pressing "DEL" twice in load/save dialog deletes a save.

Share this post


Link to post

btw, thank you for the cvar info above in your previous post(s).

~ I still wasn't able to turbo/speed into the transparent-solid texture hard enough to grab the BFG lol.

Share this post


Link to post

this trick is highly framerate-dependent, and generally is not guaranteed to work at all. as i wrote (or assumed ;-) in the OP, k8vavoom is "Doom by the spirit, not by the letter". of course, one can argue that supporting all vanilla quirks is necessary for keeping the spirit, but i cannot agree (and it is generally not possible anyway, because of the freestep nature of the engine).

 

i mean, don't try too hard, it may simply won't work due to engine differences. generally, most movement tricks in k8vavoom are different and/or don't work (except straferunning). this is something i won't going to "fix", it's just how the engine works.

Share this post


Link to post

also, useless fact: there are more than 800 cvars in the engine. yes, i am impressed too.

Share this post


Link to post

I have a problem with blinking sectors and other elements on the screen (except HUD). It can even be seen on pause. My settings is on default. When I select as the main integrated graphics card (Intel (R) HD Graphics) instead of discrete (NVIDIA GeForce GT 720M), the problem disappears. Nothing similar was observed with other source ports.

Share this post


Link to post

i have no idea. i don't have the hardware with dual GPUs to test it, nor i'm doing anything unusual in graphics code (and don't even have Windows). thanks for you report, but sorry, i'm afraid that i can't help here. my GPU is GT720 too, and i see no problems with it. so it may be something with GPU switching.

Share this post


Link to post

I happen to have rechecked how k8vavoom has been doing recently, and I report no rendering issues for me on a GTX 950 either.

 

If it goes away when switching to integrated, it might be a driver issue.

Share this post


Link to post
16 hours ago, seed said:

I happen to have rechecked how k8vavoom has been doing recently

come back, we have such sights to show you...

Share this post


Link to post

we're going to break your Doom even more!

 

added (optional, of course, but turned on by default) extra friction to non-moving (i.e. when no movement keys pressed) player mobj, so it will stop faster. because i am really tired of those small and well-oiled wheels on Doomguy boots.

Share this post


Link to post
38 minutes ago, ketmar said:

come back, we have such sights to show you...

 

After the stutter stops, sure :p .

 

No like seriously, for some reason VSync or not, it's not very smooth for me, it's like it either has frame pacing issues or just random frame drops. It's also the only port doing this on my end. I figured it might have been the result of not running in fullscreen, but even in exclusive FS this odd stutter is still there, even with all fancy stuff disabled.

Share this post


Link to post
6 minutes ago, seed said:

After the stutter stops, sure :p .

i really wish to lay my hands on your PC... ;-) and i also need to implement a profiler i planned to write years ago.

 

but you still can use k8vavoom to make k00l screenshots for doom pics thread! ;-)

Share this post


Link to post
1 hour ago, seed said:

it's like it either has frame pacing issues or just random frame drops

btw. can you try to run k8vavoom with "-nosound" "-nojoy", plz? and turn on sprite precaching in video options? it may help me to narrow the field i have to dig to find that bug-bastard. ;-)

Share this post


Link to post

If it helps, I get a (little bit of a flash) when I try to move the slider for bloom sample scaledown.

What I mean by try is that the slider doesn't move but the numeric value changes.

Edited by Mr.Rocket

Share this post


Link to post
11 minutes ago, Mr.Rocket said:

If it helps, I get a (little bit of a flash) when I try to move the slider for bloom sample scaledown

yeah, it is expected. the exposure is collected and blurred for several frames, and when you changing that option, the exposure resets to zero (along with some other accumulators), and the bloom needs some time to readjust itself.

 

as for slider doesn't move -- yeah, the max value is quite huge, so there are simply not enough UI positions to represent all values. ;-)

Share this post


Link to post
1 hour ago, ketmar said:

and turn on sprite precaching in video options?

 

Started fresh, and of all the suggestions, this seems to have fixed the microstutter for good. Most curious, why is precaching making such a different here? Not even GZDoom requires me to do it at all.

 

Two precaching options are turned on by default, but not the other two below them. Turned those on too and that seems to have fixed it. But this reveals another issue, which I had a feeling was buried under the microstuttering, related to mouse input. Something's not right there, or elsewhere if not, it seems the mouse may be skipping frames or something.

 

With Adaptive VSync I can feel it a bit, without any VSync it's hard to spot but I guess I just have a paw hand for these things, and with normal VSync when trying to make precise shots, with small movements, I can really see it. And this is how I perceive it, it's like it... "jumps" a frame when turning around.

 

I also noticed that the stronger the VSync is, the slower mouse turning gets, as if its resolution decreases (not to be confused with input lag, this is different). From no VSync to full VSync, it's like the turning speed gets almost halved, dang.

 

And uh, why is Adaptive capping my frame to 65, of all things? Shouldn't it cap at the screen's refresh rate and just disengage when the frame goes below 60?

Share this post


Link to post
14 minutes ago, seed said:

Started fresh, and of all the suggestions, this seems to have fixed the microstutter for good. Most curious, why is precaching making such a different here? Not even GZDoom requires me to do it at all.

it still may be sound or joystick code, tho.

 

15 minutes ago, seed said:

I also noticed that the stronger the VSync is, the slower mouse turning gets, as if its resolution decreases

this is strange. the engine basically simply changes the yaw, it should not depend of framerate. i am using screen mouse position and mouse warping, not relative mouse movement, tho, so it may be because windows does something strange with mouse position updates.

 

17 minutes ago, seed said:

And uh, why is Adaptive capping my frame to 65, of all things?

here, i haven't the slightest idea. it's not even close to default cap, which is 90.

 

anyway, thank you for testing, now i have something interesting to think about... ;-)

Share this post


Link to post
11 minutes ago, ketmar said:

it still may be sound or joystick code, tho.

 

this is strange. the engine basically simply changes the yaw, it should not depend of framerate. i am using screen mouse position and mouse warping, not relative mouse movement, tho, so it may be because windows does something strange with mouse position updates.

 

here, i haven't the slightest idea. it's not even close to default cap, which is 90.

 

anyway, thank you for testing, now i have something interesting to think about... ;-)

 

Not sure if it might still be those two, I tried with both sound and no sound, and the remaining precaching settings seem to have been the solution, but if you want to fiddle with stuff around more, hey, don't make me stop you, I like breaking things too until they start working again ;) .

 

The mouse turning thing is real as earth, I'm certain of it. With VSync the turning speed is way slower than without (Mouse look turned on, horizontal on, the rest off, if it matters). Scaled or Real FS makes no difference, same for the perceived skipping when turning.

 

So my guess was right that it should not be 65. Yet it seems to be according to the frame counter, and I do believe it is accurate since I can see some tearing when moving around.

Share this post


Link to post
18 minutes ago, seed said:

The mouse turning thing is real as earth, I'm certain of it.

yeah, i do believe that the mouse is broken. i was just thinking out loudly. using mouse coordinate queries and warping is quite old-fashioned method, and windows may simply don't expect it to be used in games anymore, and even try to "help" games by applying some throttling, thinking that it may help direct mouse queries. yet this is the only method that works good on my system (and i can't fine-tune other methods without live windows too). sigh.

 

23 minutes ago, seed said:

Yet it seems to be according to the frame counter, and I do believe it is accurate

yeah, it should be. it may be off by one frame, i think, but not by five. i am playing with adaptive vsync myself, and it never goes above 60, sometimes dropping to 40-50 when the renderer struggles with some scene. and with non-adaptive it properly drops to 30 in such cases. so this is definetely Yet Another Strange Thing.

Share this post


Link to post
42 minutes ago, ketmar said:

yeah, i do believe that the mouse is broken. i was just thinking out loudly. using mouse coordinate queries and warping is quite old-fashioned method, and windows may simply don't expect it to be used in games anymore, and even try to "help" games by applying some throttling, thinking that it may help direct mouse queries. yet this is the only method that works good on my system (and i can't fine-tune other methods without live windows too). sigh.

 

yeah, it should be. it may be off by one frame, i think, but not by five. i am playing with adaptive vsync myself, and it never goes above 60, sometimes dropping to 40-50 when the renderer struggles with some scene. and with non-adaptive it properly drops to 30 in such cases. so this is definetely Yet Another Strange Thing.

 

Well, yeah, that does sound pretty bad then. But, if you can get another implementation going I could provide some feedback for it, since I really am one of those nitpicky folks around here when it comes to input, am I not 😉.

 

As for VSync, got no idea either, but I wonder if also enabling VSync in addition to Adaptive changes anything, didn't think of re-enabling that afterwards. I just turned of VSync and enabled Adaptive below it, and bam, tearing and 65 frames.

Share this post


Link to post
19 minutes ago, seed said:

I just turned of VSync and enabled Adaptive below it, and bam, tearing and 65 frames.

ah! "adaptive" is modifier for vsync itself, if you'll turn off vsync, "adaptive" means nothing then. ;-) sure, it is better to have a combobox with 3 options instead, but it Historically Happened that adaptive setting is a separate cvar, hence it should be like that in the menu.

 

p.s.: i'll add a warning to adaptive option help. people never read help texts (especially long ones), but why not... ;-)

Share this post


Link to post
6 minutes ago, ketmar said:

ah! "adaptive" is modifier for vsync itself, if you'll turn off vsync, "adaptive" means nothing then. ;-) sure, it is better to have a combobox with 3 options instead, but it Historically Happened that adaptive setting is a separate cvar, hence it should be like that in the menu.

 

p.s.: i'll add a warning to adaptive option help. people never read help texts (especially long ones), but why not... ;-)

 

Well that's silly then, but explains why both are enabled by default too.

 

In this case, what does Adaptive even do?

Share this post


Link to post
2 minutes ago, seed said:

In this case, what does Adaptive even do?

it modifies vsync mode. if you will turn off vsync, there is nothing to modify. if you will turn it on, turning on adaptive will use adaptive vsync, and turning it off will use normal vsync.

 

i.e. it works like this:

if vsync-is-on:
  if adaptive-vsync-is-on:
    use-adaptive-vsync
  else
    use-normal-vsync

 

Share this post


Link to post

Then this doesn't explain something else - if the default cap is 90, why is it 65 with it?

 

Or... maybe it's 65 without it too? Gonna recheck tomorrow morning if the framerate changed with it turned off as well.

Share this post


Link to post
5 minutes ago, seed said:

Then this doesn't explain something else - if the default cap is 90, why is it 65 with it?

maybe that's maximum of what your PC can do at the given renderer. try to select another renderer (non-lightmapped), and turn off the shadows -- it may bump FPS. lightmapped renderer uses 3 or 4 texture layers, so it is quite demanding on bandwidth.

Share this post


Link to post
1 minute ago, ketmar said:

maybe that's maximum of what your PC can do at the given renderer. try to select another renderer (non-lightmapped), and turn off the shadows -- it may bump FPS. lightmapped renderer uses 3 or 4 texture layers, so it is quite demanding on bandwidth.

 

Wait what, there's more renderers?

 

Where??

Share this post


Link to post
Guest
This topic is now closed to further replies.
×