Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
chowbar

Uncapped framerate doesn't seem to work

Recommended Posts

Hey guys, I downloaded Eternity recently and I've been really liking it. Might be my second favorite source port after PrBoom+. Unfortunately, I've noticed some weird slowdown with Eternity and the uncapped framerate option doesn't seem to work for me. I played through E2M1 with the uncapped option turned on and i never got better than 35 fps. I even occasionally got fps near the low 30s too. Now my laptop isn't a powerhouse, but when I played through E2M1 with GZDoom 3.6 with lights and brightmaps, I never got less than 100 fps. Am I going crazy?

 

For reference, here's my potato laptop's specs:

Intel(R) Core(TM) i3-3227U CPU @ 1.90GHz
Intel HD Graphics 4000
6 GB of RAM
Windows 10 64-Bit

 

And I just checked to make sure my graphics drivers are up to date. 

Share this post


Link to post

Make sure to also turn on interpolation. Also what is telling you that you have 35FPS (as not going past means your FPS is still capped, and it is physically impossible for the setting to be ignored)?

30f505dd0c.png

Edited by Edward850

Share this post


Link to post
1 hour ago, Edward850 said:

Make sure to also turn on interpolation. Also what is telling you that you have 35FPS (as not going past means your FPS is still capped, and it is physically impossible for the setting to be ignored)?

 

Ok I opened up Eternity and both uncapped framerate and interpolation were on and I'm still getting 35 frames. 

I'm using the console command v_ticker 3 to get that frame count. 

Share this post


Link to post

V_ticker is for the physical playsim ticrate, which will always be at 35 (you can't speed up dooms tic rate without affecting physics and animations).

You want d_drawfps which will show you the visual framerate. Plus, well, compare interpolation on and off, you should be able to see the difference outright. 

Edited by Edward850

Share this post


Link to post
26 minutes ago, Edward850 said:

V_ticker is for the physical playsim ticrate, which will of course always be at 35. You want d_drawfps which will show you the framerate. 

 

Ok gotcha. I guess uncapped framerate was working all along since using d_drawfps I saw 36FPS appear a couple times during E1M1 and E1M2. I made the screen size way small and I saw 38 FPS appear too (I have Eternity set at fullscreen which is 1366x768 for me).

 

However, when I ran through those maps, I was still seeing an fps that hovered around 35 and sometimes in the low 30s.

My laptop can't be that bad if it runs GLBoom+ and GZDoom without a hitch right?

Edited by chowbar : Added GLBoom+ in addition to GZDoom

Share this post


Link to post

On my old WinXP laptop uncapped fps is 79-93, depends on map. I can say it's enough for software renderer. However i prefer capped framerate and without interpolation.

Share this post


Link to post

If i set 1024x768 resolution, max fps is 33-34 (yes, uncapped). That's because software renderer is not accelerated by video card, so it uses mostly CPU. Anyway i don't see any reason to use higher than 640x480 resolution in Doom.

Share this post


Link to post
6 hours ago, Rimantas said:

If i set 1024x768 resolution, max fps is 33-34 (yes, uncapped). That's because software renderer is not accelerated by video card, so it uses mostly CPU. Anyway i don't see any reason to use higher than 640x480 resolution in Doom.

 

Yeah I guess you're right. I just ran Eternity in 640x480 (the same resolution I use for Crispy Doom) and I never got an FPS less than 100. Now Eternity runs smooth as silk. 

Share this post


Link to post

@chowbar Can you go to the last page of the video options and check that Video Drive is set to SDL GL2D? If it isn't, set it to that then restart Eternity, then retest at 1366x768.

Also make sure your laptop is plugged in and isn't in any sort of power saving mode (Windows 10 has additional power saving options you'll find if you select the battery toolbar icon). Eternity naturally uses software rendering and requires the CPU to be unrestricted for best performance.

Share this post


Link to post
4 hours ago, Edward850 said:

@chowbar Can you go to the last page of the video options and check that Video Drive is set to SDL GL2D? If it isn't, set it to that then restart Eternity, then retest at 1366x768.

Also make sure your laptop is plugged in and isn't in any sort of power saving mode (Windows 10 has additional power saving options you'll find if you select the battery toolbar icon). Eternity naturally uses software rendering and requires the CPU to be unrestricted for best performance.

 

Ok so I set my laptop to power mode and plugged it in and it turns out Eternity was already set to SDL GL2D.

When I started it at 640x480, I rarely got less than 100FPS playing the Ultimate Doom demos, but once I changed the resolution to 1366x768, I got an FPS that reached no higher than 40FPS. 

Share this post


Link to post

That's... really crazy. A modern 2Ghz CPU should be enough for that resolution.

Wild thought, what happens if you set the resolution to 1360x768?

Share this post


Link to post
6 minutes ago, Edward850 said:

That's... really crazy. A modern 2Ghz CPU should be enough for that resolution.

Wild thought, what happens if you set the resolution to 1360x768?

 

Yeah I know right? Never had this problem with PrBoom+, ZDoom (and its derivatives), and Crispy.

When I set the res to 1360x768, I got an FPS in the mid to high 40s playing the first UD demo.

 

Tbh, I don't mind playing Eternity at 640x480 if it means I get the extra FPS. If anything it reminds me I'm playing Doom with a period correct aspect ratio. 

Share this post


Link to post
23 hours ago, Edward850 said:

That's... really crazy. A modern 2Ghz CPU should be enough for that resolution.

Wild thought, what happens if you set the resolution to 1360x768?

Clever!

 

@chowbar Also, try 1368x768. In fact, I'd suggest a series of tests. Try each of these separately (change one setting, play the game and measure FPS, then quit, and start over, trying a different setting). My theory is that, if you're laptop is not a complete dog, then there's probably one single problem giving you poor performance.

 

In general, higher resolutions should negatively affect performance, but it's not always a linear progression. In fact, cache issues can cause a higher resolution to play faster than a lower resolution, in specific cases.

 

If you're using VSync, some "aliasing" between your monitor refresh rate, and Doom's 35fps rate could be causing your system to fail to take advantage of interpolation.

 

Here's a few things to hopefully help narrow down the issue:

  • Toggle VSync, if available.
  • Try windowed mode in various resolutions, as well as full screen.
  • Try some original Doom IWAD maps, as well as a complex custom map.
  • Make sure you're not loading up the console, or filling a huge log file.
  • Make sure you don't have background programs running, killing the CPU.

 

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×