Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
portalsam

Custom Monster Sprite

Question

Uhh so I'm trying to get my custom monster to work but it shows up as a missing texture. The sprite shows up in DB2, but not in-game. I'm pretty sure that the decorate is fine but I have no idea about the textures. I attached an image, as well as a reduced version of my wad. image.png.8106412bb40ff7053daf2bb0d02bc4ed.png

tompigtestreduced.zip

Share this post


Link to post

10 answers to this question

Recommended Posts

  • 2

In your DECORATE, you refer to frames A through U, but you only include frames A and B. Furthermore, you have no angles on your sprite names. Your sprite names need to be in the form TOM0A0, where TOM0 is the sprite name, A is the frame, and 0 is the angle. Angle 0 means that the sprite will look the same from all directions. If you want it to look different from different directions, use angles 1 - 8.

https://zdoom.org/wiki/Sprite

 

If the page I linked doesn't explain it well enough, look at the sprites in the iwads (doom.wad or doom2.wad) to see examples of how it works. Just be careful to make no changes to the iwads.

Share this post


Link to post
  • 0
2 hours ago, Empyre said:

In your DECORATE, you refer to frames A through U, but you only include frames A and B. Furthermore, you have no angles on your sprite names. Your sprite names need to be in the form TOM0A0, where TOM0 is the sprite name, A is the frame, and 0 is the angle. Angle 0 means that the sprite will look the same from all directions. If you want it to look different from different directions, use angles 1 - 8.

https://zdoom.org/wiki/Sprite

 

If the page I linked doesn't explain it well enough, look at the sprites in the iwads (doom.wad or doom2.wad) to see examples of how it works. Just be careful to make no changes to the iwads.

Thanks for this info, this got a few things working. However, now the sprite is invisible. I don't know if I'm being dumb or something is happening. I've tried many combinations of letters and numbers and it either crashes the game or remains invisible. Again wad is attached.

tompigtestreduced.zip

Share this post


Link to post
  • 0

I assume the reason it is invisible, is because you didn't change offsets of the sprites. The way to do it, is by choosing all sprites simultaneously, after that, in the right window, you will see 2 options: Convert Gfx to and Modify Gfx offsets, pick up the second one. After that, you have to choose "monsters" in the automatic offsets and then press ok to release your fluffy demon right into the world of mortals. Also, you can do it manually, by dragging sprites into the center of the cross (to see it, you have to enable "sprite" view, it's in the bottom of the sprite screen, by default it is set as "Auto", so you gotta change that). Well, and here you go, that should make everything work (theoretically) as smooth as a butter.

Share this post


Link to post
  • 0
9 hours ago, BioRenegat said:

I assume the reason it is invisible, is because you didn't change offsets of the sprites. The way to do it, is by choosing all sprites simultaneously, after that, in the right window, you will see 2 options: Convert Gfx to and Modify Gfx offsets, pick up the second one. After that, you have to choose "monsters" in the automatic offsets and then press ok to release your fluffy demon right into the world of mortals. Also, you can do it manually, by dragging sprites into the center of the cross (to see it, you have to enable "sprite" view, it's in the bottom of the sprite screen, by default it is set as "Auto", so you gotta change that). Well, and here you go, that should make everything work (theoretically) as smooth as a butter.

Thanks! The sprites are working fine now.

Share this post


Link to post
  • 0

ACTOR Anubis : DoomImp replaces Anubis //3001
{
    spawnid 5
    obituary "so was killed by an Anubis."
    hitobituary "so was slashed by an Anubis."
    health 60 gibhealth 120
    radius 20
    height 56
    mass 100
    speed 8
    painchance 200
    seesound "imp/sight"
    painsound "imp/pain"
    deathsound "imp/death"
    activesound "imp/active"
    MONSTER
    +FLOORCLIP +MISSILEMORE
    MeleeDamage 9
    states
    {
    Spawn:
        ANBS AB 10 A_Look
        loop
    See:
        ANBS AABBCCDD 3 A_Chase
        loop
    Melee:
        ANBS EF 8 A_FaceTarget
        ANBS G 0 A_PlaySound("imp/clawattack")
        ANBS G 6 A_MeleeAttack
        goto See
    Missile:
        ANBS EF 5 A_FaceTarget
        ANBS G 5 A_CustomMissile("DoomImpBall_", 32, 8, Random(-2, 2), 0)
        goto See
    Pain:
        ANBS J 1
        ANBS J 2
        ANBS J 3
        ANBS J 4
        ANBS J 2 A_Pain
        goto See
    Death:
        NULL A 0 A_KillMaster
        ANBS L 1
        ANBS L 2
        ANBS L 3 A_Scream
        ANBS L 4
        ANBS L 5
        ANBS L 6
        ANBS L 7 A_NoBlocking
        ANBS L -1
        stop
    XDeath:
        NULL A 0 A_KillMaster
        NULL A 0 A_SpawnDebris("rGib5",0) //(Imp hand [skin brown])
        NULL A 0 A_SpawnDebris("rGib5",0) //(Imp hand [skin brown])
        NULL A 0 A_SpawnDebris("rGib3",0) //(eyeball)
        NULL A 0 A_SpawnDebris("rGib3",0) //(eyeball)
        NULL A 0 A_SpawnDebris("rGib19",0) //(brain)
        NULL A 0 A_SpawnItem("rxGibGenerator_s",0,0,0,0)
        NULL A 0 A_SpawnItem("rxGibGenerator_s",0,0,0,0)
        NULL A 0 A_SpawnItem("rxGibGenerator_s",0,0,0,0)
        NULL A 0 A_SpawnItem("rxGibGenerator_s",0,0,0,0)
//        ANBS M 1
//        ANBS M 2 A_XScream
//        ANBS M 3
//        ANBS M 4 A_NoBlocking
//        ANBS M 5
//      ANBS M 6
//        ANBS M -1
        Stop
    Burn: 
        NULL A 0 A_KillMaster
        NULL A 0 A_PlaySound("imp/death")
        NULL A 0 A_CustomMissile("Human_Burn", 0, 0, 0)
        Stop
    Raise:
        ANBS ML 8
        ANBS KJI 6
        goto See
    }
}

Share this post


Link to post
  • 0

Gez already answered this in another thread. The actor is trying to replace itself. You need replaces DoomImp instead of replaces Anubis.

Share this post


Link to post
  • 0
23 hours ago, Empyre said:

Gez already answered this in another thread. The actor is trying to replace itself. You need replaces DoomImp instead of replaces Anubis.

thanks

 

Share this post


Link to post
  • 0

Sorry that i write a lot but i have a lot of question . Now what is the problem in missile goto see  ?

 

   spawn :
        ANBS A 10 A_LOOK
        loop
    see :
        ANBS AABBCCDD 3 A_CHASE
        loop
    melee :
        ANBS EF  8
        ANBS GH  0  A_PLAYSOUND
        ANBS I   6  A_MELEEATTACK
        goto see
    missile :
        ANBS EF  8 
        ANBS GHI 6  A_CUSTOMMISSILE
        goto See
    pain :
        ANBS I 2
        ANBS I 2 A_PAIN
        goto see

Share this post


Link to post
  • 0

it looks like you are using A_CustomMissile without telling it what missile to shoot, and you are also using A_PlaySound without telling it what sound to play (which will default to the pistol sound). If you are using the MissileType property to tell what missile to shoot, you should use A_MissileAttack, instead of A_CustomMissile. That is the old, outdated way to do it, but it does still work. Since you are using A_MeleeAttack (also outdated), you can use the MeleeSound property to tell that attack what sound to play, instead of using A_PlaySound.

 

The only thing "wrong" I see about that goto See is you have a capital S only there, but I don't think that matters.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×