Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Dragonfly

[FINAL RELEASE] Eviternity

Recommended Posts

Both pistol start and continuous are supported. It was designed with continuous in mind but pistol starting is completely possible, amd was how the maps were tested when they were first built.

 

Gl/PrBoom don't have any particles at all, since they're made using ACS, which isn't supported in those ports. All differences between ports are cosmetic only, so the gameplay is very much the same. :)

Share this post


Link to post
4 minutes ago, Dominic Tarason said:

these levels do a great job at teaching Doom fundamentals

 

I loved that angle of the write-up, much appreciated. Big thanks for giving us some media attention! (and for the texture shout-out in the comments :)

Share this post


Link to post
3 hours ago, waverider said:

Just found out that there seems to be no way to get proper pistol start to work in GZDoom unless I'm willing to try unofficial  mods

 

Just type IDCLEV** (** being the map number) or open the console and type "map *" (without quotes) to restart the current map. You can also bind a key for it through the console if you like, like this:

 

bind r "map *"

Share this post


Link to post

I didn't test it for mod compatibility - Though honestly I'd suggest you try and find out ;)

Share this post


Link to post
1 minute ago, Dragonfly said:

I didn't test it for mod compatibility - Though honestly I'd suggest you try and find out ;)

I would love to, I just discovered this wonderful community because of a video i saw of brutal doom and im digging the game alot, its so cool that people create their own games and everybody can play them, i just wish i had a computer since mine broke like 3 weeks ago. im gonna buy one soon but cant wait to try this.

Share this post


Link to post

hey. dumb question, is this vanilla and crispy doom compatible? been playing some old maps on my pi 0

EDIT:

just skipped to pg.1 - 

my take is it's not doable.

 

Share this post


Link to post
2 hours ago, zaszthedestroyer said:

hey. dumb question, is this vanilla and crispy doom compatible? been playing some old maps on my pi 0

EDIT:

just skipped to pg.1 - 

my take is it's not doable.

 

 

I suspect something like Map26 would pretty much melt a vanilla compatible source-port.  The opening view alone contains over 13,000 visible linedefs.

Share this post


Link to post

This looks AWESOME, but when i drag the wad to GZDoom it says "Script error, "Eviternity.wad:ZSCRIPT" line 3:
Version mismatch. 3.5.0 expected but only 3.3.0 supported" What is it?

Share this post


Link to post
1 hour ago, D88M said:

This looks AWESOME, but when i drag the wad to GZDoom it says "Script error, "Eviternity.wad:ZSCRIPT" line 3:
Version mismatch. 3.5.0 expected but only 3.3.0 supported" What is it?

Your GZDoom is too old. Update it.

Share this post


Link to post
17 hours ago, Dragonfly said:

 

  Hide contents

@Malice I'll answer that question later on when I have access to SLADE. I can't remember the lump names from the top of my head.

 

Alright. I will await your reply with the insight I seek.

Share this post


Link to post

Just downloaded Eviternity from idgames, and the "MENUDEF" lump is named "MENUDEF_" instead, and GZDoom 3.7.2 doesn't recognize it as a menu lump. Renaming it to "MENUDEF" with Slade enables the weather toggle options menu.

Share this post


Link to post
19 hours ago, boris said:

Your GZDoom is too old. Update it.

I just did, and when i drag the WAD to the "GZDoom.exe", the loading screen appears but then i get this: 
"Unsupported OpenGL version.
At least OpenGL 3.3 is required to run GZDoom.
For older versions of OpenGL please download the vintage build of GZDoom."

 

Do i have to update my drivers? I have Windows 7 64 bits.

Share this post


Link to post
27 minutes ago, D88M said:

I just did, and when i drag the WAD to the "GZDoom.exe", the loading screen appears but then i get this: 
"Unsupported OpenGL version.
At least OpenGL 3.3 is required to run GZDoom.
For older versions of OpenGL please download the vintage build of GZDoom."

 

Do i have to update my drivers? I have Windows 7 64 bits.

 

Probably not a bad idea to keep your drivers updated, although it could be your GPU is just too old to run the modern versions of GZDoom.  If that's the case, the vintage version of GZDoom (which is an up-to-date version of GZDoom with the older version of the renderer) might help.  You can grab it at the ZDoom downloads page.

Share this post


Link to post

Eviternity crashes EE's latest build with ACS VM errors. Not sure if that is something to report to Eviternity or EE.

Share this post


Link to post

I think its an EE issue, cause I went with an earlier devbuild from January, and it works fine.

 

Edit: Just tried the feb 11 release, and it works fine for me, too. Might be fixed?

Edited by StoneMason

Share this post


Link to post

Is anyone else getting a crash to desktop after exiting Map05 "Demon" and trying to load Map06 "Reconnect" with GZDoom 3.7.2?

I am getting an error saying "Code: C0000005 (Access violation - tried to read address 00000000000097C7) / Address: 000000013F67C63A)".

 

Crash does not happen when starting ep.2 via the menu, so it must be something about the transition from the first episode to the second.

Edited by NightFright

Share this post


Link to post
5 hours ago, kristus said:

Eviternity crashes EE's latest build with ACS VM errors. Not sure if that is something to report to Eviternity or EE.

 

Paging @Altazimuth who may be able to advise.

 

 

1 hour ago, NightFright said:

Is anyone else getting a crash to desktop after exiting Map05 "Demon" and trying to load Map06 "Reconnect" with GZDoom 3.7.2?

I am getting an error saying "Code: C0000005 (Access violation - tried to read address 00000000000097C7) / Address: 000000013F67C63A)".

 

Crash does not happen when starting ep.2 via the menu, so it must be something about the transition from the first episode to the second.

 

I never experienced this when testing. I'd advise getting a crash report and sending it to the ZDoom developers on their forums.

Share this post


Link to post
7 hours ago, kristus said:

Eviternity crashes EE's latest build with ACS VM errors. Not sure if that is something to report to Eviternity or EE.

Actually crashes? Where? I've seen ACSVM errors that don't crash the engine (expected, since it uses unknown opcodes), but no crashes. There was a crashing issue in any map with a sky transfer as well that I got printz to fix.

Share this post


Link to post
Just now, NightFright said:

MENUDEF in GZDoom probably doesn't work since it's named MENUDEF_ in the pwad. The menu also doesn't show for me.

 

Thanks for the report, though this is a known bug and was reported just a few posts back. :)

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×