Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MsKaye

SIGIL - New Romero megawad [released!]

Recommended Posts

I've been having trouble getting Sigil to work on GZDoom 4.1.3x64. It runs and plays just fine, except switches and doors don't seem to work. I noticed it in E5M1, right after killing a caco that rises from a lava pit, you have a door to your left. That didn't open when trying to use it or shoot it. Then I dropped to the lava and the switches that I guess should lower the platforms for you to get back up also didn't work. Has anyone had this problem? Do you guys know how to fix it? I tried running the wad on GZDoom 3.7.2x64 too but the problem's still there. Thank you in advance.

Don't know if this is the best place to post this, sorry if it's not.

Share this post


Link to post
13 hours ago, eulo said:

I love Onemandoom's review of Sigil, it's easily the best read so far. I didn't notice the secrets in E5M1 are probably referring to the main areas of E5M8. Also he emphasizes how tight the design is, and how every level is thematic. I wish we had more mapsets with such concept. I mean where every level has a different visual and/or play narrative.

 

That was a really fun read, thanks for pointing it out!

Share this post


Link to post
On 6/18/2019 at 9:51 PM, ReaperAA said:

 

What the Hell? Is it a box made of gold? That's waaaay too much.

No. It's just rare. If I ordered one and there was no way to get more, I wouldn't sell it away cheaply.

Share this post


Link to post
Posted (edited)

By the way, my Asendia tracking number in the email from LRG (received on 11.6.) still does not really tell anything. Asendia's tracking has only said "Shipment Has Left Seller Facility And Is In Transit To Carrier" this whole time. I guess it will arrive some time this week, shipments from the US to here usually take 2-3 weeks. I will probably also have to pay over 50€ in import fees.

 

Did anyone in Germany get their box from Ireland instead of US, as was originally advertised on LRG's order page? (not that it would help me in any way because I do not live there)

Edited by xttl

Share this post


Link to post

as i expected, the reply i got from the customer support didn't really tell me much of anything, just the stuff i knew about that they send the orders out in batches, and that i should "wait some time for the order to start tracking." but my tracking number literally doesn't work and doesn't tell me anything at all. if xttl's tracking actually tells them something, and got the shipment confirmation today, then there has to be something wrong on my end for me to not getting any information at all.

Share this post


Link to post
1 minute ago, Viscra Maelstrom said:

as i expected, the reply i got from the customer support didn't really tell me much of anything, just the stuff i knew about that they send the orders out in batches, and that i should "wait some time for the order to start tracking." but my tracking number literally doesn't work and doesn't tell me anything at all. if xttl's tracking actually tells them something, and got the shipment confirmation today, then there has to be something wrong on my end for me to not getting any information at all.

 

I actually meant to type 11.6., I got the order confirmation about two weeks ago and the tracking number started working within 24 hours, but the tracking status has not updated since then at all.

Share this post


Link to post

ohh, okay then, that makes sense @xttl. that still confuses me though, since i got the shipment confirmation the same day as you did, but my tracking still doesn't work. i guess there's nothing to do but wait this week out, then go bother the customer support then if nothing happens after then.

Share this post


Link to post

I also wrote them again yesterday via FB Messanger  They told me that maybe just the label was printed the day I got the shipping notification on 13.06 because of my missing tracking info.  But they can not say for sure. And that all the orders should be processed within the next week. Its ridiculous.....

I openend a new ticket an hour ago. 

Share this post


Link to post
9 hours ago, xttl said:

Did anyone in Germany get their box from Ireland instead of US, as was originally advertised on LRG's order page? (not that it would help me in any way because I do not live there)

 

Actually, mine came from the uk, not Ireland. No customs fee at all.

Share this post


Link to post

The package didn't arrive yet, but now there are finally some updates on Asendia's tracking page. Did the package seriously only start moving now, even though it was sent two weeks ago? The tracking says it's been "received by export agent" on 26th.

Share this post


Link to post

I guess that video got leaked, isn't it the one supposed to be exclusive from the purchase of the limited edition? Or is that something else?

Share this post


Link to post

Same here! I really think they just started the shippment. Like I said they told me that maybe just the label was printed the day we got our notification. 

Share this post


Link to post
Posted (edited)
2 hours ago, Ferk said:

I guess that video got leaked, isn't it the one supposed to be exclusive from the purchase of the limited edition? Or is that something else?

 

It should come with both the regular edition and Beast Box (on the USB drive), if I remember correctly. But at least thanks to the leaker and no thanks to LRG and the slowest shipper ever they use I finally get to see it!

 

Eh, seems Romero didn't know Plutonia and PWADs had prior art on separate deathmatch arenas. Level testing was done in GZDoom's OpenGL renderer using the default (=wrong) lighting setting or at least there's lots of footage of GZDoom running with broken lighting in the video, so is that why the maps are in some places way too dark if you play with proper lighting?

 

Though to be fair, I've used VMware to run Doom Builder & test maps under Linux and well, GZDoom's shader-based lighting doesn't work with the emulated GPU so it probably doesn't work in VMware Fusion on MacOS either. Of course there's still always the software renderer to play with something which doesn't look like flat overbright crap...

Edited by xttl

Share this post


Link to post

by the way, my Asendia tracking finally started to show something as well. the last update says "Package Received By Export Agent", which i'm a bit clueless on what it exactly means. what's more confusing, though, is that in the shipping info, they're also telling me that i can track my order through this site. but i don't have the faintest clue what kind of number they want me to enter, as none of the ones i tried works and says that the parcel doesn't have tracking details yet.

Share this post


Link to post

Still WIP, tho. But I'm glad to see Romero didn't forget about it with all the E3 and Empire of Sin announcement stuff.

 

Did anyone try it, are there par times in it?

Share this post


Link to post

so finally, my Beast Box has arrived safely to me. as far as i can tell, everything arrived as it should; the coin itself had come loose from the box, but thankfully hadn't rolled out, and the statue was nested away safe and sound. it looks really good, and is surprisingly a lot heavier than i anticipated. as a side note, the coin itself isn't gold like in the promo shots, but silver.

 

i was fairly annoyed with how LRG handled the shipment of these things, but in the end i'm happy of having finally received it, and it definitely lived up to my expectations.

 

i do have one question though. how should you wash the shirt that came with the box? i didn't get any info on what settings you should use when putting it in the laundry... should you just wash it by hand or what?

Share this post


Link to post
Posted (edited)

@Viscra Maelstrom in general for washing shirts (whether printed or plain) wash with cold water (hot can cause shrinkage even if the tag says pre-shrunk) and with like colors, and let it air dry, dont put shirts in the dryer, especially printed (that's how cracks and chipping on the print happen) and can also shrink the clothing.

 

This is my personal experience, as I am someone who doesn't buy a lot of clothes but keep what I have in good condition. I'm almost 38 lol but have been doing laundry since I was 11, my mom taught me this (and other things) not only for responsibility but that I shouldn't rely on a woman or any one to do these types of things for me (no offense intended to you, anyone or women or sounding misogynistic) 

Share this post


Link to post

so I got the beast box, as it turns out the readme file is telling me to use gzdoom. so that awnsers the quiestion, which source port to play with.

besides the paid version comes with a SIGIL_SHRED.wad which includes mp3 files as sounds track which everyone cam make themselfs with the soundtrack files but I guess this makes the life for use paying customers a little easier.

Share this post


Link to post

I received my Standard and Beast Boxes yesterday.

My Beast Box number is as high as 1346. No wonder it took a while to send these out.

Share this post


Link to post
Posted (edited)

My Sigil box has finally arrived and I'm so relieved that I can put my soul to rest. Feels like end of an era after all that's happened but it's behind me now. I'm not sure if I'd order another doombox if it was sold or whether I'd give LRG my business again but for the very least I feel happy supporting Romero and hopefully the amount of orders inspires him to create more Doom wads in the future. 

Sigilbox.png

doombox2.png

I think I can finally put this thread behind me as well. 

Share this post


Link to post

Hi @xttl - I've been trying to get your DOS SIGIL.EXE working on my 486 (see specs below)...

but always get the following error when selecting "New Game"

 

SIGIL v1.1 [haven't tried the v1.2 WIP yet]

ERROR: W_GetNumForName: M_EP15 not found!

 

Original DOOM 1.9 works fine with the SIGIL_COMPAT.wad (despite the occasional crash)

 

Specs

Unknown 486 mainboard (tried to identify it, but can't - has a part number beginning IB...so might be IBM)

Intel 486 DX2 66

64MB RAM

Cirrus Logic 1MB VLB GFX

640MB HDD (C:)

4GB HDD additional [scsi] (D: to K:)

Yamaha CDRW [scsi]

Pioneer DVD [scsi]

Sound Blaster AWE 64 ISA

Western Digital 10Mb LAN

SCSI Controller card

FDD/HDD/Ports (LPT/Serial) controller card

 

Any ideas/suggestions as to what might be wrong?

 

 

Share this post


Link to post
6 hours ago, themadhaxor said:

Intel 486 DX2 66

64MB RAM

 

64 MB RAM on a 486? Dayum, man! And I though I was so cool with my 32 MB :D

Share this post


Link to post
7 hours ago, themadhaxor said:

Hi @xttl - I've been trying to get your DOS SIGIL.EXE working on my 486 (see specs below)...

but always get the following error when selecting "New Game"

 

SIGIL v1.1 [haven't tried the v1.2 WIP yet]

ERROR: W_GetNumForName: M_EP15 not found!

 

It's missing the menu graphics for Episode 5.

Share this post


Link to post

My box also finally arrived on Friday, but I have not fetched it yet from the post office, bad weather and have had other stuff to do. Not sure if an delivery attempt was made at some point when I was not at home or if the price simply didn't include delivery to door... Seems it did not go into customs after all, so I guess everyone in EU is covered in this respect when they order from LRG, even though for some reason they only mention Germany specifically, eh?

 

8 hours ago, themadhaxor said:

SIGIL v1.1 [haven't tried the v1.2 WIP yet]

ERROR: W_GetNumForName: M_EP15 not found!

 

You need to use SIGIL.WAD, not SIGIL_COMPAT.wad. Check that you have it in the same directory as the exe (it will be autoloaded). M_EPI5 is found inside SIGIL.WAD, but not in the COMPAT version since it reuses the E3 map slots. (M_EPI5 is the menu graphic for the 5th episde as mentioned above by Kristus)

Share this post


Link to post
Posted (edited)

I’ve tried using both SIGIL.WAD and SIGIL_COMPAT.WAD...

but I get the error regardless...

I’ll double check later this evening when I’m back home...

Almost forgot to mention that my 486 mainboard (when fully upgraded) supports 512k cache and 128MB RAM...

Currently has 64MB and 256k...

Edited by themadhaxor

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×