Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
AverageWalrus24

Quake Source Port CD Music

Recommended Posts

I've tried getting the CD music to work in both Quakespasm and Darkplace. For both I've followed the instructions that I've found in their text files/websites, but the music still isn't playing, any ideas?

 

Also, I would like to verify which source port is "better" of the two (or maybe there's a better one that I didn't find).

Any assistance is appreciated.

Share this post


Link to post

If you want to play the music directly from the CD you have to use a version that uses SDL (not SDL2 – they removed the support for CD audio). AFAIK Quakespasm can be compiled with both versions. It's probably a better idea to use external music, i.e. ogg or flac. Unfortunately both ports have different naming schemes. Quakespasm uses music files that are named id\music\track02.ogg … id\music\track11.ogg.

 

Darkplaces has support for dynamic lights and high resolution skins/textures/etc. Quakespasm does not support dynamic lights and only supports high resolution textures. Darkplaces is less faithful, has problems with some mods, is infrequently updated and has modified physics.

 

I have not used Darkplaces for many years. If you want to use updated graphics you should probably use FTEQW, although I'm not familiar with that port.

 

If you want the game to look similar to software mode, you should use the following settings in Quakespasm:

gl_texturemode "GL_NEAREST_MIPMAP_LINEAR" // no blurry filtering
r_viewmodel_quake "1" // weapon positioning similar to winquake
r_particles "2" // square particles

 

 

Share this post


Link to post
13 hours ago, AverageWalrus24 said:

I've tried getting the CD music to work in both Quakespasm and Darkplace. For both I've followed the instructions that I've found in their text files/websites, but the music still isn't playing, any ideas?

 

Also, I would like to verify which source port is "better" of the two (or maybe there's a better one that I didn't find).

Any assistance is appreciated.

 

Did you rip the audio CDs as either mp3, FLAC, or OGG and place them in the \id1\music folder in your quakespasm installation?

 

Also, you must name the files like this:

 

track02.flac  
track03.flac
track04.flac
track05.flac
track06.flac
track07.flac
track08.flac
track09.flac
track10.flac
track11.flac

 

or

 

track02.mp3
track03.mp3
track04.mp3
track05.mp3
track06.mp3
track07.mp3
track08.mp3
track09.mp3
track10.mp3
track11.mp3

 

or

 

track02.ogg
track03.ogg
track04.ogg
track05.ogg
track06.ogg
track07.ogg
track08.ogg
track09.ogg
track10.ogg
track11.ogg

 

Now obviously, if your files are mp3, flac, or ogg, replace flac with whatever format you used.

 

For the Quake mission packs, the folder structures are \hipnotic\music and \rogue\music respectively.  Use the same file naming conventions as above for the individual music tracks themselves. 

Edited by Master O

Share this post


Link to post
9 hours ago, Manuel-K said:

If you want to use updated graphics you should probably use FTEQW, although I'm not familiar with that port.

If their Hexen II side of things is any indication, it's probably just as crap as Darkplaces, but maybe the Quake side is more faithful.

Share this post


Link to post

I had no problems getting music to run on both Darkplaces as well as Quakespasm. I used Darkplaces for a while, then switched to Quakespasm and haven't looked back. A small number of Darkplaces' graphical additions (smoke and blood in particular) look nice, but the majority of them just kind of drown out the atmosphere. Quakespasm is more stable and has far greater mod compatibility. Though you need to use Darkplaces in order to play Nehahra (which I highly recommend). 

Share this post


Link to post

I'd stay completely away from Darkplaces anymore.  Friends don't let friends use Darkplaces.  Use Quakespasm or vkQuake for the most mod/level compatibility, or if you really want those few bits of extra eyecandy, go with FTE Quake. 

 

The music files should be placed like Master O mentioned above.

Share this post


Link to post
12 hours ago, Master O said:

Stuff

I had done as you said beforehand, and re-downloaded Quakespasm and tried again to make sure I didn't mess up, and I'm still not getting the music the play normally. The music will play if I go to the console and use the "music" command (Music trackXX).

 

Any ideas as to what may be wrong?

Share this post


Link to post
11 minutes ago, AverageWalrus24 said:

I had done as you said beforehand, and re-downloaded Quakespasm and tried again to make sure I didn't mess up, and I'm still not getting the music the play normally. The music will play if I go to the console and use the "music" command (Music trackXX).

 

Any ideas as to what may be wrong?

 

The only other option I can think of is to go to the Options menu in Quakespasm and set "External Music" to "On".

Share this post


Link to post
2 minutes ago, Master O said:

 

The only other option I can think of is to go to the Options menu in Quakespasm and set "External Music" to "On".

I checked, and it's on by default.

Share this post


Link to post
1 minute ago, AverageWalrus24 said:

I checked, and it's on by default.

 

What version of Quakespasm are you using? 

Share this post


Link to post
2 minutes ago, AverageWalrus24 said:

@Master O 0.93.1_win64

 

 

 

Have you tried going past the Skill selection map and straight into episode 1 to see if the music is playing? Also, are you using the quakespasm.exe and not the quakespasm-sdl2.exe ?

Share this post


Link to post
1 minute ago, Master O said:

 

Have you tried going past the Skill selection map and straight into episode 1 to see if the music is playing? Also, are you using the quakespasm.exe and not the quakespasm-sdl2.exe ?

Yes and yes.

Share this post


Link to post
8 minutes ago, AverageWalrus24 said:

Yes and yes.

 

I know this might sound sound dumb, but is your id1 folder lowercased or capitalized? I'm also using Windows and mine is ID1 and it plays the music correctly.  You may want to try renaming the id1 folder to ID1 and see if that works.

 

ID1\music\track02.flac  (or whatever audio format you used)

 

(etc)

Share this post


Link to post

Well I enjoy Darkplaces with a HD mod from moddb which looks very faithful to the older textures just more higher res and it looks very nice, I haven't had any performance issues with it so far.

Share this post


Link to post

@Manuel-K 6fkrhGH.png

 

 

I may have found the problem, I just noticed that inside the console there is a line that states, "Couldn't exec autoexec.cfg" JBn7w9k.png

 

I can't seem to find autoexec.cfg, so I presume that it isn't present (and also that it is responsible for starting the music) so if this is something that I am supposed to have, can I have a copy of the file, or at least know what the contents of said file are so that I can make one.

 

 

Share this post


Link to post
2 minutes ago, AverageWalrus24 said:

@Manuel-K 6fkrhGH.png

 

 

I may have found the problem, I just noticed that inside the console there is a line that states, "Couldn't exec autoexec.cfg" JBn7w9k.png

 

I can't seem to find autoexec.cfg, so I presume that it isn't present (and also that it is responsible for starting the music) so if this is something that I am supposed to have, can I have a copy of the file, or at least know what the contents of said file are so that I can make one.

 

 

 

I notice in your music folder screenshot, the file extensions are not present in the filenames:

 

https://www.intowindows.com/show-or-hide-extensions-with-file-names-in-windows-10-file-explorer/

 

That may or may not be why quakespasm isn't playing the files.  Try that and see what happens.

 

 

 

Share this post


Link to post

Are you sure that the file extensions are correct? It says “ogg video file”, so it might be .ogv instead of ogg.

5 minutes ago, AverageWalrus24 said:

I can't seem to find autoexec.cfg, so I presume that it isn't present (and also that it is responsible for starting the music) so if this is something that I am supposed to have, can I have a copy of the file, or at least know what the contents of said file are so that I can make one.

 

No, you don't need to have an autoexec.cfg.

Share this post


Link to post

@Master O I did as asked, the problem is still present.

 

@Manuel-K I swapped out the .oggs for .mp3s, and the problem is still present. I believe it says "ogg video file" because I have VLC media player installed, and .oggs are opened by that by default, .mp3s aren't though, which is why I swapped the .oggs for the .mp3s (to see if VLC was causing problems).

Share this post


Link to post

Start Quakespasm, open the console, type in “developer 1”, start a new game, open the console, type in “condump” and post the contents of that file.

Share this post


Link to post
Spoiler

UDP Initialized
WIPX_OpenSocket: Address family not
supported by protocol family
WIPX_Init: Unable to open control
socket, IPX disabled
Exe: 16:04:16 Jun  6 2018
256.0 megabyte heap
Video mode 1920x1080x24 60Hz (24-bit
z-buffer, 0x FSAA) initialized
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce GTX 1060
6GB/PCIe/SSE2
GL_VERSION: 4.6.0 NVIDIA 417.35
FOUND: ARB_vertex_buffer_object
FOUND: ARB_multitexture
GL_MAX_TEXTURE_UNITS: 4
FOUND: ARB_texture_env_combine
FOUND: ARB_texture_env_add
FOUND: SDL_GL_SetSwapInterval
FOUND: EXT_texture_filter_anisotropic
FOUND: ARB_texture_non_power_of_two
FOUND: GLSL

Sound Initialization
SDL audio spec  : 44100 Hz, 1024 samples, 2 channels
SDL audio driver: directsound - Speakers (Realtek High Definition Audio), 6553
Audio: 16 bit, stereo, 44100 Hz
CDAudio disabled at compile time

========= Quake Initialized =========

execing quake.rc
execing default.cfg
execing config.cfg
couldn't exec autoexec.cfg
3 demo(s) in loop
]developer 1
SpawnServer: start
Clearing memory
Programs occupy 403K.
40 entities inhibited
Server spawned.
CL_EstablishConnection: connected to local
Client LOCAL connected

FITZQUAKE 0.85 SERVER (24778 CRC)
Serverinfo packet received.

Introduction
Using protocol 666
FindFile: can't find music/track04.ogg
FindFile: can't find music/track04.opus
FindFile: can't find music/track04.flac
FindFile: can't find music/track04.wav
CL_SignonReply: 1
CL_SignonReply: 2
CL_SignonReply: 3
242.7 megabyte data cache
CL_SignonReply: 4
]condump

Spoiler

UDP Initialized
WIPX_OpenSocket: Address family not
supported by protocol family
WIPX_Init: Unable to open control
socket, IPX disabled
Exe: 16:04:16 Jun  6 2018
256.0 megabyte heap
Video mode 1920x1080x24 60Hz (24-bit
z-buffer, 0x FSAA) initialized
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce GTX 1060
6GB/PCIe/SSE2
GL_VERSION: 4.6.0 NVIDIA 417.35
FOUND: ARB_vertex_buffer_object
FOUND: ARB_multitexture
GL_MAX_TEXTURE_UNITS: 4
FOUND: ARB_texture_env_combine
FOUND: ARB_texture_env_add
FOUND: SDL_GL_SetSwapInterval
FOUND: EXT_texture_filter_anisotropic
FOUND: ARB_texture_non_power_of_two
FOUND: GLSL

Sound Initialization
SDL audio spec  : 44100 Hz, 1024 samples, 2 channels
SDL audio driver: directsound - Speakers (Realtek High Definition Audio), 6553
Audio: 16 bit, stereo, 44100 Hz
CDAudio disabled at compile time

========= Quake Initialized =========

execing quake.rc
execing default.cfg
execing config.cfg
couldn't exec autoexec.cfg
3 demo(s) in loop
]developer 1
SpawnServer: start
Clearing memory
Programs occupy 403K.
40 entities inhibited
Server spawned.
CL_EstablishConnection: connected to local
Client LOCAL connected

FITZQUAKE 0.85 SERVER (24778 CRC)
Serverinfo packet received.

Introduction
Using protocol 666
FindFile: can't find music/track04.opus
FindFile: can't find music/track04.mp3
FindFile: can't find music/track04.flac
FindFile: can't find music/track04.wav
CL_SignonReply: 1
CL_SignonReply: 2
CL_SignonReply: 3
242.7 megabyte data cache
CL_SignonReply: 4
]condump

@Manuel-K I did it for both the .mp3s and the .oggs.

Share this post


Link to post

In the console. If the menu says that it is enabled it the var should be 1.

 

I'm afraid I'm out of ideas for the moment.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×