Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Hellbent

1070 max-q slow playing Eviternity

Recommended Posts

So I downloaded gzdoom since it's optimized for modern operating systems and processors (My GS65 came today! what a beaut!). Yet, even at 960x540 res and software render mode (pixel mode vs smoothed gfx GL mode) the framerate in Eviternity was poor. Do I need to play in GL mode for decent framerate? I really prefer the classic pixel mode. /sigh

 

My computer specs are GeForce 1070 max-q GPU, i7-8750H CPU @ 2.2ghz, 16gb RAM, Windows 10 Home, 256gb SSD drive.

 

I've installed very little software so far. Kinda disappointing.

Share this post


Link to post

You can have crisp pixels in GL mode just fine. All you have to do is turn texture filtering off.

 

I believe GZDoom is more CPU intensive.

Share this post


Link to post

Your GPU is not making any difference in your frame rate. It is slow because you have a mobile CPU and you are playing a very complex Doom level in GZDoom. Your best best is to try and play it in PrBoom+ or Eternity and see if the reduced complexity of the engine allows it to run fast enough.

Share this post


Link to post

I would definitely take @Linguica's advice, but also maybe try GZDoom's Doom Software Renderer.  Idk how much it will help, it's what I've been using since I'm using a controller.

 

EDIT: I should not I'm note using it for performance, but because I like how it looks.

 

EDITx2: I'm dumb, I must have glazed over that you were using software mode...what am I doing with my life.  So yeah use PRBoom+ or Eternity.  Both are solid and sturdy.  And shouldn't give you much performance grief.

Edited by guitardz

Share this post


Link to post

Hmm... the computer is touted by reviewers and users as playing top intensive AAA titles with high fps and at high settings, so seems like it should be able to play Eviternity with good framerate at medium-low settings. But thanks for the tips.

Share this post


Link to post
On 12/18/2018 at 12:28 AM, Hellbent said:

Hmm... the computer is touted by reviewers and users as playing top intensive AAA titles with high fps and at high settings, so seems like it should be able to play Eviternity with good framerate at medium-low settings. But thanks for the tips.

 

The problem here is that the Doom engine isn't optimized for modern hardware. GZDoom is heavily modified, sure, but its roots are still archaic, so it keeps some of its limitations (e.g. it won't use more than one CPU core and your GPU won't do much). Now, I'm not an expert so don't quote me on this, but it also seems that the whole lindef-type architecture gets exponentially more expensive the bigger it gets, especially on GZDoom.

 

I remember someone on the Steam forums complaining that Doom 3 ran like garbage on their shiny new gaming laptop, and as it turns out it was due to the low clock speeds of the CPU coupled with the fact that the game used a single core.

Share this post


Link to post
12 hours ago, KVELLER said:

 

The problem here is that the Doom engine isn't optimized for modern hardware. GZDoom is heavily modified, sure, but its roots are still archaic, so it keeps some of its limitations (e.g. it won't use more than one CPU core and your GPU won't do much).

 

This is spot on. Here's a thread that explains it pretty well too.

Share this post


Link to post

Which maps ran badly? I'm on a laptop too but with a slower processor and GPU and haven't had any problems with Eviternity yet (although I'm only up to map 9).

Otherwise happy with the system? I've got a Razer Blade 2016 -- had to RMA the first one they sent me and after two years the battery is bulging so much the trackpad is no longer flat. I'm considering a GS65 to replace it.

Share this post


Link to post

Consider lowering your settings too. If you're playing at 1080p with all the bells and whistles such as bloom, anti-aliasing, ambient occlusion, etc, it will have an impact. Also please try it in PrBoom+ - you'll have none of the GZDoom targeted effects like snow, rain, portal particles etc, which will assist in increasing your frame rate.

Share this post


Link to post

If u really want to stick with GZdoom (don't wanna use PrBoom+ or Eternity Engine), then consider using the default OpenGL mode (OpenGL has better performance than software renderer). Turn off all special effects like texture filtering, bloom, AA, dynamic lights, ambient occulusion and use 1280x720 or lower resolution.

 

Also make sure in the Nvidia control Panel that GZdoom is using the high-performance Graphics card. Otherwise GZdoom might be using the integrated/intel GPU.

Share this post


Link to post

One extra stroke of lag management - wait for RC2 to drop; we'll be having the option added to remove weather effects, as this can cause a lot of lag in certain areas.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×