Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
guitardz

GZDoom Resolution Scale in a Window? *Resolved*

Recommended Posts

Okay, after fecking with my GZD opengl mode a bit trying to make it look like software, I have this!

Screenshot_Doom_20181225_031032.png

Yes that is in 640x400

But in a window that is 1792x1008

Looks like this on my monitor:

test.jpg

What I want to do is make it 711x400 so it fills out the full width of the 16:9 window

But I can only use these presets

Capture.PNG

I can choose "custom" on resolution scale, but I don't know where to tell GZD what I want my custom resolution to be.

It isn't down there where it says Custom Resolution Mode because that resizes the window...

Anyone have an idea to help with this?

 

EDIT: Thanks to @Redxone I have the answer I was looking for, a simple console command:

 

vid_setscale <width> <height>

With it my software mode emulation is complete.  If your interested in using some of these settings yourself check out @Woolie Wool's comment about it here:

https://www.doomworld.com/forum/post/1948548

 

And enjoy a few shots of my finalized settings.  I settled for 1066x600 since I originally played PC Doom in 800x600.

Spoiler

 

Screenshot_Doom_20181226_025032.png

Screenshot_Doom_20181226_025108.png

Screenshot_Doom_20181226_025203.png

 

 

Edited by guitardz : Solution found.

Share this post


Link to post

You need to set the custom resolution to the desired numbers not the window size.  I typically use 854x400 in full screen.  However this will give a square pixel letterbox image on my monitor to which you need to set vid_scale_customstretched 1, in order for a correct aspect ratio.  Alt-Entering to a window should keep the window filled.  The settings you have now are setting a 4:3 resolution to 16:9, hence the compression in your second image.  Make sure to set resolution scale back to custom as using the 320x200 or 640x400 presets will always force a 4:3 image.  You could also use 426x240 or 854x480 and that will keep the square pixel menus as GZDoom does by default.  If that's important to you.  If it still doesn't display correctly check the settings on you graphics card or monitor as they could be forcing a certain ratio too.  Hope that helps

 

Edit: Also if you use 426x200, 854x400 or some mutiple, etc. be sure to set HUD preserves aspect ratio to "off", as the cvar mentioned above will do the correction by itself

Edited by okbuddy : New information

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×