Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
GamingMarine

OBS Not Picking Up Desktop Audio

Recommended Posts

This has been an issue for pretty much everyone for quite a while, but it's never been brought up here (As far as I know).

 

I recently got OBS to replace Windows's built in Game Bar. While the audio balance levels say that it's picking up both my microphone as well as my desktop, only my voice can be heard.

 

I've tried EVERYTHING I can possibly think of to fix this: Reinstalling OBS, restarting my computer, changing OBS's installation directory, changing my default audio device, changing audio tracks, switching headphones, having multiple desktop audio devices set up, etc., but to no avail.

 

Additional notes:

-I don't have any additional programs known to affect this installed (i.e. Nahimic...)

-As mentioned before, I have two headphones: A Hunterspider USB headset, and some earbuds from a brand I don't remember the name of

-OBS isn't muted in volume mixer

 

Specs/Log (If needed)

Spoiler

Windows Version: Windows 10 Home 1803

Windows Build: 17134.523

Manufacturer: CyberPowerPC

Processor: Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz 3.00 GHz

Installed Memory (RAM): 8.00 GB (7.87 GB usable)

System Type: 64-bit Operating System, x64-based processor

Spoiler

16:42:06.244: CPU Name: Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz
16:42:06.244: CPU Speed: 3000MHz
16:42:06.244: Physical Cores: 4, Logical Cores: 4
16:42:06.244: Physical Memory: 8057MB Total, 4618MB Free
16:42:06.244: Windows Version: 10.0 Build 17134 (revision: 523; 64-bit)
16:42:06.244: Running as administrator: false
16:42:06.244: Aero is Enabled (Aero is always on for windows 8 and above)
16:42:06.244: Windows 10 Gaming Features:
16:42:06.244:     Game Bar: On
16:42:06.244:     Game DVR: On
16:42:06.244:     Game DVR Background Recording: Off
16:42:06.245: Sec. Software Status:
16:42:06.247:     Windows Defender Antivirus: enabled (AV)
16:42:06.247:     Windows Firewall: enabled (FW)
16:42:06.247:     Windows Defender Antivirus: enabled (ASW)
16:42:06.247: Browser Hardware Acceleration: true
16:42:06.247: Portable mode: false
16:42:06.343: OBS 22.0.2 (64-bit, windows)
16:42:06.343: ---------------------------------
16:42:06.344: ---------------------------------
16:42:06.344: audio settings reset:
16:42:06.344:     samples per sec: 48000
16:42:06.344:     speakers:        2
16:42:06.360: ---------------------------------
16:42:06.360: Initializing D3D11...
16:42:06.360: Available Video Adapters: 
16:42:06.361:     Adapter 1: Intel(R) HD Graphics 630
16:42:06.361:       Dedicated VRAM: 134217728
16:42:06.361:       Shared VRAM:    4224591872
16:42:06.361:       output 1: pos={0, 0}, size={1920, 1080}, attached=true
16:42:06.361:     Adapter 2: Radeon RX 580 Series
16:42:06.361:       Dedicated VRAM: 4237361152
16:42:06.361:       Shared VRAM:    4224591872
16:42:06.363: Loading up D3D11 on adapter Intel(R) HD Graphics 630 (0)
16:42:06.378: D3D11 loaded successfully, feature level used: 45056
16:42:07.080: ---------------------------------
16:42:07.080: video settings reset:
16:42:07.080:     base resolution:   1920x1080
16:42:07.080:     output resolution: 1920x1080
16:42:07.080:     downscale filter:  Bicubic
16:42:07.080:     fps:               30/1
16:42:07.080:     format:            NV12
16:42:07.080:     YUV mode:          601/Partial
16:42:07.080: Audio monitoring device:
16:42:07.080:     name: Default
16:42:07.080:     id: default
16:42:07.081: ---------------------------------
16:42:07.142: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
16:42:07.166: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
16:42:07.540: [AMF] Version 2.4.2 loaded (Compiled: 1.4.7.0, Runtime: 1.4.10.0, Library: 1;4;10;0;18.40.11.01;201811071823;CL#1703991).
16:42:07.717: [AMF] [Capability Manager] Testing Direct3D 11 Adapter 'Radeon RX 580 Series (VEN_1002/DEV_67df/SUB_c5801682/REV_00e7)':
16:42:07.717:   H264/AVC: Supported
16:42:07.717:   H265/HEVC: Supported
16:42:07.717: 
16:42:07.868: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
16:42:07.886: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.
16:42:07.886:  (127)
16:42:07.886: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
16:42:07.920: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
16:42:07.955: [obs-browser]: Version 2.1.5
16:42:07.955: [obs-browser]: Blacklisted device detected, disabling browser source hardware acceleration.
16:42:08.045: LoadLibrary failed for 'nvEncodeAPI64.dll': The specified module could not be found.
16:42:08.045:  (126)
16:42:08.263: Couldn't find VLC installation, VLC video source disabled
16:42:08.303: No blackmagic support
16:42:08.375: ---------------------------------
16:42:08.375:   Loaded Modules:
16:42:08.375:     win-wasapi.dll
16:42:08.375:     win-mf.dll
16:42:08.375:     win-dshow.dll
16:42:08.375:     win-decklink.dll
16:42:08.375:     win-capture.dll
16:42:08.375:     vlc-video.dll
16:42:08.375:     text-freetype2.dll
16:42:08.375:     rtmp-services.dll
16:42:08.375:     obs-x264.dll
16:42:08.375:     obs-vst.dll
16:42:08.375:     obs-transitions.dll
16:42:08.375:     obs-text.dll
16:42:08.375:     obs-qsv11.dll
16:42:08.375:     obs-outputs.dll
16:42:08.375:     obs-filters.dll
16:42:08.375:     obs-ffmpeg.dll
16:42:08.375:     obs-browser.dll
16:42:08.375:     image-source.dll
16:42:08.375:     frontend-tools.dll
16:42:08.375:     enc-amf.dll
16:42:08.375:     coreaudio-encoder.dll
16:42:08.375: ---------------------------------
16:42:08.375: ==== Startup complete ===============================================
16:42:08.381: All scene data cleared
16:42:08.381: ------------------------------------------------
16:42:08.462: WASAPI: Device 'Speakers (Realtek High Definition Audio)' initialized
16:42:08.477: WASAPI: Device 'Microphone (Blue Snowball)' initialized
16:42:08.532: adding 42 milliseconds of audio buffering, total audio buffering is now 42 milliseconds
16:42:08.780: Switched to scene 'Desktop'
16:42:08.780: ------------------------------------------------
16:42:08.780: Loaded scenes:
16:42:08.780: - scene 'Desktop':
16:42:08.790:     - source: 'Game Capture' (game_capture)
16:42:08.790:     - source: 'Display Capture' (monitor_capture)
16:42:08.790: ------------------------------------------------
16:42:08.860: CalculateFileHash: Failed to open file 'C:\Users\GamingMarine\AppData\Roaming\obs-studio\updates\whatsnew.json': 
16:44:15.541: [qsv encoder: 'simple_h264_recording'] settings:
16:44:15.541:     rate_control:   ICQ
16:44:15.541:     ICQ Quality:    23
16:44:15.541:     fps_num:        30
16:44:15.541:     fps_den:        1
16:44:15.541:     width:          1920
16:44:15.541:     height:         1080
16:44:15.541: [qsv encoder: 'simple_h264_recording'] debug info:
16:44:15.547:     impl:           D3D11
16:44:15.547:     surf:           D3D11
16:44:15.621:     m_nSurfNum:     16
16:44:15.623:     m_nTaskPool:    4
16:44:15.623:     major:          1
16:44:15.623:     minor:          25
16:44:15.623: ---------------------------------
16:44:15.623: [FFmpeg aac encoder: 'simple_aac_recording'] bitrate: 128, channels: 2, channel_layout: 3
16:44:15.623: 
16:44:15.697: ==== Recording Start ===============================================
16:44:15.697: [ffmpeg muxer: 'simple_file_output'] Writing file 'C:/Users/GamingMarine/Videos/OBS Captures/2019-01-11 16-44-15.mp4'...
16:44:23.667: [ffmpeg muxer: 'simple_file_output'] Output of file 'C:/Users/GamingMarine/Videos/OBS Captures/2019-01-11 16-44-15.mp4' stopped
16:44:23.667: Output 'simple_file_output': stopping
16:44:23.667: Output 'simple_file_output': Total frames output: 222
16:44:23.667: Output 'simple_file_output': Total drawn frames: 239
16:44:23.667: ==== Recording Stop ================================================
16:54:20.443: WASAPI: Device 'Speakers (Realtek High Definition Audio)' Terminated
16:54:20.497: WASAPI: Device 'Speakers (Realtek High Definition Audio)' initialized
16:54:20.584: WASAPI: Device 'Speakers (Realtek High Definition Audio)' initialized
16:54:20.604: Settings changed (audio)
16:54:20.604: ------------------------------------------------
16:54:37.390: [qsv encoder: 'simple_h264_recording'] settings:
16:54:37.390:     rate_control:   ICQ
16:54:37.390:     ICQ Quality:    23
16:54:37.390:     fps_num:        30
16:54:37.390:     fps_den:        1
16:54:37.390:     width:          1920
16:54:37.390:     height:         1080
16:54:37.390: [qsv encoder: 'simple_h264_recording'] debug info:
16:54:37.396:     impl:           D3D11
16:54:37.396:     surf:           D3D11
16:54:37.432:     m_nSurfNum:     16
16:54:37.433:     m_nTaskPool:    4
16:54:37.433:     major:          1
16:54:37.433:     minor:          25
16:54:37.433: ---------------------------------
16:54:37.434: [FFmpeg aac encoder: 'simple_aac_recording'] bitrate: 128, channels: 2, channel_layout: 3
16:54:37.434: 
16:54:37.457: ==== Recording Start ===============================================
16:54:37.457: [ffmpeg muxer: 'simple_file_output'] Writing file 'C:/Users/GamingMarine/Videos/OBS Captures/2019-01-11 16-54-37.mp4'...
16:54:48.272: [ffmpeg muxer: 'simple_file_output'] Output of file 'C:/Users/GamingMarine/Videos/OBS Captures/2019-01-11 16-54-37.mp4' stopped
16:54:48.272: Output 'simple_file_output': stopping
16:54:48.272: Output 'simple_file_output': Total frames output: 306
16:54:48.272: Output 'simple_file_output': Total drawn frames: 324
16:54:48.272: ==== Recording Stop ================================================

I really hope a fix gets found soon, because I'm so frustrated I'm on the verge of quitting YouTube.

Share this post


Link to post

Make sure your desktop audio is configured to be recorded (not muted) and is correctly set to your recording track.

It should look like this:

c79327936e.png

Also, make sure your intended application you wish to record is playing back on the same device you have told OBS to record. If you have two different audio out devices, the audio will be missed if not correctly set. You can configure which device OBS records as desktop audio in settings under Audio.

Edited by Edward850

Share this post


Link to post
13 minutes ago, Edward850 said:

Make sure your desktop audio is configured to be recorded (not muted) and is correctly set to your recording track.

It should look like this:

c79327936e.png

Tried that, but no luck.

Also, forgot to mention, I don't have any capture cards.

Share this post


Link to post

Did you also check what I mentioned in the edit? You have multiple audio devices so it's very likely your audio isn't going to the right place.

Share this post


Link to post
6 hours ago, Edward850 said:

Did you also check what I mentioned in the edit? You have multiple audio devices so it's very likely your audio isn't going to the right place.

Actually it looks like he only has 1 output device (the Realtek high definition audio) and 1 input device (the mic), unless OBS is trying to treat the mic as an output instead of an inout which would be weird...

Share this post


Link to post

He claimed he has a USB headset, which by all accounts would be a separate device (Realtek Audio being onboard). I can only assume his spec sheet doesn't reflect the system as is.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×