Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Crackers0106

Can't open The Ultimate DOOM in gzdoombuilder in Gzdoom mode

Recommended Posts

When I use gzdoombuilder there is no "GZdoom: Doom" in the game configuration like there is for doom 2. Thus I can not use GZdoom features such as dynamic lights in my level. Any help?

Share this post


Link to post

I think the reason you can't see "GZDooM: DooM (in *** Format)" is because you haven't defined it in the "Game Configurations" tab in the Tool menu.

 

Click on Tools then click on Game Configurations then on the left will be a list of X: X (in X format) . To the left of them should be a box, some with a tick and some without. Simply tick the boxes you need.

 

Hope this helps you :3

Share this post


Link to post
7 hours ago, Crackers0106 said:

When I use gzdoombuilder there is no "GZdoom: Doom" in the game configuration like there is for doom 2. Thus I can not use GZdoom features such as dynamic lights in my level. Any help?


Strangely enough, GZDB don't have such configs for Doom 1, so you have to add new configs based on Doom 2 but without mentioning Doom 2 things (GZDoom_DoomDoom.cfg and ZDoom_things.cfg). They are in the "configurations" and "includes" folders of GZDB.

Share this post


Link to post
5 hours ago, DynamiteKaitorn said:

I think the reason you can't see "GZDooM: DooM (in *** Format)" is because you haven't defined it in the "Game Configurations" tab in the Tool menu.

 

Click on Tools then click on Game Configurations then on the left will be a list of X: X (in X format) . To the left of them should be a box, some with a tick and some without. Simply tick the boxes you need.

 

Hope this helps you :3

 

I thought that too, but "GZDooM: DooM (in *** Format)" isn't an option at all.  I guess you just have to use Doom 2 but stick in the Doom IWAD instead. 

Share this post


Link to post

I created a file called "GZDoom_UDoomUDMF.cfg" in GzDoomBuilder\Configurations, basing it off the DoomUDMF file and then including the following:
 

// This is required to prevent accidental use of a different configuration
type = "Doom Builder 2 Game Configuration";

// This is the title to show for this game
game = "GZDoom: Ultimate Doom (UDMF)";

// This is the simplified game engine/sourceport name
engine = "gzdoom";

// Should this configuration be initially available?
enabledbydefault = true;

defaultskytextures
{
	SKY1 = "E1M1,E1M2,E1M3,E1M4,E1M5,E1M6,E1M7,E1M8,E1M9";
	SKY2 = "E2M1,E2M2,E2M3,E2M4,E2M5,E2M6,E2M7,E2M8,E2M9";
	SKY3 = "E3M1,E3M2,E3M3,E3M4,E3M5,E3M6,E3M7,E3M8,E3M9";
	SKY4 = "E4M1,E4M2,E4M3,E4M4,E4M5,E4M6,E4M7,E4M8,E4M9";
}

thingtypes
{
	// Basic game actors
	include("Includes\\Doom_things.cfg");
	// include("Includes\\Doom2_things.cfg");
	// Additional ZDoom actors for that game
	include("Includes\\ZDoom_things.cfg", "doom");
	// Standard ZDoom actors
	include("Includes\\ZDoom_things.cfg", "zdoom");
	// Additional actors from the engine
	include("Includes\\GZDoom_things.cfg", "gzdoom");
	include("Includes\\GZDoom_things.cfg", "gzdoom_lights");
}

I then created a Doom_things.cfg file with just the Ultimate Doom things in, but you can also use the default and just not include anything from Doom 2, in which case you'll get a few errors in GZDoom Builder saying that Doom 2 things were not found, but it will still run.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×