Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Scorpinax

Removed Texture Still Showing up in Editor?

Question

Can someone help me with this? I truly have no idea how to do this.
Recently I removed a texture from my project Chokehold. I used SLADE and deleted both the patch and the texture name.
The flat never loaded properly regardless, but even by deleting the patch and texture list it still shows up in the GZdoom editor as an option. How do I get it to stop showing up in the selectable textures? For all I know it's totally gone out of the wad but it persists.

 

 

0help.png

Share this post


Link to post

11 answers to this question

Recommended Posts

  • 1

I had a quick look in your wad and found the patch in your TEXTURE1 lump.  

 

423rQLQ.png

 

The patch "TRUTWL04" is not present, but it's defined as a Textures twice: one using the missing TRUTWL04 patch and one using TRUTWL03, which is present.  I removed both Texture entries and the texture disappeared from the GZDB texture browser window as expected.

 

I think you'd just missed properly removing it from the TEXTURE1 lump.

Share this post


Link to post
  • 0
10 minutes ago, Dark Pulse said:

Check all the levels in the WAD and make sure it's not used anywhere?

I went through and checked all the levels, I don't see it being used in any of them. Thank you for the suggestion though.

 

If anyone wants to try and figure this out i'd greatly appreciate it, here's a download to the current version

Download

Share this post


Link to post
  • 0
11 minutes ago, Dark Pulse said:

Are they still defined in your TEXTURE1/TEXTURE2/PNAMES lumps? How are you doing custom textures?

I removed it from PNAMES and TEXTURE1. There is no TEXTURE2 within the wad. 
I add textures by loading the texture into patch from a file, then adding a texture and naming it the same as the patch, and adding the patch into the texture.

Share this post


Link to post
  • 0
6 minutes ago, Dark Pulse said:

This do anything for you? 

 

Holy crap thank you so much! It got rid of the unused stuff in a flash and also took it off the editor as well. This will come in handy exactly what i need it for, thanks a ton man. Now i just have to figure out how to make it exclude skyboxes and i'm good :)

Share this post


Link to post
  • 0

It was probably still being used in the level, but in a place that wouldn't normally be visible, such as a lower/upper texture on a one-sided linedef. In GZDB (bugfix version), there is a "map analysis mode" that will find and allow you to remove such textures, so you don't have to use external tools.

Share this post


Link to post
  • 0

GZDoomBuilder (BF), go to Mode / Find and Replace mode (or Press F3), and then search for that texture.

Share this post


Link to post
  • 0

I should clarify, that the texture was never used in any level: it always loaded as a missing texture. My problem lies in that I cannot seem to stop it from showing up in the texture selector even after removing it seemingly entirely from the wad

Share this post


Link to post
  • 0
24 minutes ago, Bauul said:

 

I think you'd just missed properly removing it from the TEXTURE1 lump.

Well I feel like an absolute buffoon now. I had no idea it was in there twice.
(there's no 'filter by' option on my old vers. so i just found the first one and removed it)

 

Thank you so much for taking the time!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×