Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
chowbar

GLBoom+ behaves weirdly

Recommended Posts

Hey guys, picked up a new laptop with a 1080 display and an Intel UHD 620 so I've been transferring a bunch of doom wads.

I was redownloading some source ports when I noticed that GLBoom+ 2.5.1.5 seems to behave weirdly.

After a fresh install and I went to change the screen resolution in windowed mode, but the screen resolution never changed even as I changed them.

When I set GLBoom+ to fullscreen and with a 1920x1080 resolution, it went into fullscreen mode but not totally fullscreen because the black borders never went away.

After I closed the exe and loaded it up again, another odd thing happened where now it appears to be fullscreen mode but it's slightly zoomed in on the top left of the screen. And that's how it's been since.

 

I did update my intel graphics drivers and I tried fiddling around with the scaling settings on the Intel UHD control panel but I'm at a loss here. I suspect its my display but I got no idea how to get to play nicely with GLBoom. I used GZDoom at 1920x1080 last night with no problems too.

Share this post


Link to post

This is just a guess, but it might have something to do with how Windows does scaling for high-DPI displays. Try this, assuming you're on Windows 10: right-click the GLBoom+ exe, go to properties -> compatibility -> change high DPI settings, then check the box at the bottom to override the default scaling behavior.

Share this post


Link to post
4 hours ago, Movac said:

This is just a guess, but it might have something to do with how Windows does scaling for high-DPI displays. Try this, assuming you're on Windows 10: right-click the GLBoom+ exe, go to properties -> compatibility -> change high DPI settings, then check the box at the bottom to override the default scaling behavior.

 

Thanks for the tip @Movac but I'm afraid it didn't help.

I'll keep fiddling around other options in Windows and the Intel Control Panel but I've still had no luck getting Boom to play nicely with this display.

Which is a shame cause I loved using PrBoom+ on my last 1366x768 laptop.

 

I don't even think PrBoom+ behaves nicely either because when I set it to 640x480 fullscreen, I don't the black borders on the side like Cripsy Doom does.

Share this post


Link to post
57 minutes ago, chowbar said:

Thanks for the tip @Movac but I'm afraid it didn't help.

That was certainly the setting I needed to adjust when getting a new laptop with a very high resolution screen. Perhaps you need to go a step further with it though. Merely checking the box for "Override high DPI scaling behaviour" is not sufficient. You need to choose "Application" under "Scaling performed by:" too.

 

I've always found it works best if you set the resolution to match that of the desktop. Fullscreen of course.

 

Regarding black borders or lack of them, this is related to the "Aspect Ratio" and "Status Bar and Menu Appearance" that you set in the in-game menu (Options -> General).

Share this post


Link to post
5 hours ago, chowbar said:

I don't even think PrBoom+ behaves nicely either because when I set it to 640x480 fullscreen, I don't the black borders on the side like Cripsy Doom does.

 

Both source ports work differently, PrBoom+ doesn't do forced aspect ratio corrections like Crispy and Choco (or ZDoom). You're not getting the black bars on the sides because your monitor probably doesn't support 4:3 resolutions well, mine doesn't either so it always stretches them to fit the screen instead of adding the bars, which makes them look horrendous.

 

You could switch the scaling options in the settings menu of the driver and let the GPU do it instead of the monitor, that usually works.

Edited by seed

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×