Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MetroidJunkie

Anyone else unable to switch to Snapmap Mode at all?

Recommended Posts

I'd switch to it, it would load, and then display the basic interface with the Featured tab active but then, presumably when it's trying to load in user maps for that featured tab, it freezes outright. Often, it would steal control of my mouse and I'd have to use the keyboard to shut it down with Task Manager. I managed to get Single Player to more or less run perfectly, now, but I still can't switch into Snapmap to save my life.

Share this post


Link to post

I suspected it was a problem with the server retrieving files for the featured tab, but this confirms it. It’s still a serious issue but I suppose at least now I can make my own maps.

Share this post


Link to post

I think I have a hunch as to why Snapmap freezes online. The component itself seems to be severely out of date. The reason I've come to this hypothesis is that, when I actually got into the editor, many things added later on such as the ability to add custom textures to blocking volumes as well as many types of templates are all gone. How did this happen? Steam says Doom 2016 itself is completely up to date and has all of the updates for single player, so why is Snapmap out of date?

Share this post


Link to post

Came back from the dead to report that I can access Snapmap fine, but I currently have my game set to launch straight to snapmap through the Steam launch options. (only works on steam, so you're out of luck if this problem is in console).

The freezing problem isn't an issue either. I'm not sure what I can tell ya about it. For me, the list of maps are outdated, but not broken upon loading.

Have the launch options on Steam contain this [+com_gameType 1]. No brackets. This will launch Doom straight to snapmap without having to shut down campaign, then load it up. Saves me some seconds of waiting.

 

Figured this out by rummaging through Snapmap's console commands. Says right there on the 3rd red-out area that it's launching +com_gameType 1.

CONSOLE.png.7213513ee5effa75fd84be1810e35ba2.png

Share this post


Link to post
Spoiler

sRpt6rF.png

 

It didn't help. It went straight to Snapmap but still froze. It's not loading, either. CPU and Memory are high usage but Network and Disk may as well be 0% each.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×