Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
aSeriesOfNumbers

Doom 64 retribution music

Recommended Posts

11 hours ago, aSeriesOfNumbers said:

Does anyone know how to get the actual n64 soundtrack working with this version of Doom 64?

 

What is bad about retribution soundtrack? thought it was about the same.

Share this post


Link to post

It was a bit tricky to find out how the music works. I also thought it was the actual music, until I found Nevanders hint in the text files. If you don't change some settings you'll only hear some weird mish-mash of tunes. In case some players still have trouble to fix that, here's a short guideline  : 

 

-> Launch your game/ Main menu

-> Choose "options"  

-> Choose "sound options"

-> select midi device "Fluidsynth"

-> Also choose "advanced options", (3 or 4 lines below midi device)

-> select "midi player options" 

-> click on "Fluidsynth" 

-> select configuration -> change to DOOMSND

 

Make sure you've put the DOOMSND.SF2 in your soundfonts folder as well or it might not be recognized. And keep in mind to change back to GZDOOM sound in case you play other wads than that afterwards,- or you'll hear the same old story again. 

 

 

 

Share this post


Link to post

Honestly I'm considering completely removing the MIDI soundtrack from the WAD and requiring users to just download the OGG pack since nobody can seem to figure out how to set up a soundfont properly, and then criticizing me for not using the real Doom 64 music.

Share this post


Link to post

I mean, the directions are in the readme, it boggles me how much people will avoid reading directions, but are fine crowdsourcing the info online when the solution is right in front of them.

Share this post


Link to post
43 minutes ago, Nevander said:

Honestly I'm considering completely removing the MIDI soundtrack from the WAD and requiring users to just download the OGG pack since nobody can seem to figure out how to set up a soundfont properly, and then criticizing me for not using the real Doom 64 music.

I got it working just fine. It ain't that hard.

 

That said, I also just threw up a suggestion to allow creators to embed soundfonts in their WADs/PK3s/PK7s on ZDoom's forums and have the engine automatically set it up for the end-user, so that might help solve the problem as well.

Edited by Dark Pulse

Share this post


Link to post
4 hours ago, Nevander said:

Honestly I'm considering completely removing the MIDI soundtrack from the WAD and requiring users to just download the OGG pack since nobody can seem to figure out how to set up a soundfont properly, and then criticizing me for not using the real Doom 64 music.

I never criticized you for not using it. I said in my message that I'm sure you included the proper ost. I also said that I already got it working awhile afterwards. Besides, I'm still fairly new to learning how to edit and configure this sorta stuff in order to get everything working properly. 

Sorry for any misunderstandings.

Edited by aSeriesOfNumbers

Share this post


Link to post
4 hours ago, guitardz said:

I mean, the directions are in the readme, it boggles me how much people will avoid reading directions, but are fine crowdsourcing the info online when the solution is right in front of them.

I did read the readme, I was still confused. And as I already said to Nevander, I'm still very new to learning this sorta stuff.

Edited by aSeriesOfNumbers

Share this post


Link to post
8 hours ago, 4everDoomed said:

It was a bit tricky to find out how the music works. I also thought it was the actual music, until I found Nevanders hint in the text files. If you don't change some settings you'll only hear some weird mish-mash of tunes. In case some players still have trouble to fix that, here's a short guideline  : 

 

-> Launch your game/ Main menu

-> Choose "options"  

-> Choose "sound options"

-> select midi device "Fluidsynth"

-> Also choose "advanced options", (3 or 4 lines below midi device)

-> select "midi player options" 

-> click on "Fluidsynth" 

-> select configuration -> change to DOOMSND

 

Make sure you've put the DOOMSND.SF2 in your soundfonts folder as well or it might not be recognized. And keep in mind to change back to GZDOOM sound in case you play other wads than that afterwards,- or you'll hear the same old story again. 

 

 

 

I already got it working bud. Thank you though.

Share this post


Link to post
48 minutes ago, aSeriesOfNumbers said:

I already got it working bud. Thank you though.

 

Great !

 

I think Nevander was referring to all drama that happened in his own Doom64 Retribution thread, not to you specifically.

Besides, you already solved it by yourself, like I did.. so enjoy it !!

 

 

 

4 hours ago, Nevander said:

Honestly I'm considering completely removing the MIDI soundtrack from the WAD and requiring users to just download the OGG pack since nobody can seem to figure out how to set up a soundfont properly, and then criticizing me for not using the real Doom 64 music.

 

 

However you will decide, I'm glad you started this project a few years ago. It is awesome and the whole package represents Doom64 perfectly. Even the test facility is beautiful craftsmanship, altough it's for exploration only. That whole project is clearly a labour of love and definitely not some usual wad quickly cobbled together. I already started the Doomslayer mode,- damn that's a toughy nut to crack. 3 hits and you're a goner..  Some crowded places might be impossible to survive.

 

I like it. 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×