Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SiFi270

Why does D2TWID's map33 crash so many ports?

Recommended Posts

There may be an existing D2TWID thread I could post this in, but I'm not sure if it's worth bumping even for this.

 

In Crispy Doom, Eternity, and PrBoom+, trying to take a single step in map33 of Doom 2 the Way id Did will make the program freeze up. All three of these ports can handle map33 of any other wad just fine, such as Plutonia 2 or even the Doom 2 BFG Edition iwad. It's a limit removing map in an otherwise vanilla wad, but these are all limit removing ports. I don't think it's a result of emulating any other aspect of vanilla behavior, because it happens regardless of compatibility settings in PrBoom+ and Eternity, and Odamex doesn't have any such problems with it despite also being quite a faithful port.

 

One thing I found curious was that both demos on DSDA for this map were played with no monsters, but trying it that way still got me the same results in PrBoom+.

 

edit1: And then I tried it on another computer and everything worked fine. Oh boy.

edit2: On the computer it works on, the date it was last modified is 11/16/13, while on the first one I used that date is 12/27/13. I guess something went wrong between an outdated version I've had for a while and the one I got from Doomkid's vanilla wad pack?

edit3: I appear to be wrong about everything. I sent the outdated wad from the computer that works to the one that doesn't, and it still froze. I'm going to try seeing if I somehow have a fishy version of the iwad. Doomkid, sorry the above edit gave you a notification about this mess when nothing's your fault.

edit4: Just un- and re-installed Doom 2, still having the problem. I think this is the point where most experts would conclude that my issues are supernatural in origin.

edit5: It works in the latest daily build of Crispy, even though the versions of each port I was trying before that were the same on each computer.

 

Final edit: Oh how embarassing. Whenever it didn't work, I was loading it with vsmooth, and whenever it did, I was using a more minimalistic loadout. Any other details are unrelated. I guess this thread will remain here as a testament to my idiocy.

Edited by SiFi270

Share this post


Link to post

D2TWID's own DEHACKED lump and vsmooth.deh together cause P_SetPsprite() to enter an infinite loop as soon as the Shotgun is picked up.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×