Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
elend

GzDoom Builder Bugfix won't start at all (Fixed)

Recommended Posts

Posted (edited)

EDIT:

 

Okay, it works now. Hoping that I might be helping someone in the future with this thread, here is, how I accidentally fixed it:

 

I downloaded GzDoom Builder Bugfix R3012 which initially worked. From this version I used the built in updater to update to 3045, which now works just as well. Very strange, but that's how it is sometimes.

 

Original Post:

 

I need help. I bought a new laptop with Windows10 and on this laptop my GzDoom Builder Bugfix won't start at all anymore.

 

1) I downloaded DirectX9 and installed it.

2) I could not install the .NET framework, since I have a newer one installed.

3) I tried that different SlimDX.dll I found somewhere in a thread here on DW.

4) I tried both GzDoom Builder Bugfix 32-bit and 64-bit versions. Yes, in different directories.

5) I checked in "Windows Features" that both the old .NET framworks (2.0 and 3.0) as well as the new one (4.5 and higher) are activated.

6) In my peril I even installed DoomBuilder 2 because it came packaged with all the necessary things, but to no avail. (Doom Builder 2 works btw)

 

I am now out of ideas as to what to try next and would appreciate any tip you guys can give me. If I can't get this working anymore, my mapping career is at an abrupt and early end. :(

Edited by elend

Share this post


Link to post

Sorry for the necro, but I think it's better than making another thread.

 

Unfortunately I cannot find a download for the version R3012 of GZDB-BF anywhere. I've just reset my PC, and have ran into the same problem. Could anyone provide a download, or maybe a different solution?

 

And to make note, I've downloaded DirectX9, .NET Framework's latest version, made sure my drivers updated, downloaded new and replaced the DevIL.dll and SlimDX.dll files, tried different compatibility modes, allowed GZDB-BF through the firewall, made sure I installed the x64 version for my x64 system, and yes, I've restarted my computer, multiple times.

 

Edit: I'm using Windows 10.

Edited by Juza

Share this post


Link to post

Yeah, I did all the above mentioned tactics and GZDB-BF will not launch. I'm stuck with standard GZDB for now.

i7 5820k

GTX 1080 (latest drivers)

Windows 10 pro (everything updated)

Share this post


Link to post

Well, by now r3012 is oldhat, the latest version of GZDBBF is r3097.

 

I had made a tutorial about how to install and troubleshoot an installation of GZDBBF. 

It seems to have help a few people so far, maybe this will also be the case for you.

Share this post


Link to post

Downloading the SlimDX version linked in your tutorial fixed it. Thank you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×