Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kore

PRBoom+ choppy software mode.

Recommended Posts

My computer is not weak by any means and the issue doesn't change even at low resolutions. Basically the game is skipping some frames every few frames, and occasionally it skips a lot of frames. I've tried various different configurations but the issue doesn't go away. And yes, the issue persists even with capped framerate, but it's less noticeable. I don't have this problem with GZDoom's software mode. I was wondering if there was anything I could do to fix this matter since I really need to test my map in prboom's software mode. No issues with the GL renderer.

Share this post


Link to post

I too have the same issue with PrBoom+ software renderer. GlBoom+ runs butter smooth tho.

 

Eternity Engine's software renderer is slightly choppy too, but less than PrBoom+'s software renderer.

Share this post


Link to post

It probably helps to enable uncapped framerate when playing with the Software renderer. 

Share this post


Link to post
25 minutes ago, Sector 147 said:

What's the difference between PrBoom+ and GlBoom+?

 

GlBoom+ is the executable with the OpenGL render of the port, but supposedly, you can switch to the Software one in it as well if so is desired.

Share this post


Link to post
Posted (edited)

Uncapping the framerate just makes it more noticeable. Eternity ran butter smooth for me though.

Actually I wanted to use PrBoom+ as a baseline to make sure glitches didn't carry over, and software renderers tend to differ between source ports.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×