Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

GZDoom - Problem on OpenGL, flashy textures and menu, etc

Recommended Posts

Lately I've been trying to setup OpenGL in GZDoom to work on my laptop, and everytime I do that I get this weird buggy appearance where textures and menu words appear and disappear every single millisecond. A screenshot:




This happens in the last version of the source port. Also, I tried a vintage version, I think 2.x, basically older versions of GZ and the same issue is still there. It's not the custom wad because it happens with the iwad too. Neither fullscreen or windowed mode work, nor changing the resolution, tried every setting in the configuration (OpenGL renderer) and nothing. Enemies, basically "things" don't seem to bug. 


Some information about my system:



It's a laptop, HP.


Renderer: AMD Radeon HD 7640G

RAM: 512 mb

Processor: AMD A804500M APU with Radeon(tm) HD Graphics, N/A, Familiy fh, Model: 10h, Stepping: 1h 

OpenGL version: 4.2

Driver: 8.941.0.0 (.dll) Catalyst 8.941.4, 26-jan-12

DirectX: DirectX 9, 11.0


I guess this is enough information, let me know if something else is needed. I'm not really sure what to do, probably update the drivers but if there's a simpler solution, I'd be very grateful to know. 


Also, I know they are different source ports but OpenGL in GLB+ has always worked fine.

Share this post

Link to post

That driver is ANCIENT. More importantly, it's from a time when AMD's OpenGL drivers were suffering from massive problems. There should definitely be something more recent that works better.


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now