Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Bonific

How do i run brutal doom? +error

Recommended Posts

Hi, I'm new in all of this world of doom, and so i downloaded BDooM v21, I have the "free" version of doom and I only have the DOOM1.WAD and the ZDOOM, nothing more all the other things ara save and all that stuff, I saw i few tutorials and even the "official" tutorial that is with the BDOOM.zip and i had all the things I needed (I think so) and when I executed the program with the mod it showed this error:

 

Script error, "bd21RC8.pk3:dead.txt" line 1638: "NOTONAUTOMAP" is an unknown flag

 

Script error, "bd21RC8.pk3:flares.txt" line 7: "NOTONAUTOMAP" is an unknown flag

 

And then it showed me another error:

 

Script error, "bd21RC8.pk3:puff.txt" line 546: Expected ')', got '.'

 

And that's it, any suggestion?

Share this post


Link to post

By "free" version do you mean shareware? Just Episode 1? If so I don't think you can really do much with it, however you can try FreeDoom ,https://freedoom.github.io/download.html , and make sure you're using GZDoom 3.0 and up, or Zandronum 3.0. ZDoom 2.8.1 plays well from my experience but I think certain effects won't work so its best to use GZDoom. I use ZDL, makes loading mods and map packs SO MUCH easier, but if you're using FreeDoom you have to point it out in Iwads in Settings of ZDL, otherwise it'll say no iwad found. Here's ZDL link: https://forum.zdoom.org/viewtopic.php?f=44&t=32596

Share this post


Link to post
1 minute ago, Beezle said:

By "free" version do you mean shareware? Just Episode 1? If so I don't think you can really do much with it, however you can try FreeDoom ,https://freedoom.github.io/download.html , and make sure you're using GZDoom 3.0 and up, or Zandronum 3.0. ZDoom 2.8.1 plays well from my experience but I think certain effects won't work so its best to use GZDoom. I use ZDL, makes loading mods and map packs SO MUCH easier, but if you're using FreeDoom you have to point it out in Iwads in Settings of ZDL, otherwise it'll say no iwad found. Here's ZDL link: https://forum.zdoom.org/viewtopic.php?f=44&t=32596

Yes, i mean shareware and i can play all episodes, btw i'm installing zandronum 3.0, also thanks for the ZDL information

Share this post


Link to post
1 minute ago, Bonific said:

Yes, i mean shareware and i can play all episodes, btw i'm installing zandronum 3.0, also thanks for the ZDL information

Let me know if that works and if not, what else is loaded. Never tried loading mods with the shareware version.

Share this post


Link to post

It works! I didn't load it with ZDL but with Zandronum yes, maybe i was using an old version of ZDoom, thank you so much :D

Share this post


Link to post

zdoom isnt maintained anymore, gzdoom has taken its place

Share this post


Link to post
3 hours ago, Bonific said:

Yes, i mean shareware and i can play all episodes,

 

This doesn't quite add up. The shareware version only has the first episode in. If you have all the episodes then you've got the full, commercial version of the game.

 

Either way though, yeah, you need an up-to-date version of either Zandronum (arguably Doom's most advanced multiplayer source port) or GZDoom (arguably Doom's most advanced singleplayer source port) to play the latest version of Brutal Doom.

Share this post


Link to post

Honestly, you should go and get the full version, it's cheap and not bank breaking.

Share this post


Link to post
Posted (edited)
4 hours ago, Bauul said:

 

This doesn't quite add up. The shareware version only has the first episode in. If you have all the episodes then you've got the full, commercial version of the game.

I have the Doom1.wad and I can play all the levels, so i don't know.

 

Also thanks for the information to all, anyway I can't buy DOOM, if i could i would do it, but i can't, i don't any money source and i can't a job, at the moment, but if i can get some pocket money or something i'll buy all the 3 chapters/games/episodes/whatever.

Share this post


Link to post

Honestly, what is it with these people and not wanting to buy Doom? I've noticed this pop up recently.

 

Doom costs 5 dollars on Steam. Doom 2 costs 5 dollars on Steam. Final Doom costs 5 dollars on Steam. Master Levels costs 5 dollars on Steam.

 

It can't be because they can't afford it nowadays, because these old games are dirt cheap on Steam and some people still refuse to buy them. I will come to the conclusion that it's not because they can't afford it, but rather since the game happens to be an old MS-DOS game, they'll assume it's abandonware. (Despite the fact that the source code has been released, thus preventing it from being abandonware.)

Share this post


Link to post

I thought Master Levels was still pretty pricey, or is that the on sale price?

Share this post


Link to post

I think Bonific's confusion steems from the fact that the Episodes appear to be selectable.

Try to select another episode and you'll see.

 

3 minutes ago, Edward850 said:

Neither, crazyflyingdonut failed a spot check. Master Levels is not sold independently and can only be bought as part of the Doom Classic Complete package: https://store.steampowered.com/sub/18397/

 

GOG's the better option if you already own Ultimate Doom https://www.gog.com/game/doom_ii_final_doom

Share this post


Link to post

There's no point in buying licensed Classic Doom if you're not a collector or fan. Most of the best gameplay mods and megawads can be played with Freedoom.

But if you want, in Russia you can buy Steam Doom Classic Complete (Ultimate Doom, Master Levels for Doom II, Doom II, Final Doom) for 5.5 USD.

Share this post


Link to post
Posted (edited)
3 hours ago, Edward850 said:

Neither, crazyflyingdonut failed a spot check. Master Levels is not sold independently and can only be bought as part of the Doom Classic Complete package: https://store.steampowered.com/sub/18397/, same with GOG: https://www.gog.com/game/doom_ii_final_doom

It is bundled with Doom 2 itself (on Steam, at least), so why do I need to spend $15 just to get an expansion?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×