Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
memes4lyfe

quake 4 goes back to the main menu after selecting "new game"

Recommended Posts

every time I select new game, I get a loading screen and I get sent back to the previous screen.  how can I fix this? and no. it has nothing to do with drivers. it's never drivers. I would like some advice on how to start the game rather than just "update your drivers cause that works for me and no one else!"

Share this post


Link to post
Posted (edited)

Check your drivers.

 

Jokes aside, I don't like your attitude, but here's an idea: check your q4base/Quake4Config.cfgQuake4Config.cfg and see if "seta com_videoRam" and "sys_videoRam" aren't set higher than your CG memory.

If it doesn't work check your drivers.

Share this post


Link to post

ok. sorry for being so salty, it`s just that I don't really think that the drivers have anything to do with it, that's all.

Share this post


Link to post

Well sometimes it's good to follow people's suggestions no matter your beliefs (?) unless they try to sell you snake oil or something.

 

Anyway, tell us how it goes with tweaking the variables I mentioned.

Share this post


Link to post

Have you tried to reinstall it? Try a fresh install and failing that, the steam community boards are normally golden for bugs etc.

Share this post


Link to post

That's another idea indeed. If it's a Steam version, it's worth checking file integrity too.

Share this post


Link to post

i think it's one of two things: my sound card doesn't support openAL, or the game is broken.

Share this post


Link to post

Did you check the in-game console? Maybe it's printing out some error message you don't see without looking at it.

Share this post


Link to post

Do you have a sound card or just running your sound from the back of the mobo?

 

It's highly doubtful that the game is broken. What are your PC stats just out of interest?

Share this post


Link to post

I have an acer laptop running windows 10. I have an AMD A6-7310 APU with AMD radeon R4 graphics. (4 CPUs), \2.0GHz

VRAM is 1012, and 8192MB of RAM.

Share this post


Link to post

Boris' suggestion is probably your best shot. Launch the game with "+set com_allowconsole 1" and see what the console comes up with after you got kicked back to the main menu.

Share this post


Link to post

to see if it's not my computer that's the problem, I'll use a digital version of quake 4.

Share this post


Link to post

ok. so the digital version had no problems whatsoever.

I was using a cd version of the game that I patched myself with a new pak003.pk4 file and the latest patch when this happened. now the digital version however did not kick me to the menu.

Share this post


Link to post
8 hours ago, memes4lyfe said:

I was using a cd version of the game that I patched myself with a new pak003.pk4 file and the latest patch when this happened

That was like a super important detail to give us outright. We would have given you better methods to troubleshoot the issue.

Share this post


Link to post
5 minutes ago, Kira said:

That was like a super important detail to give us outright. We would have given you better methods to troubleshoot the issue.


With a handle like 'memes4lyfe' were you expecting otherwise?

Share this post


Link to post
14 hours ago, memes4lyfe said:

ok. so the digital version had no problems whatsoever.

I was using a cd version of the game that I patched myself with a new pak003.pk4 file and the latest patch when this happened. now the digital version however did not kick me to the menu.

 

>modifies important game file

>"Idk why my game isn't working!"

 

Details are important my friend! :)

Share this post


Link to post

One small tip: these days messing with CD installs of older games on modern OS it's usually asking for trouble, assuming you can even get past the install. If there's a digital version, get that. It's most likely already patched up and ready to play apart from some tweaking.

 

In rare cases you may or may not need additional patches. For me, I had to use the unofficial patch for Unreal Gold to make it playable even though people say the Steam version is fine.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×