Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
V0idH0und

How the hell do you get the built in Timidity++ or GUS for GZDoom to work?

Recommended Posts

Can't figure it out, and I can't find any documentation for it, only the standalone version. I ripped the patches from the XBLA version of Doom 1 & 2 and I want to use them with GZDoom 4.0 so I can have XBLA music.

Share this post


Link to post

And for Original GUS patch sets, the easiest way is to zip it all up. But don't expect to be able to create your own one - whoever developed that control file format must have been insane, bad as it is.

 

Unfortunately, the GUS and WildMIDI players require a GUS patch set to work as intended. The GUS synth nominally can handle SF2 but the feature seems to be broken., they sound like garbage.

 

Share this post


Link to post
16 hours ago, Kappes Buur said:

https://forum.zdoom.org/viewtopic.php?f=50&t=60388&p=1051895

 

Configure Timidity++ in Sound Options.

Stick the sf2 file into the Soundfonts folder.

 

15 hours ago, Graf Zahl said:

And for Original GUS patch sets, the easiest way is to zip it all up. But don't expect to be able to create your own one - whoever developed that control file format must have been insane, bad as it is.

 

Unfortunately, the GUS and WildMIDI players require a GUS patch set to work as intended. The GUS synth nominally can handle SF2 but the feature seems to be broken., they sound like garbage.

 

As far as I know, it doesn't have a sf2 file. So unless someone made one...

 

I can't get it to detect the patches no matter what I try. :/

Share this post


Link to post
Posted (edited)

Don't know if ths will work on GZDOOM, I only tried ZDOOM

 

Create a shortcut of the GZDOOM.EXE in the same folder as the original .exe, rightclick it and click properties.

 

put:  -file ''full name of patch here" on the target line box.  and hit enter

 

If that doesn't work... try dragging the gus patch on top of the .exe shortcut.

 

I messed with the gus patches on ZDOOM... but i like the OPL one more. 

Share this post


Link to post
7 hours ago, V0idH0und said:

I can't get it to detect the patches no matter what I try. :/

 

GZDoom cannot "detect patches". Even a GUS patch set needs to come with some sort of configuration so that the player knows what to use for which instrument, and if that isn't present there's no chance it'll work.

How to write such a configuration is a different matter. I've never written one and the entire format is a bit archaic. All I can suggest is to download an existing GUS patch set, see how it handles this and then try to replicate it.

Share this post


Link to post
9 hours ago, Graf Zahl said:

 

GZDoom cannot "detect patches". Even a GUS patch set needs to come with some sort of configuration so that the player knows what to use for which instrument, and if that isn't present there's no chance it'll work.

How to write such a configuration is a different matter. I've never written one and the entire format is a bit archaic. All I can suggest is to download an existing GUS patch set, see how it handles this and then try to replicate it.

Yeah, I meant I couldn't get it to detect the config file. Where exactly is the config file supposed to be? The wiki doesn't really say. Honestly the wiki tells you the commands needed to set it up, but doesn't really tell you where anything is supposed to go.

Share this post


Link to post

If you have a complete patch set with config file, make sure that all paths in the config file are relative and only point to subdirectories.Then make sure that the config file is named timidity.cfg. After that zip it all and put the archive into the soundfonts folder of your GZDoom installation. After that the engine should list it in the setup menus as an available option.

 

Share this post


Link to post
Posted (edited)
54 minutes ago, Graf Zahl said:

If you have a complete patch set with config file, make sure that all paths in the config file are relative and only point to subdirectories.Then make sure that the config file is named timidity.cfg. After that zip it all and put the archive into the soundfonts folder of your GZDoom installation. After that the engine should list it in the setup menus as an available option.

 

Couldn't load the instruments. I'm guessing I'm going to have to rewrite the config.

 

10 hours ago, Graf Zahl said:

All I can suggest is to download an existing GUS patch set, see how it handles this and then try to replicate it.

I'll try that.

 

EDIT:

Yeah, I don't think I'm getting it to work.

Worse case scenario, I have to sound capture the music from bfg edition with audacity.

Edited by V0idH0und

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×