Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
G01000011

Dynamic lighting problem in GZDoom 4.1.1 x64

Recommended Posts

Posted (edited)

Hi,

 

I'm making a map and was testing in GZDoom 3.5.0 x64, things looked like this:

 

Screenshot_Doom_20190525_143107.png.e0236b1279347135df83b2849eed8583.png

 

Now upon testing in GZDoom 4.1.1 x64 I get this:

 

Screenshot_Doom_20190525_143028.png.486e5f706c031468052fe3df752b224a.png

 

Is there something I'm missing? I have the same options selected on both.

 

Thanks.

Share this post


Link to post

As a first step, I'd suggest upgrading to 4.1.2 (the latest release) and seeing if the issue perseveres. 

 

Also, are you running the new Vulkan renderer?

Share this post


Link to post

Hi Bauul. It's still doing it in 4.1.2B x64. I'm just using 'Hardware Accelerated', I've tried Vulkan and it does the same. I'm going to try and edit a copy of the level, in this area there are negative dynamic lighting spots to make darkness. Also I want this to work when I release it on the latest version.

Share this post


Link to post
Posted (edited)

I meant to say Subtractive lighting. Somehow the older version was registering as fine on a cranked up RGB setting, then the new one was resgistering it for what it is. I tweaked the values down and it seems to be all right now in both, so I don't know what 3.5.0 x64 was up to? Thanks.

Share this post


Link to post
On 5/25/2019 at 10:21 AM, G01000011 said:

I meant to say Subtractive lighting. Somehow the older version was registering as fine on a cranked up RGB setting, then the new one was resgistering it for what it is. I tweaked the values down and it seems to be all right now in both, so I don't know what 3.5.0 x64 was up to? Thanks.

Did you try adjusting Sector Lighting? That makes a huge difference if its on Dark. I prefer on Doom or Standard.

Share this post


Link to post

Hi BeezIe. I always have it set to Doom. It seems to be all right now with an edit made to the lights. There were Subtractive lights at 900 on RGB. I set these and the radius down and it seems to be good now. I just don't understand how the older version was presenting it as lower?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×