Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
One Doomed Bunny

Actor is double defined even though it is not. What?

Question

Greetings,

 

I have just started making my brand new mod. When I try to make maps for it there are tons of errors but this one is the most weird to me:

 

"DECORATE error in "MOD.pk3\decorate", line 107. Actor "Flare" is double-defined"

 

Now of course I went and checked if this was all true and blimey...it is only defined ONCE in that one decorate file.

Any clue or help would be very much appreciated.

 

Thanks,

One Doomed Bunny

Share this post


Link to post

11 answers to this question

Recommended Posts

  • 2

What is the actor's ED Number? If it's one that is already defined either internally or from another actor in your DECORATE, doom doesn't like it. If that fails, try giving the "flare" a slightly different name and see if that works.

Share this post


Link to post
  • 1

Some warnings can be ignored in the editor. They will not affect anything once in-game. Test your level and if everything works there, no problem.

Share this post


Link to post
  • 1

Not having an ED number can sometimes be a problem. Typically I start with something like "Actor banana 15000" just so that I can easily find it when I wish to place it.

Share this post


Link to post
  • 1

What happens if you rename flare to something else, like "my_flare" and update all corresponding references accordingly?

Share this post


Link to post
  • 1

I had this problem too and I discovered that for testing I accidentally ran two pk3 files at once and that was causing the error to appear.

Share this post


Link to post
  • 0
13 minutes ago, DynamiteKaitorn said:

What is the actor's ED Number? If it's one that is already defined either internally or from another actor in your DECORATE, doom doesn't like it. If that fails, try giving the "flare" a slightly different name and see if that works.

It does not have an ED number. I gave it another name and now that error is gone so thank you.

However, now I have a bunch of ones like this:

 

DECORATE warning in "MOD.pk3\decorate", line 139. Unable to find "BlueTorch" class to replace, while parsing "TallTorch_Blue"

 

Here is the "BlueTorch" class: https://zdoom.org/wiki/Classes:BlueTorch

This is so confusing for me...

Share this post


Link to post
  • 0
On 5/26/2019 at 5:27 PM, Nevander said:

Some warnings can be ignored in the editor. They will not affect anything once in-game. Test your level and if everything works there, no problem.

Oh, okay. That always weirded me out by having so many errors but running fine. Also sorry for the late reply. Thanks!

 

Share this post


Link to post
  • 0
On 5/27/2019 at 2:40 AM, DynamiteKaitorn said:

Not having an ED number can sometimes be a problem. Typically I start with something like "Actor banana 15000" just so that I can easily find it when I wish to place it.

Ok, might try that. Thanks! Sorry for the late reply.

Share this post


Link to post
  • 0
On 5/27/2019 at 11:28 AM, Gez said:

What happens if you rename flare to something else, like "my_flare" and update all corresponding references accordingly?

Yes. I renamed the flare actor and it worked then. Kinda weird. Thanks and sorry for the late reply.

Share this post


Link to post
  • 0
On 5/27/2019 at 9:42 PM, Szuran said:

I had this problem too and I discovered that for testing I accidentally ran two pk3 files at once and that was causing the error to appear.

Hmmm. Well I am running just this one pk3, a gzdoom pk3 along with a DOOM2.wad

Also sorry for the late reply.

Thanks.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×