Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
xdarkmasterx

prboom plus mouse bug

Recommended Posts

Posted (edited)

yo sorry to be a bother but my post in prboom main thread didn't get many replies so hopefully it will get more views in its own thread

 

original post:

 

i've been having a lot of trouble getting mouse to work properly in this port in windows 10. before "creator update" from 2017, this port worked fine, but after the update, mouse movement has become very choppy and randomly "warps" to the side when looking around (as if you suddenly jerked the mouse to one side or the other).

 

i have tried using latest test version which uses SDL2 (2.5.1.5.test), but the mouse movement then becomes very slow, and choppiness persists. i've tried replacing SDL.dll with several other iteration, but either it will not have any significant effect, or will cause the mouse to become completely unusable.

 

has anyone ever found fix for the problem? i have searched some times this site and others but have found no solution that works for me

 

also, PRboom plus is the only port I've tried in which i run into such Problem as that. vanilla, chocolate doom, crispy doom, and gzdoom do not display some issue with the mouse at all

 

Share this post


Link to post

I experienced something similar a couple of times in prboom+ on Delta Touch, but thought it was an issue of the way DT handles mouse movement. Maybe there's more to it, it seems.

Share this post


Link to post

if you have a gaming mouse and it has a config program, try turning down the Polling Rate.

 

my mouse defaults to 1000 but some source ports indeed give me mouse issues, but turning it down to 128 fixes it

 

if you dont have a mouse that allows that then i dont think theres a way to change it

Share this post


Link to post
Posted (edited)
5 minutes ago, kaleb. said:

if you have a gaming mouse and it has a config program, try turning down the Polling Rate.

 

my mouse defaults to 1000 but some source ports indeed give me mouse issues, but turning it down to 128 fixes it

 

if you dont have a mouse that allows that then i dont think theres a way to change it

 

i'm afraid not

 

i doubt completely it is problem with he Mouse, at least not in entirety, because in beginning prboom works fine, but after "creators update", this port and many other games (quake, half life, unreal) acquire same Problem, but much worse and more obvious (in half life for instance I could not adjust my aim without it snapping back to its original position in under a second) i have fixed in all others by replacing SDL .dll with a "fixed" version but have not had same Luck with prboom (and in some interation does the "fix" makes it even worse)

Share this post


Link to post
Posted (edited)

i had this problem with Eternity Engine and Quakespasm after the windows 10 update and it was only fixed when they switched to SDL2. so i think the problem is just SDL1. not sure what's wrong with the PRBoom sdl2 version you mentioned though?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×