Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Tuckymonster

weapon in iwad not working

Question

Posted (edited)

here is my code 


ACTOR magnum : weapon 1 {
    Weapon.BobStyle InverseSmooth
    Weapon.BobSpeed 2.1
    Weapon.BobRangeY 0.3
    Weapon.BobRangeX 0.6
    Weapon.AmmoType "ammo"
    Weapon.SelectionOrder 1
    Obituary "%k died from a magnum blast by the magnum lord %o"
    
    States {
    
    Spawn:
    MGNT G -1
    STOP
    
    Select:
    MGNT A 1 A_RAISE
    loop
    
    Deselect:
    MGNT A 1 A_LOWER
    loop
    
    Ready:
    MGNT A 1 A_WEAPONREADY
    loop
    
    FIRE:
    MGNT A 0 
    MGNT BCDEF A_FIREBULLETS(0,0,
    MGNT A 0 A_REFIRE("FireS")
    MGNT A 1
    goto Ready
    
    
    FireS:
    MGNT BCDEF A_FIREBULLETS(0, 0, 1, 10)
    MGNT A 0 A_REFIRE("FireS")
    goto Ready
    }
}



i put this in my PK3 witch is an iwad being read from GZDOOM.PK3

and when i launch it

i get this

 

Script error, "my pk3 file and dir" line 30:
SC_GetNumber: Bad numeric constant "A_FIREBULLETS". 

what does it mean and how can i fix it?

Edited by Tuckymonster

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 1
8 hours ago, Tuckymonster said:

   MGNT BCDEF A_FIREBULLETS(0,0,

You have the sprite name, some frame letters, but no frame duration.  It is expecting to see the number of tics for those frames, but instead, it sees A_FIREBULLETS.

Share this post


Link to post
  • 0
37 minutes ago, DynamiteKaitorn said:

MGNT BCDEF A_FIREBULLETS(0,0,

 

Where's the " ) " ?

*face palm*

i did, but same error

Share this post


Link to post
  • 0
2 minutes ago, xvertigox said:

The wiki link has an example.

Script error, "my dir" line 30:
SC_GetNumber: Bad numeric constant "Bright".
 

Share this post


Link to post
  • 0
12 hours ago, Empyre said:

You have the sprite name, some frame letters, but no frame duration.  It is expecting to see the number of tics for those frames, but instead, it sees A_FIREBULLETS.

i reworked the code, i got this error 

 

Execution could not continue.

1 errors during actor postprocessing

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×