Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ChicagoTrash

Doom 2016 not responding

Recommended Posts

I recently installed Doom 2016. Whenever I attempt to launch it, it loads up to 99% and then it starts not responding. The start theme then starts playing but the audio is really choppy. I've tried basically everything. Anyone have any ideas? Thanks for your time.

Share this post


Link to post

I'm assuming your PC is strong enough to run the game in the first place, right?

Share this post


Link to post
6 hours ago, KVELLER said:

I'm assuming your PC is strong enough to run the game in the first place, right?

Yeah. It's not great but it should work.

Share this post


Link to post
On 6/14/2019 at 3:53 PM, silentzorah said:

Try running it with the Vulkan API.  I had the same issue until I did that.

Sorry if this question makes me sound like an idiot, but how do I do that? I can't change it in-game because it starts not responding before I can reach a menu. 

Share this post


Link to post

I have the opposite problem, I enabled Vulkan to see if it would run better, but now it just crashes on start up, I'm glad it's the free demo that broke.
To be fair, it ran pretty well in GL on a medium/high mix 1080.
 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×