Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
wolfmcbeard

Weird issue with dynamic lights not working in GZDoom 4.1.1

Question

I've had a weird issue with dynamic lights not working when the wad is played, this is occurring on multiple wads.
Is the wad already broken, or is this just a bug in GZDoom4.1.1? 
Can I fix it?
How do I fix it?

MAP01 (edit area) at 2019.06.26 06-46-16.394 [R3058].jpg

Screenshot_Doom_20190626_064637.png

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

Make sure you don't have the "dormant" flag on for the lights. I've done that. Also make sure they have all the difficulty settings flags checked so they will appear in all settings.

Share this post


Link to post
  • 0

I remember I once seen someone turned off dynamic lighting in the GZDoom settings and forgot to turn it back on, during gameplay. So they seen dynamic lights while editing but it was gone during gameplay. I believe they are in the display options then dynamic lighting. I think you have to access it while playing the map.

Share this post


Link to post
  • 0

educated guess: you put your light sources "on the floor" (either directly, or by using vanilla format instead of doom-in-hexen). in doom, "on the floor" actually means "IN the floor", therefore your light source is completely culled by the floor surface.

 

switch to "doom-in-hexen" map format, and rise your light sources a little.

Share this post


Link to post
  • 0
Posted (edited)

@ketmarI can't change it from UDMF from the looks of it, I'm not sure what the cause is since some maps do this when running and other maps work just fine.

@Immorpher I checked my settings, but dynamic lighting is on, I even tried the ol' turn it off and on again method and somewhat unsurprisingly it didn't work.


I've only had this issue come up recently over the last two weeks and it's getting a tad annoying.

Share this post


Link to post
  • 0

UDMF is even better than Doom-in-Hexen.  Raise the lights up from the floor like ketmar said (Z position) and that should fix it.

Share this post


Link to post
  • 0
Posted (edited)

yeah, what @Empyre said: UDMF is even better. also, note that sometimes "light source on the floor" may work, and sometimes it may fail. this is a weird corner case, and engine behavior is undefined in such cases. just make sure that your light source is not "on a floor" (or "on a ceiling"), and not in the wall, and the problem should go away.

 

to be on a safe side, make sure that your light sources are at least 8 units away from floors, ceilings and walls. this should always work as expected.

Share this post


Link to post
  • 0
53 minutes ago, Payload4367 said:

Make sure you don't have the "dormant" flag on for the lights. I've done that. Also make sure they have all the difficulty settings flags checked so they will appear in all settings.

I'm not sure why, but they were indeed set to dormant, I didn't think to check since nothing else has that tag.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×