Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Tuckymonster

Texture Lump

Question

7 answers to this question

Recommended Posts

  • 0
Posted (edited)

If you are mapping in vanilla or boom format, the PNAMES and TEXTUREx lumps are still extremely important, as they define what exactly the textures are and how they should be assembled from the various patches that are contained in the WAD.

 

If you are mapping for Gzdoom, you don't have to use those lumps. You can instead place your textures between TX_START and TX_END markers, or in the /textures folder if you are using the pk3 structure. Gzdoom also has the TEXTURES lump for more complex creations.

Share this post


Link to post
  • 0

@Spie812 thanks! but i having a problem. when i use a glass texture that transparent. i get this blue background instead of clear with the white lines. is that something just in the editor? or a error?

Share this post


Link to post
  • 0
Posted (edited)

I know little regarding that. SLADE's Graphic→Convert to... menu has some transparency options that might fix that problem. That's my only guess.

Share this post


Link to post
  • 0
1 minute ago, Spie812 said:

I know little regarding that. SLADE's Graphic→Convert to... menu has some transparency options that might fix that problem.

k. let me try that

Share this post


Link to post
  • 0
5 minutes ago, Spie812 said:

I know little regarding that. SLADE's Graphic→Convert to... menu has some transparency options that might fix that problem.

is that all you know? cuz there is a bunch of opions and tranpant stuff.

Share this post


Link to post
  • 0
Posted (edited)

Yeah, I know little about getting that sort of stuff to work. I'm just guessing here. Screw around and see what works and what doesn't. Sorry I can't be more helpful than that.

Share this post


Link to post
  • 0
1 hour ago, Tuckymonster said:

@Spie812 thanks! but i having a problem. when i use a glass texture that transparent. i get this blue background instead of clear with the white lines. is that something just in the editor? or a error?

In vanilla DooM, the patch itself needs to have the transparency built into it. In some editors the convention is to allow the transparent parts of an image to show as cyan (a shade of blue that is absent from the native doom palette). [This, of course, depends on the image format; native DooM format images use cyan. In PNG format, however, if you use cyan without indexing it as transparent, it will show up in-game as cyan.] Therefore, when you place the patch/texture into a map, the cyan parts are rendered as completely transparent.

 

It sounds like you might either have:

 

1. A native DooM format patch with a shade of blue to represent the transparent parts of the image, but that shade of blue is not cyan; or

2. A PNG format patch where the blue to which you are referring is not indexed as transparent; or

3. A completely different image format where your blue cannot be rendered as transparent because the image format does not support transparency (e.g., JPEG).

 

In many source ports, you don't need to rely on patches/textures with in-built transparency. You can take an otherwise "solid" texture, such as SHAWN2, and apply transparency/translucency to it within the map editor. [For example, refer to the ZDooM wiki on how to create a translucent line.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×