Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
DoomSpud

Hidden sectors till visible on automap...

Question

Hey everyone...

Was wondering if any of my fellow Doomed could help me with this little issue im having?

It's a 3D-floor control sector outside of the map that I want to hide from the automap but when I playtest, "TAB", "IDDT" x2... I can still see it. Along with all the other control sectors I've set to hide from the map... am I doing this wrong? is there another way?

Any help with this would be great appreciated. Cheers.


Image1.jpg.5be1b7290bca6e07e06891d30277beaf.jpg

Image2.jpg.07705a2a17336938c8dbea10d82a9e5d.jpg

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

That flag only disables drawing the sector on the textured automap. To hide the lines you'll have to enable the sidedef flag, as @Empyre said. So you should use the flags on both the sector and the sidedef to make sure to completely hide the sector no matter what the automap settings are. IDDT  will still show everything, though.

Share this post


Link to post
  • 0

The use of 2 iddt codes makes all the automap visible, ignoring the "not shown on automap" tag of a linedef.

Having that this is a cheat you have nothing to worry about, because I suppose that your map is intended to be played without cheats.

Share this post


Link to post
  • 0
14 minutes ago, Simomarchi said:

The use of 2 iddt codes makes all the automap visible, ignoring the "not shown on automap" tag of a linedef.

Having that this is a cheat you have nothing to worry about, because I suppose that your map is intended to be played without cheats.


I suspected that may have been the case, that 'IDDT' x2 ignores the flag on the sector and just displays everything, if it's meant to be seen or not. Guess there isn't really a way around that is there? That would be hardcoded I'd imagine?

And yeah, I always map to be played without the need to cheat.

Cheers for the advice. Sounds like one of those "it's just how it is" things...

Share this post


Link to post
  • 0

The flag that hides a sector in the automap is not on the sector itself, but on the linedefs.  Enter Linedef mode and select the lines you want hidden, and then Right-click them and check the Not Shown on Map flag.

Share this post


Link to post
  • 0
7 minutes ago, boris said:

That flag only disables drawing the sector on the textured automap.

I just learned something new.  I like learning new things!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×