Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
StevenC21

GZDoom Builder Bugfix Will Not Launch

Question

I am running Windows 10 Home, and I am sure that I have installed all prerequisites, including .NET 4.6.1 and DirectX 9.0c. Strangely, GZDoom Builder runs. Only the newer version fails. There is no error message, when running from a GUI or a commandline - the program simply never opens a window in the first place.

 

Does anyone have any insight into this odd behavior?

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0
Posted (edited)
5 hours ago, StevenC21 said:

I am running Windows 10 Home, and I am sure that I have installed all prerequisites, including .NET 4.6.1 and DirectX 9.0c. Strangely, GZDoom Builder runs. Only the newer version fails. There is no error message, when running from a GUI or a commandline - the program simply never opens a window in the first place.

 

Does anyone have any insight into this odd behavior?

 

Install SlimDX Runtime.NET 4.0 (January 2012), either x32 or x64 depending on the editor downloaded.

 

Maybe my tutorial could be useful for others

Edited by Kappes Buur : added a link to my tutorial

Share this post


Link to post
  • 0

I had a similar problem after updating to Windows10. What I did was, download a very old version of GzDBBF, which ran for some odd reason and then update from within that version. Since then it works.

Share this post


Link to post
  • 0

There are no old versions available - including, frustratingly, from DRDTeam's "old" dev build R3012, which they link to as the last version to use .NET 3.5 (the link 404s).

 

Any other ideas?

Share this post


Link to post
  • 0
Posted (edited)

I had that same weird issue. And, the solution was, updating my GPU drivers. GZDoom Builder from r2787 will for 100% for all users, no problem. But, in later versions, looks like the OpenGL version is another requirement for the program for some strange reason. Having OGL 3.3 after upgrading my gpu did the trick.

 

EDIT: I have Win7 Starter. Can be different from Win 10 but, it's worth to try...

Share this post


Link to post
  • 0

Is there a way to still download the r2787 from somwhere? I think that was the version I updated from to make it work.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×