Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Silliest Putty

How to record Eviternity Demo with .bat

Recommended Posts

So I've saved "c:\games\doom\gzdoom\gzdoom.exe -iwad Eviternity.wad -warp 10 -skill 4 -record UVSpeed10.Imp" as a .bat and I get an error "R_InstallSprite: Sprite BSPI frame A is missing rotations"

 

Am I missing something?

Share this post


Link to post

Make a .bat file in the right folder and give "gzdoom -iwad doom2.wad -file eviternity.wad -complevel 11 -warp 10 -record evit10- -skill 4" in that .bat file a go. Make sure your doom2.wad is in the same folder.

Sorry if this doesn't work for you, I'm still learning my way around this stuff myself, but I just gave this a go and it worked for me. 

Share this post


Link to post

You were attempting to load a PWAD as an IWAD?

 

That's... new.

Share this post


Link to post

Incidentally most people don't tend to record demos with GZDoom, because they only work with that exact version of GZDoom. People tend to use PRBoom+ (or ZDoom 2.8.1 now that's version locked) to avoid this issue.

Share this post


Link to post

Would the .bat be the same for PRBoom+ and ZDoom 2.81? besides the path of course.

 

5 hours ago, MFG38 said:

You were attempting to load a PWAD as an IWAD?

 

That's... new.


I'm new.  Did you come here just to pick on me?

Share this post


Link to post
Posted (edited)

So I just finished a run I'm happy with using ZDoom 2.8.1 Eviternity Map 10, I have the .lmp file, and I'm not sure how to play it back.

 

Are ZDoom 2.8.1 demos eligible for speed run records?

 

I used my allotted new member posts for today, oops :)

 

EDIT:  I've gotten it to play the demo, but instead of doing so on Eviternity.wad map10 it's on Doom2 map10

 

"ZDoom -playdemo c:\Games\Doom\ZDoom281\evit10-"

 

I've been looking around the forums for this stuff, but as someone who has only just started speed running, my search-fu doesn't quite seem to be up to snuff.

 

evit10uvspeed ZDoom 2.8.1

 

Screenshot_Doom_20190715_155833.png.b759770970bdccb748de8d66ea5b69f7.png

Edited by Silliest Putty

Share this post


Link to post
Posted (edited)
16 hours ago, Silliest Putty said:

I'm new.  Did you come here just to pick on me?

 

I didn't, in fact. But given your mistake, it would explain the error message at the very least.

 

I do have to say that this is the first time I've seen anyone doing that mistake.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×