Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
([zen3001])

Basic key Actor not working properly

Question

ACTOR SilverKey : Key 881{
	scale 0.5
	Inventory.PickupMessage "You picked up a silver key."
	Inventory.icon "SKEYA0"
	States{
		Spawn:
			SKEY A 1
			Loop
	}
}

the player doesn't take the key in inventory when picking it up from the map, only when I type "give Silverkey" in the console does the engine notice that I have it in my inventory, doing that makes everything work as if i had the key but when I pick up the key from the map instead of typing the command the script/door just acts like as if I don't have it...

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

Maybe my tutorial will help you.

Open the pwad (green-key_new-DiH.wad) in an editor, Slade3 or GZDB or GZDBBF, to see how I set it up.

 

If you are in doubt about how to proceed further, then the WIKI is a good place to get more information, for example

https://zdoom.org/wiki/Key

Edited by Kappes Buur

Share this post


Link to post
  • 0

i don't know where I'm supposed to get that pwad. Can't find any link on your tutorial site. just judging from your tutorial tho I allready tried everything mentioned in it and allready read through the wiki everything about keys. even tried to install on of realm667's keys and not even those are working

Share this post


Link to post
  • 0

When you move the cursor over the map image, the pointer changes from a small arrow to a hand with the index finger extended, which indicates a link. Clicking on that map image gives you the download link for the pwad.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×