Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Lillium

Imps in the Floor

Recommended Posts

I'm encountering a bug in my map where a couple of imps end up in the floor/wall. They are walking about on a ledge overseeing an area I visit early on. Sooner or later, those imps end up in the floor. They are some ways from their spawn points so they definitely appear to be 'walking' there. I can't get in the floor myself. If I go up on the ledge I can see them stuck in their walk animation in the floor. Or, from below, hear their snorkle-snorkle in the wall. I've eyed over the area in GZDoom builder, but can't see anything odd about it. I'm playing in gzdoom. Anyone encounter this issue or know of a fix/what is going awry?

Share this post


Link to post

I've experienced this before. I know nothing, so more informed people can give you a more informed answer, but I've only had two theories about it: it happens in larger maps and/or it happens with very fine and irregular geometric shapes. So is your map huge (20,000+ in any direction)? And are there any sectors made up of lots of "random" short lines near the imp activity? 

 

I've generally fixed it by locating those sectors and making them have fewer lines - less very fine detail. Note: even if the imps weren't disappearing into precisely where those sectors are, altering them has still fixed the issue for me.

 

Again, I have no idea what I'm talking about, but I know exactly what you're talking about, and anecdotally, I have been able to make the problem go away.

Share this post


Link to post

Hmmn. For me this problem usually boils down to two things

1 -  check the z height of the imp in doom builder. 

 

2 - check the sprites using your wad editor of choice (I recommend slade 3) and make sure that they are ground level, as they may be too low(why their in the ground) 

 

Another thing it may be is if you are using a custom flag in your decorate file that may cause the error as well. 

For ex, using the scale command along z (up/down) instead of x or y (forward/backward, left and right) 

Could cause this problem I think. 

Share this post


Link to post

So to clarify, these imps are fine normally. I can turn on notarget and go see them all standing in their default positions fine. They actually seem to walk over and sort of fall into the floor. On my last test of the map nearly ten of them fell in there; sometimes its just one or two.

 

Not using a decorate file unless that's something that is packed into the wad by the GZDoom Builder by default; in either case, I'm not modifying it.

 

As for odd geometric shapes, I don't think there's anything like that, at least in that particular spot. I've had some occasions where a vertex I thought was splitting a linedef was actually not splitting and making a tiny sliver of a sector; could be happening here. I might just remake the spot line for line. The map in its entirety is about 10,000x10,000, and there aren't any single sectors anywhere close to that size.

 

Didn't have much time to work on it today, will probably be poking around that area tomorrow.

 

Attached a screenshot for your amusements: Tower of Imps Under the Floor

Screenshot_Doom_20200115_221504.png

Share this post


Link to post

I've had this happen in two of my maps, both being large, open areas. Sergeants and Imps were falling into invisible holes in the floor that were the depth of the lowest floor in the map. I was using Limit-Removing and Boom formats and the cause appeared to be related to the NodeBuilder. Fiddling around with different NodeBuilders in GZDB has solved this issue both times.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×