Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fabian

This is Woof! 7.0.0 (Sep 27, 2021) [Updated WinMBF]

Recommended Posts

8 hours ago, TheMightyHeracross said:

EDIT: So upon closer inspection, it seems the oldschool Boom fullscreen HUD is there- but only on Windows. On Linux (at least my Linux Mint 20.1 build) there is no fullscreen HUD at all.

 

Erm, well, it should. Could you try pressing F5 or assign some different keys to the "Change View" actions?

Share this post


Link to post
Posted (edited)

I can actually record the strange high pitched hiss I've been experiencing... Take a listen for yourself:
(If you listen very closely, when I press a button in the main menu the hiss is still present for any audio being played from Woof!)

 

Edited by Fireseth

Share this post


Link to post

I listened with relatively high-quality headphones and still can't hear. I think in my youth there was too much very loud music. Anyway, we decided to rework the Woof sound system to sound exactly like Crispy Doom in the next major release. But this will take time.

Share this post


Link to post

Yeah, it's exactly the same hiss I have. It was present in Woof 5 too. You don't need a thousand enemies to hear it, only 1 or 2 loud enemies. Thanks for recording.

Share this post


Link to post

To me Woof, Chocolate, Crispy and PrBoom-plus all sound very close to one another. Also, I don't detect anything out of the norm in the video. I am also in the excessive exposure to loud music category though. Just curious, if you have Crispy or Chocolate, can you go into your crispy_doom.cfg or chocolate_doom.cfg and change the use_libsamplerate variable to 2? Then play Crispy/Chocolate and see how its sound effects compare to what you're hearing in Woof. I suspect that you may have really good hearing and are picking up high frequency resampling artifacts. Setting use_libsamplerate to 2 creates maximum artifacts, i.e. it will use the poorest quality resampling technique.

Share this post


Link to post

It's definitely there. There may be some discrepancies here related to age since at a certain point you stop being able to hear higher frequencies.

Share this post


Link to post
Posted (edited)
8 hours ago, mikeday said:

To me Woof, Chocolate, Crispy and PrBoom-plus all sound very close to one another. Also, I don't detect anything out of the norm in the video. I am also in the excessive exposure to loud music category though. Just curious, if you have Crispy or Chocolate, can you go into your crispy_doom.cfg or chocolate_doom.cfg and change the use_libsamplerate variable to 2? Then play Crispy/Chocolate and see how its sound effects compare to what you're hearing in Woof. I suspect that you may have really good hearing and are picking up high frequency resampling artifacts. Setting use_libsamplerate to 2 creates maximum artifacts, i.e. it will use the poorest quality resampling technique.

From what I can hear, it just makes the entire game sound more "crispy" and old- as if I had really bad headphones or speakers.
 

10 hours ago, rfomin said:

I listened with relatively high-quality headphones and still can't hear. I think in my youth there was too much very loud music. Anyway, we decided to rework the Woof sound system to sound exactly like Crispy Doom in the next major release. But this will take time.

Great to hear! I'll definitely be looking forward to the next major release.

Edited by Fireseth

Share this post


Link to post

I still don't understand how the fact that random sound pitch apparently fixes the issue fits into the picture.

Share this post


Link to post
Posted (edited)
6 hours ago, mikeday said:

Just curious, if you have Crispy or Chocolate, can you go into your crispy_doom.cfg or chocolate_doom.cfg and change the use_libsamplerate variable to 2? Then play Crispy/Chocolate and see how its sound effects compare to what you're hearing in Woof. I suspect that you may have really good hearing and are picking up high frequency resampling artifacts. Setting use_libsamplerate to 2 creates maximum artifacts, i.e. it will use the poorest quality resampling technique.

 

You may be right, this results in some hiss as well.

But it's not like those nice crunchy old sounds in Chocolate Doom - those don't come with such unpleasant effects.

By the way, I use speakers and I suffer from tinnitus, but those factors are irrelevant. The noise (in Fireseth's video) appears to have similar high frequency to those used in hearing tests so some people may not hear it.

Share this post


Link to post
12 hours ago, Fireseth said:

I can actually record the strange high pitched hiss I've been experiencing... Take a listen for yourself:
(If you listen very closely, when I press a button in the main menu the hiss is still present for any audio being played from Woof!)

 

I just watched through the whole video with headphones and couldn't hear a single hiss sound, sorry! Well, I am 40 years old and used to play in a metal band in my youth, so maybe this is the result of it. Anyway, we have an optional low-pass filter in PrBoom+ (and Choco, if I am not mistaken) that we could apply here.

Share this post


Link to post

I took a listen to the video, the hissing sounds (to me) like the noise you'd hear from low bit-depth audio. I also hear what sounds to me like a >10kHz whine when there are a lot of enemies on screen. I wanna say Odamex had an issue where SDL's resampling was poo-poo, does that sound like something that might be happening, or am I totally off-base?

 

@AlexMax, I think we talked about this on the discord at one point?

Share this post


Link to post

SDL changed the resampler in a somewhat recent 2.0.x patch and it sounds like Thelonious Dump when used on Doom's sounds.  Chocolate Doom only dodges the problem by using libsamplerate, if you turn support for it off you can hear how SDL muffles it by default.

 

Odamex bypassed the issue by using the naive resampler which doesn't sound fantastic, but at least it's not muffled.

Share this post


Link to post

I have added the low-pass filter from Chocolate Doom (optional and disabled by default) but forgot to do a test build that I could upload. 

Share this post


Link to post

I'm on 5.1.0 atm playing Alien Vendetta and feel the need to still report that MAP07's exit is busted even when setting compatibility to vanilla after killing all arachnotrons.

Share this post


Link to post

Colored blood? Auto map rotation? Save game backwards compatibility?! I need to upgrade my copy tonight!

Share this post


Link to post

Using the latest (6.1.0), it seems that some (if not all?) of the MBF21 flags are still not supported. I have a melee weapon with the +SILENT flag, but still wakes up all monsters in a regular fashion, and a projectile that has the +RIP flag but does not pierce through enemies.

I'm also still getting a "bad sfx #:0" error. If I'm troubleshooting it correctly, it seems to happen when I set Args3 to 0 for A_MonsterMeleeAttack (the arg that determines what sound is played on hit).

Share this post


Link to post
Posted (edited)

The automap looks like this for some reason while playing Full Moon on 6.1.0 (Haven't check other wads):
 

Spoiler

KrUJp6X.png
yxf15a9.png

 

Share this post


Link to post
11 hours ago, Aurelius said:

Using the latest (6.1.0), it seems that some (if not all?) of the MBF21 flags are still not supported.

Are you sure you have the complevel properly set to "mbf21"?

 

1 hour ago, Catpho said:

The automap looks like this for some reason while playing Full Moon on 6.1.0 (Haven't check other wads):

There is a line break in the map title? How does this look in PrBoom+?

Share this post


Link to post
5 minutes ago, fabian said:

Are you sure you have the complevel properly set to "mbf21"?

 

I was blissfully unaware there was a complevel option, sorry about that! However, when I went to check it's set at MBF21 by default. I even switched it over to MBF, restarted, then back to MBF21, restarted, but still no luck. Both errors are still present.

Share this post


Link to post

@fabian Checked it in dsda doom 0.19.7. In dsda doom it looks the same as my first screenshot, but leaves no artifacts on the stat bar unlike in woof.

Share this post


Link to post
Posted (edited)
4 hours ago, Catpho said:

@fabian Checked it in dsda doom 0.19.7. In dsda doom it looks the same as my first screenshot, but leaves no artifacts on the stat bar unlike in woof.

What renderer do you use? If you use gl for instance, the stat bar gets rendered on every frame, which could explain why the artifact disappears there.

Share this post


Link to post
6 hours ago, Aurelius said:

 

I was blissfully unaware there was a complevel option, sorry about that! However, when I went to check it's set at MBF21 by default. I even switched it over to MBF, restarted, then back to MBF21, restarted, but still no luck. Both errors are still present.

Could you please open a bug at the issue tracker at github and post the contents of your dehacked lump there? 

 

6 hours ago, Catpho said:

@fabian Checked it in dsda doom 0.19.7. In dsda doom it looks the same as my first screenshot, but leaves no artifacts on the stat bar unlike in woof.

I think it would be best if we just trimmed the levelname at the first line break. 

Share this post


Link to post
On 6/30/2021 at 10:00 AM, roadworx said:

so, uh.....when loading a save for any map using crushers, this happens

 

Animation.gif.0e88a622627020ab65492825403f88fb.gif

 

here's the save file

woofsav0.rar

 

 

I just had the same thing on Alien Bastards MAP04 after loading

Share this post


Link to post
20 minutes ago, game said:

 

I just had the same thing on Alien Bastards MAP04 after loading

Have you upgraded to 6.1.0?

Share this post


Link to post
Posted (edited)
5 minutes ago, fabian said:

Have you upgraded to 6.1.0?

 

Oh forgive me, I forgot. Maybe it's no longer relevant then.

Share this post


Link to post

Does this port support soundfonts, if so how would I go about getting Woof! to read and load them? Loving the updates fabian!

Share this post


Link to post

 

6 hours ago, Lila Feuer said:

Does this port support soundfonts, if so how would I go about getting Woof! to read and load them? Loving the updates fabian!

 

 

I'm not sure about Windows, but on Linux - you have to set the default soundfont by editing two config files just so you can have music play in the first place.

 

On 6/27/2021 at 7:43 PM, Ar_e_en said:

1. Install Fluidsynth and download a sf2 soundfont. 
2. Go to your "bashrc" file (it's a hidden file in your user directory) and add the following to the end of the file:


# SDL soundfont setting
export SDL_SOUNDFONTS=/usr/share/soundfonts/FluidR3_GM.sf2

(The pathway there is the location of your downloaded sf2 soundfont)

 

3. Find your Fluidsynth config file (it should be in "/etc/conf.d") and change it so it looks like this:


# Mandatory parameters (uncomment and edit)
SOUND_FONT=/usr/share/soundfonts/FluidR3_GM.sf2

# Additional optional parameters (may be useful, see 'man fluidsynth' for further info)
OTHER_OPTS='-a alsa -m alsa_seq -r 48000'

(You may or maynot need the line with "OTHER_OPTS", it depends on if it works or not)

 

4.Restart your PC and launch Woof through your terminal (preferably with the "-iwad" parameter pointing to the location of your preferred iwad).

 

Share this post


Link to post

I haven't tried this myself, but on Windows, I'm guessing you can set the environment variable SDL_SOUNDFONTS to point to your soundfont of choice. If you'd rather set the variable in a batch file, you can do that with "set," e.g. set "SDL_SOUNDFONTS=C:\Users\..."

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×