Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
chungy

Doom 64 (2020) issues

Recommended Posts

I figured it might be easiest to start a new thread for these specifically. I bought the game on PC and pretty much instantly ran into a couple things. Nothing that makes it unplayable, but...

 

  • Maybe not directly related to the game, but Bethesda.net suckage: https://chungy.keybase.pub/d64_bethesdanet.webp
  • The input defaults kind of suck. E for use and space for speed. Not sure why... suppose it's not a big deal if I can rebind...
  • The input menu constantly swaps between two (or three? I can't tell) different views and it is extremely distracting. Seems to be listing bindings for keyboard, then bindings for a gamepad. I don't even have one plugged in, and this is still making it harder than necessary just to read the listing. Many games simply display keyboard and gamepad in two separate columns instead of this swapping thing.
  • I can't bind the Shift key to speed, and it seems like binding keys doesn't reset the bind on other items. The latter is probably undesirable most of the time. The former is game-breaking and makes me think I ought to stick to EX for now.

 

Bonus: The opening logos are unskippable, and there's enough of them to make the wait annoying. The Doom Classic releases allow skipping logos, maybe Doom 64 ought to, too.

Share this post


Link to post
Posted (edited)
On 3/26/2020 at 5:44 PM, chungy said:

I can't bind the Shift key to speed

You most certainly can, both left and right. This suggests there's something going on about how your keyboard functions on either a hardware or software level. What is your layout and do you have any accessibility options like sticky keys enabled? Or perhaps some piece of background software intercepting them as overriders?

On 3/26/2020 at 5:44 PM, chungy said:

Bonus: The opening logos are unskippable, and there's enough of them to make the wait annoying. The Doom Classic releases allow skipping logos, maybe Doom 64 ought to, too.

As you can imagine, this isn't something we just get to change. Chuck on -skipmovies.

Edited by Edward850

Share this post


Link to post

This is a minor thing mentioned elsewhere, but I know a bunch of modders and I are interested in this. We have been able to get custom levels and music (except for the stats screen) to load into the port. But additional bonus textures (of any sort including renaming and adding Doom64.wad textures), cause graphical glitches and port to either crash on load or before loading a map. I have attached a test case and various crash reports I got (the textures might be loading into a part of memory where they shouldn't be).

There's a few Doom 64 EX mods, which use custom textures (Doom 64 Community Chest, Redemption Denied, ect...) which a few others and I would like to port over. It would be a second blessing to the community to play these on the uber-accurate new port. :)

Doom 64.zip

Share this post


Link to post
25 minutes ago, Edward850 said:

You most certainly can

I used the first person for a reason, I don't know about others. I certainly cannot; I can press shift and the prompt goes away, and then the menu doesn't reflect any sort of change, nor is there any change in game play.

26 minutes ago, Edward850 said:

What is your layout and do you have any accessibility options like sticky keys enabled? Or perhaps some piece of background software intercepting them as overriders? 

US International with AltGr dead keys. None of the other sort. No other game ever has an issue, either.

27 minutes ago, Edward850 said:

Chuck on -skipvideos.

Thanks, perfect. Lucky enough to have the option, many games don't :D

Share this post


Link to post
Posted (edited)
12 minutes ago, chungy said:

AltGr dead keys

We don't seem to have this kind of keyboard on hand, does this have any effect over the shift function? We use SDL2 on PC, are you capable of binding shift in other SDL2 programs, such as Eternity?

Share this post


Link to post
Posted (edited)
21 minutes ago, Edward850 said:

We don't seem to have this kind of keyboard on hand, does this have any effect over the shift function?

Hardware (and keycode-wise), it's nothing special from a normal US keyboard. The AltGr setting only changes the behavior of the right Alt key.

21 minutes ago, Edward850 said:

We use SDL2 on PC, are you capable of binding shift in other SDL2 programs, such as Eternity?

Yes. Eternity and Chocolate Doom are both fully functional. Doom64 EX even apparently uses SDL2 and doesn't have this problem.

Edited by chungy

Share this post


Link to post
54 minutes ago, Edward850 said:

As you can imagine, this isn't something we just get to change.

Why is that? What or where does it say in the rules that intro movies must be unskippable? I don't understand.

Share this post


Link to post
1 minute ago, Nevander said:

What or where does it say in the rules that intro movies must be unskippable? I don't understand.

Presumably somewhere in licensing contracts that aren't publicly viewable. Or maybe Night Dive lawyers are taking the safe side in an ambiguous setting.

Share this post


Link to post
Posted (edited)
50 minutes ago, chungy said:

Hardware (and keycode-wise), it's nothing special from a normal US keyboard. The AltGr setting only changes the behavior of the right Alt key.

Yes. Eternity and Chocolate Doom are both fully functional. Doom64 EX even apparently uses SDL2 and doesn't have this problem.

EX uses SDL1, actually. That's really strange though, there must be something screwing up with the keycodes but there's just so much information we can't see in this situation without physical access to your specific PC. I take it you can't just manually add bind lshift "speed" to your config? "C:\Users\<user>\Saved Games\Nightdive Studios\DOOM 64\kexengine.cfg"

Edited by Edward850

Share this post


Link to post
5 minutes ago, Edward850 said:

It uses SDL1, actually.

I can verify that it doesn't

 

$ ldd /bin/doom64ex | grep SDL
	libSDL2-2.0.so.0 => /usr/lib/libSDL2-2.0.so.0 (0x00007f8ca2f45000)

 

6 minutes ago, Edward850 said:

I take it you can't just manually add bind lshift "speed" to your config? "C:\Users\<user>\Saved Games\Nightdive Studios\DOOM 64\kexengine.cfg"

I didn't even notice this wasn't a native Linux app until now... wow. Apparently Steam is running it through Proton. Anyway, yeah, it appears modifying the cfg directly does have the intended effect in-game. I just can't set shift in-game. Bummer.

Share this post


Link to post
1 hour ago, Immorpher said:

This is a minor thing mentioned elsewhere, but I know a bunch of modders and I are interested in this. We have been able to get custom levels and music (except for the stats screen) to load into the port. But additional bonus textures (of any sort including renaming and adding Doom64.wad textures), cause graphical glitches and port to either crash on load or before loading a map. I have attached a test case and various crash reports I got (the textures might be loading into a part of memory where they shouldn't be).

There's a few Doom 64 EX mods, which use custom textures (Doom 64 Community Chest, Redemption Denied, ect...) which a few others and I would like to port over. It would be a second blessing to the community to play these on the uber-accurate new port. :)

Doom 64.zip

I found the basic problem with loading the wad file; if you can include a complete version of it with all the assets, I'll test loading that now as well.

Share this post


Link to post
Posted (edited)
13 minutes ago, chungy said:

I didn't even notice this wasn't a native Linux app until now... wow.

Head desks repeatedly (proton messing with us again).

I'd have known instantly this was a Proton bug if you mentioned Linux, because 99% of the time it is. Proton still ain't perfect. Yeah sorry, we don't have a native Linux client for this at time of writing.

And hence why EX uses SDL1, but 2 for you, it's still like that on Windows.

Edited by Edward850

Share this post


Link to post
9 hours ago, Quasar said:

I found the basic problem with loading the wad file; if you can include a complete version of it with all the assets, I'll test loading that now as well.


Here's the link to the full version! https://www.doomworld.com/applications/core/interface/file/attachment.php?id=53987 (they didn't separate the levels into individual wads though..). And it's from this thread: 

Thanks a ton for looking into it and testing it! :D

Share this post


Link to post

Has anyone noticed Level 20: Breakdown in the 2020 remaster, the BGM sounds a bit off, a bit weird? There are certain sound effects that are part of the ambient background music, that sound too high pitched and fast in comparison to what it originally sounded on the actual N64 hardware. In fact, I noticed the same issue on the Doom64 EX port. Which would suggest that original issue just got carried over from Doom64 EX to the offical port. I've noticed this on both the Windows version (Steam) as well as on Xbox One X.

Share this post


Link to post

The Nintendo 64 sound engine had some bugs that caused that music track to not play in the manner it's written. So that's an ordeal. You can intentionally break your music player to try to get it to sound the same, and assume that was Aubrey's intent, or you can play what's actually written and assume that WESS had some bugs (which is almost 100% certain given what we know).

Share this post


Link to post

Oddly, I fired up an older version of Doom64 EX, v1.4, and the music for Level 20 actually sounds exactly like the N64 version, so not sure at what point this changed.

Share this post


Link to post

if I'm not mistaken, the earliest versions of Doom 64 EX just used recordings of the N64 tracks as mp3s or oggs, before moving on to using the actual midi data, which is probably when the "bug" was introduced. It's nice to hear Breakdown in what was supposedly the intended way, though I'll admit I think the original N64 lack of pitch changing in that awful haunting drone makes it much spookier.

 

Share this post


Link to post

My only complaint is about the logos. It's nearly a full minute from power on to getting into a map, which is absurd for a 1997 game. 

 

If the N64 version supported in-level saves and saved settings (brightness, controller mapping), I'd play that instead just for this reason.

Share this post


Link to post
48 minutes ago, famicommander said:

My only complaint is about the logos. It's nearly a full minute from power on to getting into a map, which is absurd for a 1997 game. 

 

If the N64 version supported in-level saves and saved settings (brightness, controller mapping), I'd play that instead just for this reason.

Are you on PC or console?

Share this post


Link to post

Having an issue with the game freezing/black screening on the Nintendo Switch version when loading into a map. Not sure what it is.

Share this post


Link to post

I don't recall having that big an issue with the logos on PS4. Are you people quitting the game multiple times for some reason? When I turn it on its for one big session.

That said, there should be the ability to press X to skip each one if that isn't already a thing. Its really not a dealbreaker though.

Share this post


Link to post

I just bought the game, downloaded it and immediately upon startup I realized I need very massive help.
 

20200401012414_1.jpg.b00a327f215e94189af4fa19a828d5d0.jpg20200401012401_1.jpg.347b1996c8c2f8f4a199ce188658bfe8.jpg20200401011634_1.jpg.765a7d5cbb68d78b6897caf11eace587.jpg

 

This is what my game is on start up, and it persisted even after the opening video. Tried uninstalling and reinstalling, and it still persisted.

 

@Edward850I need your help.

 

System specs is as follows:


Processor Information: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz
Operating System Version:    Windows 7 (64 bit)
Video Card:    Driver:  NVIDIA GeForce GTX 1050 Ti
Sound card:    Audio device: Acer XF240H (NVIDIA High Defini
RAM:  16330 Mb

 

Share this post


Link to post

Oh wow, that's kinda scary - because it can sometimes mean the graphics card is dying.

 

Have you tried updating your drivers? I see you're also on W7 which is not officially supported.

Share this post


Link to post
Posted (edited)

Yep, I am on the latest driver. It's just weird that everything else aside from this game runs fine.

 

image.png.0ae4666066cd4df95504d1b755e8f641.png

 

Gonna try it on my more potatoey laptop and report the results in a  bit.

 

EDIT: Okay, it runs on my potato laptop.

 

 

Edited by ZeroTheEro

Share this post


Link to post

So it turns out for some reason the game boots up on the API defaulting to Vulkan. Using my laptop as a guide, I switched to OpenGL 3.2 and it works! So does DirectX11.

So yeah, problem solved.

Share this post


Link to post
7 minutes ago, ZeroTheEro said:

So it turns out for some reason the game boots up on the API defaulting to Vulkan.

Because that's the default. Any card that reports to support vulkan will launch in it. You have a 1050 Ti which we know will run Vulkan absolutely fine, so this likely suggests there's something else going on in your system that's really screwing with Vulkan shaders or graphics pipeline.

Perhaps you need to consider doing a clean reinstall of your drivers. 

Share this post


Link to post

You unlocked the super secret episode! Lilith 64: Graf's Suffering Will Never End

Share this post


Link to post

Another Issue is with the mouse wheel if you scroll it down it will reach the fists and the chainsaw and if you keep scrolling it will switch between those two, also if you scroll up it will reach the last weapon slot and it will stop here.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×