Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Mr. Impso

(SOLVED) can't test run a level I'm editing

Recommended Posts

Good evening. 
I'm wanting to try my hand at making doom levels. 
I'm using Slade, as that's the editor I used to be good at. it's been a few years since I used it, so I'm a little rusty, but I remember how to do must of it. 
However, I've hit a brick wall when it comes to test-running my map. 
I'm making a map for Zdoom, so no node builders, and whenever I try to test-play the map I have so far, it launches doom II and dumps me in E1M1. I thought I had the path set correctly for the zdoom executable, but obviously I've goofed something. Any help would be appreciated. 

 

Share this post


Link to post
1 minute ago, ValeriyPipick said:

Choose only one. 

I guess I don't understand. could you clarify for me please?

 

Share this post


Link to post

I could send screenshots of my preferences in Slade if that would help. 
be forewarned though, they'd be screenshots of ALL the preferences. 
I want to be as thorough as I can, as I know even the slightest setting off when it comes to this stuff can absolutely fuck everything

Share this post


Link to post
16 minutes ago, Mr. Impso said:

I guess I don't understand. could you clarify for me please?

There is no E1M1 in Doom II, it is unique feature of The Ultimate Doom.

Share this post


Link to post

Is your map lump named “map01”? Screenshots would also help for sure.

Share this post


Link to post

I've renamed it to be custom, should I leave it as map01 so it replaces the level? and I'll get on the screenshots

 

Share this post


Link to post
2 minutes ago, Mr. Impso said:

I've renamed it to be custom, should I leave it as map01 so it replaces the level?

Yes.

Share this post


Link to post

Power just got knocked out, I’ll list the settings for the menu when I actually try to test run the map.

game executable: zdoom

path: c:/users/user/desktop/zdoom-2.8.2/zdoom.exe

run configuration: run

and I tried leaving the map name as map01, no luck 

 

Share this post


Link to post

 

2 hours ago, Mr. Impso said:

and I tried leaving the map name as map01, no luck 

You can call your map according to your preferences. The important thing here is the map lump name. You can find it in the very first window that opens up once you load the map, or pressing F2 in any moment (at least in Gzdoom builder, if you are using SLADE you can directly modify the lump name simply renaming it).

Share this post


Link to post
Posted (edited)

All those screenshots and you missed the important one. :)

 

At the very start of the mapping process you have to set your preferences, such as

 

YGCU4n6.png

 

So, if you have the IWAD for DOOM2 than your map would be MAP01,

if you have the IWAD for DOOM then your map would be E1M!.

 

Since you use ZDoom as your testing and gaming engine you could use any of the three mapping formats.

 

Then, when it comes to saving your pwad, then you name it mapname.wad, whatever name you want.

Share this post


Link to post

oh. my GOD, I figured it out and I feel like such an idiot. 
So in the preferences of the run configuration, I checked the internal preferences, and there were fucking NO parameters that had been set. I set custom parameters as "Config b" and it worked. 
I don't think I have ever facepalmed as hard as I did just now, of COURSE I had to set custom parameters to run the custom map. 
I thank everyone who stopped by to help me out regardless, I really appreciate it :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×