Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
bluemoss

Doomguy emits light, anyway of removing it?

Recommended Posts

I've started on a slow, horror-esque type map, and I want to the only sources of light to be from a torch and lamps scattered in the environment

So anyone know a way to disable doomguy's light emitting armor? 

 

PS: I'm running LZDoom on software mode coz my PC has little to no OpenGL support and it's really old

 

Thanx

Share this post


Link to post

Radiant doomguy, haha. In software, I don't think it's possible to get around it. One way of making it less pronounced with the walls is by making sure the player can't get right up close to them. 

Share this post


Link to post

You could add some really dark texture variants perhaps, and use them on the walls that aren't near the torches.

 

Share this post


Link to post

I'm currently using Otex but I could always just make it really dark, but shining a flashlight on it isn't really gonna look the best

 

Share this post


Link to post

Or just toy around the light constants in the source code. That is what I did in my port and now if you want you can remove that lighting (Real Lights NOTM).

Share this post


Link to post

If you use something other than ZDoom, the lighting effect won't be quite so pronounced. Doom's light-diminishing effect isn't supposed to make very dark walls become fullbright when you stand in front of them.

 

(I haven't checked in a while, though, so maybe ZDoom has fixed this in recent years.)

Share this post


Link to post
Posted (edited)

I haven't tried, but shouldn't you be able to disablefullbright?

Or are we just talking about texture/wall view when up close to a wall? ~ if that's the case then yeah, either the texture needs to be really dark or the render mode does.. gamma corrections maybe, or yeah make it so the player can't get close enough to a wall to get a brighter effect.

Share this post


Link to post

It is perfectly possible in OpenGL mode, but software is more tricky.  As far as I'm aware, the light fade effect is hardcoded into the renderer. 

 

Also, based on limited experimentation, I don't believe it's possible to have maps so dark you actually can't see any monsters at all in software mode.  Even at 0 brightness, monsters will still have a few pixels that show up in the dark.  

Share this post


Link to post

There is no easy way to circumvent Doom's weird lighting model. You basically have to live with it.

Share this post


Link to post

There is a rendering variable called R_Visibility in ZDoom unless they removed it since I last played. Setting it to zero will get rid of that light distance effect. Perhaps it's possible to force via an ACS script?

Share this post


Link to post
1 hour ago, Wagi said:

There is a rendering variable called R_Visibility in ZDoom unless they removed it since I last played. Setting it to zero will get rid of that light distance effect. Perhaps it's possible to force via an ACS script?

That's a horrible hack no one should use, and no you can't just force it using ACS. I guess you could use Zandronum instead and use the ConsoleCommand function (which is on it's way of being removed for 3.1 even though it's extremely useful) to set r_visibility to 0, but if you're gonna do that, you might as well just use the OpenGL renderer and cut the cheese.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×