Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
yakfak

doom map editing without a mousey

Recommended Posts

my USB ports are messed up and I can't handle a laptop swipepad without going mad. what map editor would you recommend for someone using the keyboard alone, and how would you set it up? I'm used to old school stuff like winDEU but I'm alright with GZDB and DBX as well. every time someone says "get a new laptop" I will add five more pain elementals to my map

 

(it's weird to get inspired to get back into the scene at a time im totally unequipped to do it lol)

Share this post


Link to post

mouse keys doesn't seem to give you stuff like scroll wheel so using GZDB feels like someone has cut off one of my fingers

Share this post


Link to post
1 hour ago, yakfak said:

mouse keys doesn't seem to give you stuff like scroll wheel so using GZDB feels like someone has cut off one of my fingers

Couldn't you rebind what you use the scroll wheel for to buttons? It'll be a bit annoying for sure, but it'll at least make you not need to get a third-party mousekeys program. Only downside would be that you'll have to rebind it back to scroll wheel once you've gotten a functioning mouse.

The texture and things menus can be navigated with arrow keys as well, so no scroll isn't too bothersome.

 

2 hours ago, yakfak said:

every time someone says "get a new laptop" I will add five more pain elementals to my map

Get a new laptop! Get a new laptop! ;)

Share this post


Link to post
Posted (edited)

Not sure I can help with KB only editors, but...

 

With the touch pad, it's those damn touchy gestures screwing you up, isn't it?   Where you hand passes over and suddenly you've moved who knows what folder into who knows what other folder, and have to quick undo?   I can't stand that garbage.   On my newer comp which fortunately has nice tight USB's I just disable the whole thing because the options to to disable gestures seem nonexistent, but on my old computer with messed up USBs (Two work as long as the plug doesn't get disturbed or wiggled and the  other one has to be shimmed with a folded piece of paper to work), I was able to disable all that BS.   Right click the icon for it, first make sure Tap to Click is not checked, and choose Pointing Devices Properties.   Should be in the Mouse Properties window.   Go to the Device Settings tab.   Select the touch pad device and click settings.   In the properties from there, go through unchecking every single stupid gesture to disable them all.   Then your touchpad will function like a simple mouse moving around and clicking left or right as you actually intend, except for touchpad movement not being as good as an actual mouse.   Also as I mentioned before, try shimming a USB port.  Cut a narrow piece of reasonably thick paper and fold it once, and stick it as you plug in a mouse.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×