Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
BluePineapple72

(Solved) Vanishing Key Issue (Doom Builder 2)

Question

Hello. I'm working on my first WAD, and there's a section where the player grabs a red key. The key is on a linedef that, when crossed, causes a few floors to raise.

 

The issue is that whenever I load the map, the key is nowhere to be seen. It isn't on the platform it's supposed to (I haven't rigged the puzzle to drop this platform yet).

 

I've placed the player spawn beside the key's location and, when loading, I saw it flicker once, only for it to vanish unto oblivion. I'll post a few pictures to give y'all a better idea. 

 

The key in the editor:

262324355_Keybug.png.6764b61d2a0ec0691f8511836074c007.png

In game: Screenshot_Doom_20200413_214105.png.f1d3b5edef829573598fa6016a95c37e.png

(The angle isn't perfect, but you'll have to trust me when I saw it wasn't there.)

 

For reference, I loaded the test using GZDoom, and I'm editing in Hexen Format (whatever that means lol).

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Considering you changed geometry to make it work, I would also assume it is bad sectoring. I don't know much about it, but I had a problem after dragging sectors aroudn for a bit, one particular angle revealed a hole in the ceiling. What is helping is using "make sectors tool" to click around problem area to force it to recalculate things.

Share this post


Link to post
  • 1
Posted (edited)

Is the key tagged as:

 

Multiplayer?

On certain difficulties only?

 

Either of these will stop the key from spawning.

Share this post


Link to post
  • 1

You could possibly find more info on what happened using iddt and idclip to determine the position of the key in-game; it could have been an unclosed sector or some other node building error, though the geo doesn't look crazy enough for that to be too likely. Still, glad you got it working :D

Share this post


Link to post
  • 0
41 minutes ago, mrthejoshmon said:

Is the key tagged as:

 

Multiplayer?

On certain difficulties only?

 

Either of these will stop the key from spawning.

 

18 minutes ago, Kappes Buur said:

Did you select the flags?

 

DOOM2 format

  Reveal hidden contents

rL2njra.png

 

DOOM in Hexen format

  Reveal hidden contents

kGCSx15.png

 

I made sure that both of these were flagged properly. Everything was proper, so I looked elsewhere. I solved the issue, but I'm not sure why the answer worked.

385893711_KeyBugsnip2.png.a326a263f1b94783fc1f076acd26e80c.png

I used the create sector tool on the platform under the key to make two sectors split by the trigger linedef. Loading the test they key showed up finally. It worked, and I'm happy, but I don't know why? If you know why please do share, it'll help me not make this mistake again.

 

Share this post


Link to post
  • 0
11 minutes ago, Fonze said:

You could possibly find more info on what happened using iddt and idclip to determine the position of the key in-game; it could have been an unclosed sector or some other node building error, though the geo doesn't look crazy enough for that to be too likely. Still, glad you got it working :D

Thanks a bunch! I’ll make sure to look into it tomorrow!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×