Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
CrocketRocket

Weapon Sprite issue

Question

I'm currently going through GUNLabs tutorials to get myself into doom again. And right now I've come across this issue while trying to practice out custom textures before I start doing MS paint stuff. I got the gun down yet its acting weird every time I fire it. I know I manged to fix it up with the auto shotgun but I don't have a single clue on how I did it.

 

Here is the issue.

Screenshot_Doom_20200421_120436.png.7e4dfb14790f2ed3be55191f0d3572cc.png

 

Here is the code.

 

2134837534_thejankcode.PNG.699a6a6bb33f3446f4f3b1f6f52e3f00.PNG

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 1

I think the problem is because the flash sprites include the pistol,This should not be like that, the Flash sprites should normally be only the fire will emit the pistol when firing, better known as muzzleflash

Share this post


Link to post
  • 0
7 hours ago, Gaia74 said:

I think the problem is because the flash sprites include the pistol,This should not be like that, the Flash sprites should normally be only the fire will emit the pistol when firing, better known as muzzleflash

Damn. So I'm guessing I'll need to find away to add a muzzle flash on its own to really fix it. Already removed the flash sprite on it and just went on ahead without it.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×