Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
DaDoomGuy

GZDoom Builder (Bugfix) Save Issue

Question

I'm working on a WAD for shits and giggles, and I make a map in GZDoom Builder (the bugfix version) and when I save for the first time, it saves, but when I CTRL-S or save it again, it gives me this error message:

 

Unable to save the map: target file is locked by another process.
Also, unable to get the name of the offending process:
Error 29. Could not begin restart session. Unable to determine file locker.

I am on the latest version of GZDoom Builder Bugfix, and I don't know what is happening. Can anyone help me?

Share this post


Link to post

26 answers to this question

Recommended Posts

  • 0
Posted (edited)

After editing a map in GZDBBF saving with Ctrl+S works for me.

 

Are you certain that the map is not opened in another app,

maybe running in a game in the background or opened in Slade3?

Then you'll get that notification.

Share this post


Link to post
  • 0
5 hours ago, Kappes Buur said:

After editing a map in GZDBBF saving with Ctrl+S works for me.

 

Are you certain that the map is not opened in another app,

maybe running in a game in the background or opened in Slade3?

Then you'll get that notification.

Nope, it's not open in another app. The only app that's open is just GZDBBF. I don't have it open anywhere else.

Share this post


Link to post
  • 0

Try Ultimate Doom Builder rather than GZDB_BF. Also, make sure you're not saving to a protected folder. Try saving to the desktop or equivalent. 

Share this post


Link to post
  • 0
Posted (edited)
2 minutes ago, Bauul said:

Try Ultimate Doom Builder rather than GZDB_BF. Also, make sure you're not saving to a protected folder. Try saving to the desktop or equivalent. 

The thing is is that I am saving to my desktop, and it still gives me that error. I will try out Ultimate Doom Builder soon, idk if it has the same features as GZDBBF but I will give it a shot.

 

edit: Checked out the download page for UDB, turns out this is something new made by the guy who made GZDBBF, probably because GZDBBF is having problems. I will check this out ASAP, thanks for the suggestion!

Share this post


Link to post
  • 0

Update: Got UDB installed, made a quick map in it. I saved it the first time, it worked, but I saved it again and it still gave me that error message. I am still saving to desktop as the file "MAP01.wad" and no other DOOM-related program is open using it.

Share this post


Link to post
  • 0
Just now, Bauul said:

Do you have a non-Doom related program open using it?

 

Perhaps try asking at the UDB Discord server: https://discord.gg/Gwbhprv

No, no other program is using the WAD. I would join the Discord server but my shitty limited metered 20kb/s satellite internet connection can't load Discord (both desktop and web versions don't work, hence why i'm asking the question here)

Share this post


Link to post
  • 0

 

Maybe it's a problem with the OS.

To keep my computer on the straight and narrow I run the free app CCleaner by Piriform.

First I run Custom Clean and then Registry.

 

Usually that rids most problems, including internet trackers.

Share this post


Link to post
  • 0
53 minutes ago, Kappes Buur said:

 

Maybe it's a problem with the OS.

To keep my computer on the straight and narrow I run the free app CCleaner by Piriform.

First I run Custom Clean and then Registry.

 

Usually that rids most problems, including internet trackers.

I ran CCleaner just now with both the custom clean and registry fix stuff and that didn't help, UDB still gives out the same error message

Share this post


Link to post
  • 0
1 hour ago, boris said:

Probably the antivirus calling dibs on the file.

 

If that is the case then deleting the dbs file may solve the problem.

 

One last thought, when the computer had not been rebooted for some time, quirks may creep in.

Share this post


Link to post
  • 0
Posted (edited)
4 minutes ago, Kappes Buur said:

 

If that is the case then deleting the dbs file may solve the problem.

 

One last thought, when the computer had not been rebooted for some time, quirks may creep in.

I did restart my computer (cold boot included) and that didn't work

 

Also I don't think my antivirus is doing anything with the wad (I use Windows Defender and Malwarebytes Free)

 

Maybe ill delete the DBS file that gets exported with the WAD and see if that works.

 

edit: Deleting the .dbs file didn't work.

Share this post


Link to post
  • 0
Posted (edited)
7 minutes ago, DaDoomGuy said:

Maybe ill delete the other file thingy that gets exported with the WAD and see if that works.

 

oh, speaking of other file thingy.

That reminds me of the GZBuilder.cfg file. If you have not customized the editor then delete that file and let the editor rebuild it. If you have customized the the editor then make a renamed copy of that file first before deleting. That file is located in AppData/Local/Doom Builder. Maybe that will work for you.

Share this post


Link to post
  • 0
4 minutes ago, Kappes Buur said:

 

oh, speaking of other file thingy.

That reminds me of the GZBuilder.cfg file. If you have not customized the editor then delete that file and let the editor rebuild it. If you have customized the the editor then make a renamed copy of that file first before deleting. That file is located in AppData/Local/Doom Builder. Maybe that will work for you.

I have customized the builder so I renamed my old one from GZBuilder.cfg to GZBuilder.cfg_bak and let it made a new one and that didn't work

Share this post


Link to post
  • 0
Posted (edited)
6 minutes ago, DaDoomGuy said:

I have customized the builder so I renamed my old one from GZBuilder.cfg to GZBuilder.cfg_bak and let it made a new one and that didn't work

 

good deity!!! That certainly is one persky problem.

Does it always give the same error?

Short of suggesting a repair of your OS (which needs the original DVD) I'm out of ideas.

 

Let me add that I never save to the desktop or to files in the windows folder. I have my editor in D:\ and that is where I have all my pwads, mods, well anything related to DOOM.

Edited by Kappes Buur

Share this post


Link to post
  • 0
3 minutes ago, Kappes Buur said:

 

good deity!!! That certainly is one persky problem.

Does it always give the same error?

Short of suggesting a repair of your OS (which needs the original DVD) I'm out of ideas.

Yeah but I did a SFC/DCIM check of my OS using the Admin Command Prompt and it said it was ok, plus I didn't want to reset my PC because even though it keeps all my files, it deletes apps installed on my computer and I don't want to risk it deleting a shitton of apps i've installed (like music software, photoshop, etc)

 

Elsewhere, if the main dev behind UDB/GZDBBF is on Doomworld and sees this thread, I hope he has a solution to this error because I tried everything with all of them not working.

Share this post


Link to post
  • 0
Posted (edited)
6 minutes ago, DaDoomGuy said:

Elsewhere, if the main dev behind UDB/GZDBBF is on Doomworld and sees this thread,

 

He does see this thread and did give you one idea.

Since ZZYZX is absent it is boris who takes the mantle, whenever he can.

Share this post


Link to post
  • 0
2 minutes ago, Kappes Buur said:

 

He does see this thread and did give you one idea.

Since ZZYZX is absent it is boris who takes the mantle.

That is understandable. Hopefully there will be a fix to this (hopefully it's not my computers fault but judging by the error occuring on both GZDBBF, which I owned for about 5 months now, and UDB, which I got a couple hours ago, this might be my computers fault, but if it's the softwares fault then an update with a potential fix should be patched, but if not then I still need to know what the fuss up is.)

 

The only solution for me is to save the map as a separate file (first saved as MAP01, can't save again due to error, but can save as a new file like MAP01A or something along the lines of that), but that feels like a hassle to do.

Share this post


Link to post
  • 0

If it was the program's fault and easily reproducible, don't you think it would be more widespread?

Share this post


Link to post
  • 0
52 minutes ago, boris said:

If it was the program's fault and easily reproducible, don't you think it would be more widespread?

not really, thinking about it i think it's mostly my pc's fault than the app's fault if nobody else is having the issue

 

hopefully there will be a good solution to this error because i tried every method to fix it with all of them failing

Share this post


Link to post
  • 0

What if you try moving the file somewhere else, not the desktop? Like, in a folder in the root of the drive? Such as C:\wads? Same problem?

Share this post


Link to post
  • 0

If you Save As and save your map to a different file name, and then Save As again back to your original filename, does it work? 

Share this post


Link to post
  • 0

Sorry for not replying to this thread in a while, got caught up with a bunch of stuff, and I really want to make a Doom wad to pass the time, and since UDB is the norm for Doom editors, I'm still trying to figure out how to save WADs without it freaking out.

 

On 4/29/2020 at 7:40 PM, Nevander said:

What if you try moving the file somewhere else, not the desktop? Like, in a folder in the root of the drive? Such as C:\wads? Same problem?

I tried various locations, even ones that aren't locked, and it still doesn't work

 

On 4/29/2020 at 8:40 PM, Bauul said:

If you Save As and save your map to a different file name, and then Save As again back to your original filename, does it work? 

Yeah but that's a bit of a hassle to do, to save the map as something different then save it back again.

Share this post


Link to post
  • 0
Posted (edited)
11 hours ago, PeterMoro said:

Perhaps this thread could help?

 

 

I checked my Local/Temp folder and found no 8 character letter names, so i deleted whatever temporary files there are then I tried again only for it to not work.

 

Also I tried uninstalling UDB from my games drive (where I also keep GZDoom and SLADE3, and SLADE3 saves WADs and PK3s just fine), and installing it onto Program Files with little to no effect.

Share this post


Link to post
  • 0

I got Doom Builder X, an old version of Doom Builder (like GZDBBF or UDB) and it actually works, it can save without giving out any error messages. If shit hits the fan, I will try to solve it, thread or not, but elsewhere, I will be making my WAD now. Thanks!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×