Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
DevastatioN

Massive Multiplayer Online Doom Experience - Event #1 (May 23rd)

Recommended Posts

Posted (edited)

The Multiplayer Doom Federation in coordination with ZDaemon Sessions presents MMODE Event #1:

 

Massive Multiplayer Online Doom Experience - Event #1dw_mmode.png.28237c625130ad5720dcc031e3adc7f5.png

 

We will show the world that life still exists in doom deathmatch multiplayer by getting 100 players or more playing at once across various free-for-all servers.  A special wad compilation of 50 selected FFA maps will be used.

 

The event will take place on ZDaemon, May 23, between 3 Eastern and 7 Eastern.  More details will be posted on http://doomfederation.com once finalized and also in our Discord Server at https://discord.gg/qkEBB5.

 

So calling all players, if you're out there, mark your calendars and show your support for the doom community by participating in the first MMODE event.  Show the world we still exist and that there is still lots of life left in doom!

Edited by DevastatioN

Share this post


Link to post
Posted (edited)

I'd shed a tear of joy seeing mutliple FFA servers running at once.. A sight virtually unseen for the last 10+ years. I will absolutely be there! Looking forward to seeing what maps are picked, I'm sure they'll be good but there's a lot to pick from!

 

EDIT: The big 25th anniversary DM in 2018 on Zand was incredible, hundreds of players were connecting over the course of about 14 hours, and so were those huge Odamex DM sessions decino was running for a few weeks in January, where the record number of players in a DM server was set, at like 130-something. I'm glad ZDaemon is getting it's chance at a big event like this, I'll be telling every DMer I know.

 

EDIT 2: Featured the thread and added the date in the thread title, just so there's no confusion.

Edited by Doomkid

Share this post


Link to post

This is a great selection of maps, but I found an issue:

 

Screenshot_Doom_20200520_162140.png.5c11988824b3e1e66ddae62c3aff71d0.pngScreenshot_Doom_20200520_162139.png.473b573bfb60a5e9e6eed796399b6071.pngScreenshot_Doom_20200520_162141.png.72e124571eb440a8a79b5ef37e60c467.pngScreenshot_Doom_20200520_162140_01.png.6cbd055b763ab82768ed9969ed692009.png

 

Many of the flats seem to be erroneously animating.. I'm not sure how exactly to fix it - I've seen it before when compiling wads, but I can't remember what causes it.  I just want to make sure it's patched up before things get rolling!

Share this post


Link to post
On 5/3/2020 at 2:43 AM, DevastatioN said:

between 3 Eastern and 7 Eastern

AM or PM?

Share this post


Link to post
Posted (edited)

I've seen flats animating all crazy before while using a texture wad with a Boom Animated lump in another ZDoom-based port.   I had the 4th frame added to nukage and blood from the alpha/unused graphics.   When I deleted blood1-3 and nukage1-3 since they're present in Doom.wad, that happened.   Apparently when you have an Animated lump, all frames have to be in the pwad with it, even if your iwad has them.

 

So I think that wad needs to be recompiled while the missing frames to whatever flats are defined in Animated.

Share this post


Link to post
Posted (edited)
7 hours ago, Gokuma said:

I've seen flats animating all crazy before while using a texture wad with a Boom Animated lump in another ZDoom-based port.   I had the 4th frame added to nukage and blood from the alpha/unused graphics.   When I deleted blood1-3 and nukage1-3 since they're present in Doom.wad, that happened.   Apparently when you have an Animated lump, all frames have to be in the pwad with it, even if your iwad has them.

 

So I think that wad needs to be recompiled while the missing frames to whatever flats are defined in Animated.

Specifically what's going on is because of Doom's animation of animated flats being index based, it's doesn't explicitly cycle between each numbered flat. So for example, it animates between nukage1 to 3 by finding the lump indexes for nukage1 and nukage3, and then animates by cycling between all the indexes in including and between (it starts at nukage1, then goes to to each lump index below until it reaches nukage3). What you experienced is what happens when you replace one flat but not the other, or replace them out of order, it just keeps cycling until it reaches the other regardless of what's in between, even if the final flat is in a different WAD.

This is how some vanilla wads provide even longer animations as well, such as KDIKDIZD which replicated ZDooms flat warping this way.

Edited by Edward850

Share this post


Link to post

Say, I'd love to join in on this, but I'm having an issue where Zdaemon can't seem to capture my mouse. It seems to happen in the final build of Skulltag as well, but not GZDoom or Zandronum. Is there a workaround? Running Win10 x64.

Share this post


Link to post
1 hour ago, Smouths said:

Say, I'd love to join in on this, but I'm having an issue where Zdaemon can't seem to capture my mouse. It seems to happen in the final build of Skulltag as well, but not GZDoom or Zandronum. Is there a workaround? Running Win10 x64.

This doesn't actually explicity state Win10 compatibility, but it or a similar program should help:

http://www.snakebytestudios.com/projects/apps/cursor-lock/

 

Although ZD shouldn't be losing the cursor like that. Not sure what would be causing it.

Share this post


Link to post
Posted (edited)

Map works good in ZDaemon, no animated flats at that map there.

There is also no animdef or ANIMATED present in the pwad.

Hope to see you all later today o/
 

@Vic Vos
It is PM

Edited by Flambeau

Share this post


Link to post
5 hours ago, Doomkid said:

This doesn't actually explicity state Win10 compatibility, but it or a similar program should help:

http://www.snakebytestudios.com/projects/apps/cursor-lock/

 

Although ZD shouldn't be losing the cursor like that. Not sure what would be causing it.

 

Weird, the issue seems to have resolved itself on its own somehow. I spent a good few hours troubleshooting it last week to no avail *shrug*

 

I'll keep this software in mind though, thanks!

Share this post


Link to post
Posted (edited)
On 5/18/2020 at 1:29 PM, DevastatioN said:

WAD is fully compiled and ready for this Saturday!


Download Link: https://rhinoduck.net/kmwads/mdf_mmode1.zip

 

Don't forget to mark your calendars!  We're trying to get as many people out as possible to show how much support this community has!

Any other dir this wad goes into?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×