Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
EndHack

Need some help with building PrBoom+ on Linux

Recommended Posts

I got PrBoom+ mostly following a tutorial on youtube for editing dooms source code and it installed with three programs executables shortcuts with commands? or something im not exactly sure im new to linux so one is normal PrBoom+ and the others are PrBoom+ starting with freedoom or freedoom2 they seem to work fine but I have been building my own PrBoom+ (mostly following the video) but it doesn't have music and it crashes whenever I go into the options menu and I've got no idea why so far the biggest thing I've changed is the super shotgun and normal shotguns editor numbers which has worked mostly fine (I can't actually select it but I can pick it up off the ground and use it until I select a different weapon) as long as I include a pwad with the ssg's assets so if anyone has any idea whats happening or something I would like to hear your advice 

Edited by EndHack : link was broken

Share this post


Link to post

Could you please post what is printed to the terminal when the game crashes?

 

Also, please use punctuation! It's a pain to read through your post.

Share this post


Link to post
G_DoPlayDemo: playing demo with Ultimate Doom/Doom95 compatibility
P_GetNodesVersion: using normal BSP nodes
W_GetNumForName: M_GENERL not found
I_ShutdownSound: 

I'm assuming that M_GENERL is something important.

 

Edit: turns out the help me page also doesn't work, not that that's very important.

W_GetNumForName: PRBOOM not found

 

Edited by EndHack

Share this post


Link to post

So I was going to add

-file PrBoom-plus.wad (with its location and everything)

but I wanted to quick start up PrBoom, just to make sure I had typed out the right command, once it had started up the menu worked fine, but the only thing I can think of that I changed is beforehand I played around with the unedited PrBoom that I didn’t build, and while doing that I changed the settings in it, which may have somehow effected the one I’m building.

Share this post


Link to post

So turns out I was an idiot and typed

prboom-plus

instead of

./src/prboom-plus

and I was just using the non-modified one, also I tried just adding "-file (file path)prboom-plus.wad" and that didn't work

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×